Erratic bar rest behavior - automatically reverts from implicit to explicit

The attached file originated as an XML import from Sibelius, imported into Dorico Pro at around version 2.2 (I’m now on the latest 3.5).

(For copyright reasons, I deleted bars from the end of the file and scrambled the remaining content.)

I’m trying to set the Custom Scale property of the bar rest in bar 25 to 1% to hide it (see first screen shot). This worked in the other bars in this file.

When I set Custom Scale to 1%, nothing happened.

When I selected the rest and hit “delete” to turn it into an implicit rest, nothing happened.

Next, I went to “Note Entry” mode:

I entered a quarter note on beat 1, then deleted it. The rest remained explicit and full size, and the Custom Scale property remained at 1%.

Next, I entered a quarter note on beat 1, then extended it using shift-option-right arrow until it filled the bar as a dotted whole note.

I deleted the dotted whole note, and the rest became implicit (light gray), with the Custom Scale property disabled.

Setting Custom Scale to 1% made the rest disappear as expected.

I saved the file, then switched to Setup mode, then back to Write mode - no problem… Ditto with Engrave mode.

But when, in Write mode, I switched to the score, then back to the piano part, the rest reverted to being explicit and full size, with Custom scale still at 1%.

This happened multiple times. Restarting the computer didn’t change anything.

Back in note entry mode, I selected a dotted whole note for entry.

When I hovered the cursor over the measure, a ghost note appeared, but when I clicked on the staff to enter it, the cursor jumped to the next bar without entering a note.

With the left arrow key, I moved the cursor back to bar 25 and changed it to a quarter note. When I clicked in the first beat of the bar, it entered two notes! See the two screen shots, from two attempts…

Then I selected “undo” (command-Z), and a dotted whole note appeared in bar 25!

When I deleted the dotted whole note, the rest became implicit, and I was able to reduce its size as above.

I saved and closed the file.

When I re-opened it, (without quitting Dorico) the explicit rest returned at full size.

So…Dorico bug? Corrupt file? Both? Something else?

What can I do, aside from exporting PDFs before the rest returns?

Thanks!




Bar_rest_problem.dorico.zip (1.0 MB)

I can’t help thinking we had this conversation two weeks ago: Rests hidden in score but not in part - #10 by bobk

There’s nothing in bar 25 to break the multi-bar rest, so in the part it’s a multi-bar rest. Why not just use a bar repeat region, scaled down, as you’ve done in bars 5-7 and 9-11?

Each of bars in that example had a chord symbol; that’s not the case here, so it seemed different. I forgot about the whole multi-bar rest thing.

TBH, I had only just learned that bar repeat regions could be scaled down minutes before posting, so I hadn’t thought of it for this one bar. I tried just now, and it didn’t work in bar 25 alone, but did work for bars 24-25.

Still, if the single empty bar is supposed to behave as a multi-bar rest, it seems odd that I was able to get as far as I did in hiding it. If it’s something that’s not going to work, I would think Dorico should warn me.

Also, the note entry issue, while not a concern for this immediate issue, is concerning.

It’s good to have work-arounds, but I hope Dorico 4 gives us more ability to hide rests at a granular level.

Thanks, Leo!

Your post is ambiguous as to which layout you were working in when trying to scale the rest.

As to the note input thing, that just looks as though Dorico’s doing its usual helpful thing of splitting notes according to the meter. Nothing to be worried about (and can be overridden with Force Duration or altered globally from Notation Options > Note Grouping).

Sorry about that! It was always in the Piano layout.

Re: note input: I’m still not clear why, when I first clicked on the bar to enter a dotted whole note in note entry mode, Dorico didn’t enter anything in that bar and moved the cursor to bar 26.

Also, in the screenshots I posted, I had only selected a quarter note and clicked on the staff once when it entered two notes!

These note entries were in the piano layout, not the score.

I’m not ruling out user error, but I think I was doing things correctly…