Error saving file

I have an open project with some work I’d rather not lose.
When I try to save, Dorico gives me two messages, first: “An error occured”, second, after hitting ok: “Error saving file”.
When I try “Save as…” from the file menu, nothing happens at all. As far as I can tell, Dorico is fully operational, except for the save operation.

I don’t remember doing anything unusual inside or outside Dorico since I last saved. I excluded/included some flows from the full score layout and wrote notes.
Is there anything I can do?

Any advice would be greatly appreciated!


Could you take a look at the application.log file, which can be found here:

Take a copy of that (it’ll be overwritten the next time round you start Dorico I think), and attach here or send via email. Not sure if there is anything you can do immediately to get back to a defined state.

Also take a copy of the .dorico file as it is right now, as a precautionary measure.

Additionally, to attempt to save some work, try exporting individual flows, see if that works (that will create separate .dorico files). If that doesn’t, export as MusicXML.

And a sanity check, presumably you do have write access to the directory you’re trying to save to, and some space on the disk?

Many thanks for your quick answer, Stefan!

I’ve attached the application.log file.

I tried to export individual flows but got the same error messages.

As I’ve never done this before, I must ask a stupid question: how do I export as MusXML? Is this something you do in the “Save as…” dialog? This dialog doesn’t appear right now. I haven’t found any MusXML option anywhere else except for the import dialog – but I may be missing it.

I do have write access and enough disk space. I can even confirm that Dorico has write access because I’ve successfully exported an audio file.

When I first wrote, I didn’t think about this: Right before I started working in Dorico I enabled crash logs in the Windows registry (following the steps described in the FAQ thread). I’m not sure, but it’s possible that I executed the registry key while Dorico was already launching. Could this have something to do with it? It’s the only unusual thing I did that I can think of.

Is it a good idea to start a new empty project, copy the changed music there and try to save this project? I hesitate to do so because on my machine Dorico has crashed a few times after I opened a second file (or accidentaly hit Ctrl-N). (13.1 KB)

I had a look through the log file, but that all looks very normal, nothing unexpected up to the point where saving fails.

Exporting as MusicXML can be found in the File/Export (a few entries below the save menu). The lowest entry in the submenu is for exporting flows as a new Dorico file (which you said failed too?). The first entry will create MusicXML files. Note, you may lose some aspects of the notation there (particularly anything adjusted in engrave mode), but the musical content will be preserved.

One other intermediate step you can try is, in Play mode, Play menu, ‘Apply Default Playback Template…’, just in case it is any audio engine data that fails to save.

Once you have done those exports, and tried export flow again too, then you can certainly create a new project, set up the players, and copy paste everything across. If it crashes (I certainly wouldn’t it expect it too, but I also don’t expect it being unable to save), then please also take a copy of the crashlogs (in %LOCALAPPDATA%\CrashDumps) and send those to us.

The Dorico file format is basically a zip file (eg if you rename one to then you can look through it in Windows Explorer), and when you open a file then Dorico unzips it to a temporary location and then opens it from there. When you save, the individual files get written back to the same temporary location, and then zipped back up. It’s possible that the score is being saved, but some error is preventing the audio engine data from being saved, so we may be able to recover the score.

Try this:

  • Try saving again (which we expect will fail again)
  • Open the folder C:/Users/FLORIA~1/AppData/Local/Temp/Dorico/ocfsessions/session-a873/f0b8-b476-890f-5d49 (that’s the temporary dir I can see from your application log)
  • Look at the modified time of the files score.dtn and scorelibrary.dtn (you might need to show Details in explorer, or right click and choose ‘File Properties’). If the time of the file is the current time then that means that the main score data saved successfully. If that’s the case then take a copy of this whole directory somewhere safe (because Dorico will delete it when you exit).
  • You can now zip up the directory and rename to .dorico (you do have to get the directory in the right place, so if you’re not sure then either upload the zip here, or if you don’t want to share it publicly then send me a private message)

Good luck

Thank you, Stefan and Paul, for looking through the log file and for the additional advice!

Applying the default playback template didn’t change anything. I tried to save again and looked into the temporary folder. Unfortunately, the time of the score and scorelibrary files is 19:25, which is about the last time I managed to save successfully.

Then I opened a new project and copied the music there (no crash). But, funnily, in this new project, Dorico doesn’t react at all when I try to save or “save as…”.

But, this is weird: over here the export submenu looks like this – no MusXML to choose:
I guess I will have to input the flow again. Never mind, it’s not the end of the world.

Thanks for your support again! At this time of day… it has been said many times on this forum, but the user support of the Dorico team is truly astonishing!

If it’s not too late (before you’ve exited), one last thing to try, to see if we can work out what’s preventing it from saving. Download Sysinternals Process Monitor from Microsoft, then run it and press Ctrl-L to bring up the filter dialog and then set the top fields to:

[process name] [contains] [dorico] then [include]

and press ‘Add’ and then ok. Then switch to Dorico and try to save. You should see some activity in the Process Monitor window, and one of those entries may hold the key. You can then do ‘File Save’ and upload the file here or send to us.

I’ll try that tomorrow. I left Dorico open for the night.

Here’s the logfile I saved from the process monitor after trying to save in Dorico.
I hope it helps to find out what’s going wrong! (540 KB)

I’ve been trying to dig into the log file, and can see when it’s reporting the error, but unfortunately I can’t see why it’s failing, so at this point I can’t suggest anything else to retrieve the score data, sadly.

I would recommend rebooting and doing a disk check, as it’s possible that something on your system is in a strange state. Then try starting Dorico again and try opening and saving a project to make sure things are working again. I

Thanks anyway!

I did a reboot and Dorico saves happily again. And I was able to export most of the notes as MIDI before I exited so it’s not all lost.

I did a disk check but no errors were found.

Two funny things, I don’t know if they’re at all related. Just in case this helps to narrow down the culprit:

  1. When I open Dorico now, the MusXML option is again where it should be in the export submenu. (You can see on the image I posted yesterday that it was not there in that session.)
  2. I did a registry check and an error was found concerning the file extension .dtn, saying this extension is unused.

Continue your great work!

I’m glad that you didn’t have any substantial data loss.

If the menu item was in a strange place then that suggests that some magical powers were at work (I have no idea what). That could have explained the odd behaviour with saving. Perhaps a system update had some strange effect.

Don’t worry about the .dtn warning – that’s an internal file format used by Dorico. It isn’t registered globally as you can’t open those files in a meaningful way.