even distribution of staves across 2 pages?

This is driving me nuts! I’ve removed page numbers and player names and various un-needed bits. I now have a score that looks terrible - why is the second page so different in layout to the first? I’ve tried everything I can think of in Layout but can find nothing to “auto” distribute the systems evenly, even if it means leaving a space at the bottom, which is fine, I just cannot see how to do it. ELEMENTS please not Pro…


I don’t think there’s a way to auto-distribute staves evenly, because variations in the music (particularly high/low notes or stacked notations etc) mean different staves/systems tend to require different amounts of vertical space.

You can set a fixed casting off value, e.g. if you have 20 systems total, set this to 10 systems per frame. You can also handle this manually by inserting a frame break at the start of the system you want to be at the top of the 2nd page. Alternatively, you can tweak your vertical spacing settings, but that’s less directly to produce the direct results you want as quickly.

(In general, removing or hiding information in text frames outside the boundaries of music frames won’t cause Dorico to recalculate spacing, as that’s determined within music frames. I know you can’t see those in Elements, but your best bet to managing how music music fits on the page is to look at the vertical spacing settings, casting off, the music frame margins, the page margins, and the staff size.)

Thanks Lillie, that worked, setting the casting off per frame. Brilliant, I can can continue now!

Hmmm, slight flaw - so when I put 7 systems per frame in, it puts 7 systems on the first page (and that includes allowing for the title etc) and 6 on the second page, where there is in fact more room as there’s no title - which seems counter-intuitive - BUT, when I go to export PDF mode, it shifts to 7 and 5 - so it’s shifting the bars per system. If I put 6 systems per frame then I get an additional page which I don’t want - with just one system at the top. Seems to be a conundrum - but why is it shifting bar layout from “write” mode to “print” mode - surely it should remain the same?

I imagine if you only have 13 systems, it will cast off following your settings (7 systems per page) until it runs out of systems. Perhaps use a couple of system breaks to make sure you’ve got the right number of systems?

In Print mode - are you definitely viewing the same layout? Print mode displays the layout currently selected in the panel on the left, not from the layout selector in the toolbar at the top (that should be greyed out).

My bad - partly - I was forgetting that going to the Print section didn’t follow the layout I was working in. However still wondering why there are more systems on the lead page where the title takes up the space of a system.

There should also be an option accompanying the casting off setting that says “Scale according to frame height” that generally knocks a system off your setting on the first page to accommodate for the extra title etc.

Aha! That’ll be the one I un-ticked in my various attempts to get a layout that worked, and in fact re-ticking it has made a difference, thank you for your patience!

Lillie, is using Layout Options–>Staves and Systems–> Casting off → number of bars per system the only way of controlling how systems are displayed in Write mode?

Thanks . . .

No, you can use system breaks and if you have Pro, making into systems. That works on a local level.

The Page formatting chapter of the manual is at your disposal.

Thanks, Lillie. I haven’t dared delve into Engrave mode yet, and so wasn’t looking at anything in the manual there. But I will . . .

. . . before I do, tho’: do the operations described in Page Formatting apply equally to Write and Engrave modes?

What you see in Write mode > Page View should match what you see in Engrave mode.

Layout Options can be accessed from any mode - type Cmd/Ctrl-Shift-L.

There’s a bunch of page formatting stuff (such as fiddling with frame sizes and padding, whether on the master pages or individual pages) that you can only achieve within Engrave mode. Those changes will be reflected in Write mode > Page view, though.

Thanks, pianoleo!

Is there a general practice that users employ regarding this – that is, do most begin in Write mode and only later finesse layout in Engrave (with the formatting options you’ve mentioned)? Vice versa? Or does everything depend on the type of project and personal preference?

It really depends on the project. The separation of modes intentionally runs Setup > Write > Engrave > Play > Print, but the separation of Write and Engrave modes is, I think, more about making it easy to focus on writing without worrying about engraving, and on engraving without the risk of accidentally changing the substance of the music.

Thanks . . . I think that order was what I was intuiting, too. However, without any interventions, Write mode’s way of displaying bars per system can be truly chaotic, hence my questions.

I suppose if you’re using the fixed casting off settings with an unsuitable combination of staff size, page size and density of content, yes!

No, I wasn’t using any intervention at all. As I input more music, Write can sometimes decide to suddenly give two (sparsely populated) bars an entire system while simultaneously cramming another six bars into the next system. Pretty strange. . .

Ah. When your flow’s particularly short this can be an issue. Unless you’re in the habit of writing very short flows, don’t worry about it!

Thanks again!

In general, the manual will state if you have to be in Write mode or Engrave mode in the first step. If you can be in either, in the Pro manual you’ll see that too. Doing things in the big 5 options dialogs can be done in any mode if you access the dialog using the key command.