Expression Controller Is Navigating around Project Window!

Hi

Could realy do swith some help on this.

Sometimes when I record MIDI data in the project window, and use CC11 (expression) as part of the performance, the selected track changes during the record process. Basically, it’s as if cc11 is acting like a cursor control and is moving the selcted track up or down in the Project Window.

Is it possible that I have some option active, which enables external cc events to navigate around the Project Window? It’s starting to become a real pain, as half the time I’m finding I’ve recorded data onto the wrong track.

Thanks for any suggestions

Jules

That reads like, somehow you have CC#11 controlling an element in the Generic Remote Device (Devices menu>Device Setup)

I’m getting nowhere with this issue. It is happening every single time I record. It’s actually not limited to controller info - the same thing happens as soon as Cubase receives any MIDI input, note data, MIDI cc etc.

I’ve checked my remote device setup, and there is nothing there set to respond to any of the controllers I’m using or note data.

Here’s an example that I can rerpoduce 100% reliably. I have two tracks. Track 1 has a single part on it. Track 2 has nothing on it. I select the part on track 1, then I select track 2. The part on Track 1 is still selected, but it’s track 2 that is record enabled, and Track 2 that I want to record onto. I hit record and during the count-in, as soon as any MIDI data is sent to Cubase, it jumps back up to track 1 and start recording on that track.

I presume this means it is trying to record into the selected part? Is there a preference somewhere I can change to stop it from behaving this way? Or is this a bug?

Thanks for any help.

Jules

Normally, as soon as the count-in is finished, that selected Part on track #1 should de-select (even if you don’t send any MIDI data).
Is that working ok, at least?

Yes, if I don’t record anything and just let Cubase run, then the selected part is deselected.

However, if I send any kind of MIDI data, the selected track jumps back to track of the selected part. It actually records into a new part sitting on top of the existing part, but on the same track.

I hope that makes sense.

Jules

Try inserting the midi monitor on both the tracks to see what is passing through them. It might shed some light on the problem for the gurus here.
another question is - where is your midi data coming from? A VST? external synth or controller?
Must say I’m stumped at this point in trying to offer any help
Neil

Hi Neil - thanks for your help.

Midi info is coming from an external MIDI controller (CME VX8). Will try the midi monitor idea when I’m back in the studio on Monday.

Thanks again.

Jules

Does it jump tracks when you simply play from your external keyboard (and when not in Record)
(I’m still suspecting your Generic Remote Device(s) :wink:

Yes, it jumps with ANY kind of MIDI data including MIDI note data.

No, it only ever does it when I’m recording - never does it when I’m just playing back.

It’s totally reproducible here (as described above), and so far totally insoluble.

That wasn’t my question :wink:. I asked if it happens when you are playing live into Cubase without it being in Record (not talking about “playback” here :wink: )

Sorry Vic. The answer is the same - if I transmit MIDI data into Cubase at any time time than when it’s recording, it does not exhibit this behaviour.

Jules
http://www.trailermen.com

Do you, by any chance, without telling us, also have a MIDI Editor window open at the time?

I often have the Key Editor window open if that’s what you mean.

You mention “without telling us”. I can assure you I am not trying to mislead anyone or hide any information here Vic, so if I have failed to mention anything, it’s because I assumed it was irrelevant.

Jules

I wasn’t accusing you of tax evasion or anything! :stuck_out_tongue:
Don’t forget, we can only build up a picture of what is going on, from what you actually tell us :wink:.
And, in this case, if a MIDI Editor window is open (presumably, opened from that selected MIDI Part), if the MIDI Editor window has the focus, it will become the record enabled track. However, if the focus is still the Project window, this shouldn’t happen, and the selected track should remain record-enabled.

Ok Vic - no worries. I hadn’t realized that I had other windows open might change things. I’m just working in the Project Window, with a MIDI editor open on my 2nd monitor so I can quickly make edits when I need to.

However, although the MIDI Editor Window is open, and there is a part selected, when I am recording the Project Window has focus (100% for sure) and an empty, record-enabled track is selected. NOT the track with the existing part on it.

I think you’re onto something here, because Cubase jumps back to the track with the selected part on it (ie. the part displayed in the MIDI editor). This seems to suggest that there is something broken with regard to how Cubase is interpreting which track is in focus. Out of interest, are there any settings you’re aware of in preferences which might enable me to work around this?

Thanks for all your help. Hopefully a moderator might refer this issue to the devs, assuming we haven’t missed something.

I did look for some Preference that could affect this (didn’t find anything, though).
I am just wondering if this particular behavior is slightly different between Mac and PC (as regards focus). Here, on Mac, so long as the project window has focus, the record-enabled track remains the same, even if there is a selected MIDI Part on a different track, with its MIDI Editor window open.

… of course, one very quick test, would be to close the MIDI Editor window, see if the problem still occurs :wink:

Good thinking…

I just tested it, and having the MIDI Editor window open or closed makes no difference - it does the jumping track thing both ways. Back to the drawing board …

Another, just for testing purposes…
Devices Menu>Device Setup>Remote Devices (I don’t know what you will have in there, but, go through every item, including Quick Controls) and set the MIDI Input for each Remote Device to “Not Connected”

I had already checked the Remote Device situation, but just checked again, and MIDI input and output devices for both VST and track Quick Controls are set to ‘Not Connected’.

You could be correct - maybe it’s just a PC thing.