Expression Maps MIDI Channel Reset

I’ve been setting up a simple Expression Map to control Hollywood Strings articulations on one track using MIDI channels.

It works fine, the main problem is when I press stop in Cubase the articulation always reverts to slot one in my Expression Map.

This doesn’t affect the parts I’ve already recorded but it’s annoying when I’m trying to compose and the articulation keeps changing from the one I was using when I press stop.

I’ve searched through posts here and some suggest adding an empty slot in slot one, but that doesn’t solve the problem, as the articulation still changes when I press stop.

Is there a way to stop the Expression Map from resetting on stop, or this something we have to grin and bear?

Hi,

In the Expression Map Setup, there is a check box: Latch Mode. The Tooltip of this checkbox says: “Deactvite this option to return to the default sound slot when releaseing the remote key.” Is this option enabled or disabled in your Expression Map? Could this solve your issue?

Hi Martin, thanks for the reply.

If I disable Latch Mode, then I need to keep my finger pressed on the articulation keyswitch for it to be enabled, it resets back to slot one when I release my finger.

With it enabled, it at least sticks with the selected articulation, but then resets to the first slot when I stop playback or record.

OK, then this function works as expected. :slight_smile:

To me it doesn’t jump to the 1st slot after stop. But it jumps to the 1st slot, when I go to Zero (beginning of the project). What about your Preferences > Transport? Do you have “Return to Start Position on Stop” enabled or disabled?

Then I’m thinking about the Preferences > MIDI. What about your “Reset on Stop” settings, and “Insert Reset Events after Record”? Are these disabled or enabled?

At least that’s working as it should :slight_smile:

Preferences > Transport? Do you have “Return to Start Position on Stop” enabled or disabled?

This is disabled.

Preferences > MIDI. What about your “Reset on Stop” settings, and “Insert Reset Events after Record”? Are these disabled or enabled?

Both of these are also disabled.

Two comments, if I may :wink:

  1. “Latch” only has relevance while actually playing (live) or recording… has absolutely no consequence on playback.
  2. Normally, it is sufficient to create a “blank” Slot #1, in order for the return to Slot #1 to be without consequence… with the unfortunate exception of when using Expressions Maps for MIDI Channel change… even with a blank slot #1 any played notes now revert to the MIDI channel as set in the MIDI track itself (rather than remaining at the last one transmitted by the Expression map). No way around that one, I’m afraid :wink:.

Oh dear, that’s a pity.

Well thanks for your help anyway guys.

Why the latest slot stays selected on my system, then? A “lucky” bug? :slight_smile:

Depends where you stop :wink:… for “direction type”, it should hold the last articulation until the end of the MIDI Part, then it reverts to slot #1, and for attribute type, similar, but last articulation only till end of last recorded note, then back to slot #1.
EDIT: Slight correction…
for attribute type, if you stop anywhere where there isn’t actually a note still playing, it will revert to slot #1. (in other words, reverts to slot #1 at the end of every note… and not affected by “Latch”, I promise you :wink:…, until it encounters a new articulation).

Or, writing this another way :wink:
Direction type articulations…
There is always an active articulation until the end of the MIDI Part (even if it is slot #1), so, stop anywhere during the MIDI Part, and the currently-active articulation will be held. Stop after the end of the MIDI Part, and it reverts to slot #1.
Attribute type articulations…
Stop anywhere during a recorded note, and the articulation for that note is held. Stop during a silence between notes, and it reverts to slot #, as it also does if you stop after the end of the MIDI Part.

Please add an option to maintain the expression map on stop. This is very frustrating when working on a part. And I really do not want to add a blank slot to each of my 109 (to date) expression maps.

It is already the case.

I read this (“old”) thread quickly, surprisingly it doesn’t seem to have been already mentioned though this is the first thing to check (or did I misread ?) :

Preferences>MIDI : “Never Reset Chased Controllers” option should be checked, in addition to “Reset on Stop” unchecked, and in addition to what Vic said about Direction and Attribute articulations.

Has anyone found a solution for this? I have the exact same problem.

Same problem here, is there no solution ?

Bump. This suggestion did nothing for me; upon stopping my recording, the track always resets to slot one in my expression map.

I’ve recently switched to Cubase (coming from Logic) and this “bug” was also driving me absolutely INSANE. I came up with a solution… using Keyboard Maestro, I created a few macros to automatically retrigger the last selected expression map each time after the space bar is pressed. There’s probably a more elegant way of programming all this, but this is what I came up with:

1.) First, you’ll want to create a series of macros that listen for incoming midi keyswitches, which then set that note value to the variable “LastArticulation” (see screenshot)

2.) Next, you’ll create a separate Keyboard Maestro macro that basically says… "every time the spacebar is pressed, send out a midi keyswitch using the variable “LastArticulation” (see screenshot)

Hopefully y’all with find this usefully. And seriously Steinberg, get your act together…this should be basic stuff that’s integrated into your DAW!
KM - Retrigger Expression Map.jpeg
KM - Listen for Incoming Midi keyswitch.jpeg

Good work around, unfortunately, it seems to be mac only. My work around is using a midi keyboard on a single note/hold/arpeggiator so that the midi note sent to the expression maps is simply repeated super fast.

This has the bonus feature of If I want to make on the spot legato ensembles or staccato tuttis, I simply need to hit the legato or staccato relative key on the keyboard and then ctrl-select the multiple instruments and they all switch to the same articulation. Your maps need to be standardized to do so but it works pretty well.

Last but not least is filtering the midi notes at the input so that out of range notes of each instruments do not end up in the piano roll hen I play wide chords on an all brass of strings ensemble. That way I can record a piccolo and a double bass simultaneously for exemple without my left hand recording silent midi notes in the piccolo’s midi event and vise versa.

I still can’t select pizzicato on the bass and legato on the piccolo with the my technique unless I stop the arpeggiator and then I get the same issue so we still need a fix for this midi channel reset on stop. Is there an alternative to Keyboard Maestro on Windows?