External Instrument Automation issue in Cubase 11 and 12

Hi guys, help needed from External Instruments / MIDI experts here as I’m completely at a loss.

I have recently moved from Cubase 10 to 11/12 and have come across this bug when using external instruments which is really frustrating as I am not able to record automation properly.

In C10 I was able to control Minitaur Editor (it’s an Insert FX plugin) using the hardware itself. Any physical changes on the unit would affect the editor and the automation would be recorded on the separate lane - in the example below I used cutoff knob on the hardware which would correctly create an automation of the cutoff parameter in the Insert plugin (editor). Same if I used a mouse to move the knob within the editor.

In C12, however moving the physical knob creates an additional lane for Midi CC19 and even though the knob within the editor moves, it doesn’t actually record the data for it. And I end up with two separate lanes (one controlled by the physical hardware knob and the other one by the software version) and when it comes to playback they literally fight with each other.

Same project, same settings but in Cubase 11 and 12 my external instruments just no longer behave as they should. I also have Minilogue XD synth with a 3rd party editor which again worked perfectly fine in C10 but fails to record the data in C11/12.

Anyone experienced this before? Has something changed with version 11 in terms of the way Cubase deals with incoming MIDI / CC data? It appears the MIDI data is no longer carried over to the editor itself. Anyone here with Minitaur able to reproduce this issue?

Ps. The only ‘workaround’ I found is to manually create a custom MIDI Remote script in Cubase 12 and assigning the hardware knobs to controllers within the Insert editor, but would rather avoid spending hours on doing this for Korg Minilogue XD.

PS. 2: I’m on Windows 10, the devices are connected via USB-Audio.

See from the top menu MIDI/CC Automation Setup.

Could this be it?

Did you check all the setting of the MIDI device corresponds to the external instrument?

Did that hardware device come with separate pieces of software (often in the Components folder of Cubase)?

If yes, maybe something needs to be copied from the Components folder of the older Cubase version to the current one?

Another thing to check might be that the device in question is NOT included in “All MIDI Inputs”?

The settings may be different because each version of Cubase has its own folder for user-specific settings.

It looks like in v11 and 12, Cubase is detecting two sources of automation, one is coming directly from the hardware as MIDI and the other as binary data stream via the plug-in. What happens if you set the MIDI inputs of the instrument track to none? Is the plug-in automation still getting written?

Yes that’s exactly what seems to be happening. Midi data from hardware is getting recorded but not passed onto the plugin itself (well it does as I can see the knob movement in the editor but it doesn’t trigger its automation recording). The only way to record the binary data stream from the plugin is using a mouse, but it used to be possible to use the hardware knob. If I set the MIDI input to None then there’s no automation for the MIDI data, but I can still record the plugin automation by hand / mouse.

MIDI-wise, I remember one change in Cubase 12— WinRT MIDI. You may experiment with those settings to see if they make any difference.

Check the MIDI filters (Edit > Preferences > MIDI > MIDI filters) in your C10 and C12 installations whether they’re identical and no MIDI feedback loops occur.

Also check the Minitaur USB Driver on your PC, including its firmware as per Editor Manual.

If nothing works, there may still be workarounds such as applying specific MIDI filters or the Input Transformer to sift the conflicting MIDI.

Best of luck and let us know how it goes.

Also check the MIDI device setting. When you create an external instrument, you have created a MIDI device (you can’t make ext. inst. Without one) and there is plenty of settings. That might differ from the old version.

Thank you for the suggestions guys but none of them worked unfortunately. I even tried installing C12 and C10 on a brand new Windows 11 laptop and it’s the same scenario so I’m inclined to believe something has changed in the Cubase architecture and 3rd party VST plugins for external gear no longer talk to Cubase. I have actually found a couple of older posts with similar questions but no resolution so far. I’m gonna try and test it on Mac OS next week as well to see if it is OS related. Might do a short video as well. Really gutted as it now means recording live automation from an external gear is just not straightforward at all.

Not sure, if you saw my earlier post

Did you compare the Components folder of your Cubase 10 vs Cubase 12 installations?

I’ve often found that I had to manually copy some of the 3rd party hardware supporting files from the older Cubase installation to the newer one.

As long as the old one’s were also 64 bit, they have kept on working for me for a long time after copying them to the newer Cubase installations.

Yes tried that, no luck :frowning:

I have just recorded a short demonstration in both versions using both of my synths.