Extremely high energy usage. Dorico 3

Is this issue already fixed in Dorico 3.0.10? When I put videoengine.bundle back, where I deleted it from, I experience the same performance issue as before while playing my scores back - CPU usage quickly grows till 100% or more…

Unfortunately not. Our video team has to tackle several issues at the moment, and they have not had the time yet to look into this issue. So please have a bit more patience. Many thanks for your understanding.

I’m having a CPU usage issue too specifically and only during playback, CPU usage from Dorico goes from 0.1% to over 97% with glitches and hiccups happening. It only happens during playback and when moving/inputting notes (it may be because I have it so it plays back notes when editing them). I believe my issue may be caused by the exact same thing described here (the video engine of Dorico 3 causing issues). I have many instruments since it’s a big template but I’m not even using half of them, happens when using the string section (5 instruments sending basic long notes). The VSTi aren’t even hosted on the same computer (they are hosted on a separate slave machine) and neither Cubase, MAX (both on the Dorico computer) nor the slave machine itself spike in CPU usage as Dorico does and Dorico is the only program getting sluggish and buggy.

I’ll try deleting the mentioned file and see if it helps.

Deleting the video engine file definitely helped with CPU usage, at least from my early tests. Average 40-50% usage now, and works way better.

Do you have a small buffer size? If so, try increasing it. Smaller buffer sizes increase the CPU load.

Hi Paul. No, the issue is independent of buffer size, I’m aware of the setting and how it helps the CPU usage but even with the highest buffer size the issue happens. As I mentioned, deleting the video engine related file helped and reduced the strain on the CPU by a big margin so I believe that may be the cause. As I said I have other programs opened on the same computer (like Cubase) and only Dorico is the one that had that huge spike (Dorico sends MIDI to Cubase’s armed MIDI tracks, no samples are hosted on either of them, only MIDI being sent and Cubase receiving audio from another computer but even then it happens when using very few tracks [so little audio is being received by Cubase and it’s not resource-intensive] and Dorico is the program with the spike, not Cubase; all glithces and hiccups are from Dorico’s MIDI mainly from what I’ve seen (the MIDI messages get omitted and cut because of the high CPU usage). And yes it happens when Cubase also has the highest buffer size too because the problem originates in Dorico (I can see the CPU usage in the Activity Monitor of the computer [Mac].

I’m on the the latest Dorico 3.1.10 / Mac OS 10.15.3 and seems the videoengine.bundle may be the cause of the CPU spikes I see the Dorico process take when playing back. I had previously sent an email to the Dorico team to report this but thought I would post my new findings here as well.

With the videoengine.bundle in place inside the Dorico app / Components folder, running playback shows Dorico process using around 120% + VST Audio Engine running 30-40%

Quit Dorico and move the videoengine.bundle to my desktop.

Launch the same project and playback VST Audio Ending is the same (makes sense) and Dorico process is 17-18%

Yes, this issue is ongoing and is not yet solved. The video engine team are aware of it, but at the present time there’s no ETA for a fix, I’m afraid.

Is it safe to move the video engine.bundle to the desktop? I don’t use the video part of Dorico, so this might be the temporary solution (I too, have the CPU running off the charts). But, I don’t want to mess things up by taking this action. Advisable, or no?

I’ve moved the video engine.bundle to my desktop, and everything works fine.

From Dorico’s point of view, yes, no problem to remove it from the bundle. Might become a code signature issue on OSX Catalina, because you mess with a signed bundle. So you need to try it out on Catalina, if it still starts up fine without the videoengine.

In terms of moving the video engine.bundle - copy it to the desk to, then delete? Moving it seems to only create an alias on the desktop. I’m missing something…

Moving it seems to only create an alias on the desktop. I’m missing something…

Yes, there is a special way to move it, but I can’t remember how I did it - sorry! This may work: in the Finder’s Go menu, option-click and hold to show the Library folder. Navigate from there to the video engine (I can’t remember the path right now), and then you should be able drag the video engine file to the desktop. FWIW I haven’t deleted it.

I am using MacOS Catalina, and moving the video engine hasn’t been a problem.

You may not be able to answer this, but assuming this doesn’t get fixed until closer to the next version of Dorico later this year (which I understand will be some type of paid upgrade), is this type of bug/issue one that would still be ported to Dorico 3 as well?

It’s hard to say. It really depends on the nature of the fix, when it eventually comes. At the moment I have no visibility of the relative priority of this issue with the video engine team, or what kind of changes might be required to fix the problem, and whether that will have any knock-on effects on the host applications.

My assumption: If not removing that bundle but only using APFS file permissions to block access to this bundle, it may help with certain possibility.
Anyone wanna try it?

You can remove the video.engine on Catalina with no problems. (Well, I’ve not seen any…!)

How does one remove the video.engine? Dragging it to the desktop only creates an alia, with the video.engine still in the folder.


Maybe a future version could have a setting to disable video.

Do a right-click on the item, a pop-up menu appears. From that choose ‘Move to Trash’ and it goes to the bin.