Feature Request: ReWire/MTC

Didn’t work for me at first (Windows 10 here). I had it setup in an older project. Killed the TXL instance, started a new one and reset the virtual port connection and all, and it worked. Worth a try?

…Alsmost… I see the the timecode TXL20 plugin is now sending data through loopmidi. But Cubase is not starting. “Activate External Sync” in cubase is on.
In Cubase Studio Setup → MIDI Port Setup → TC2DAW IN is active. I deactivated TC2DAW OUT.

I ‘armed’ Cubase by pressing the Record button. Is this necessary at all?

The start Dorico, but Cubase does not respond. What am I missing?

It is also strange (?) that the timecode (in the plugin) only starts running when dorico is already playing music for 10 seconds (see sceendump).


Sync-MachineControl
Sync-LoopMidi
Sync-Dorico-TXLtimecode

I just tested with MidiOX.

This confirms that Dorico, through the TXL timecode plugin sends data to loopMIDI (which shows an increasing Total Data), and then to MidiOx, which detects MTC (as you can see in the Monitor output), and also the MTC Transport is running (but starts after 10 seconds).

Still no clue why Cubase does not start when I hit play in Dorico.

Hello,
see this topic: I made a description with voicemeeter, TXl cubase and Dorico

I posted a lot of printscreen .
BUT: TXL MTC is great to put Cubase as slave and Dorico as Master but if there are tempo changes in Dorico , Cubase will play a but the tempo will not change!!! so the number of the measure and position in the measure will not be adjusted!!
Dorico don’t send any tempo information and we can’t copy tempo variation from Dorico to cubase with copy and paste. The export tempo from Dorico can’t be open in Cubase. (I don’t think that dorico 5 is improved in this domain, I use D4)
Dorico is very closed in on himself at this level
Hope it can help you.
Best regards

Give these things a try.

  1. Make sure Dorico has an ASIO audio output connected somewhere, even if you’re not really having Dorico host or play sounds. Better if it’s the same audio device Cubase is using (even if it is some unused set of outputs somewhere in the audio matrix). Dorico and subsequent plugins needs a proper clock from somewhere…

  2. In your transport bar: Disable the tempo track in Cubase, and try setting the time display to the time-code mode. For me, all of the time display modes are working but I’d give the TC display a try anyway. Really, when Dorico is ‘master’ it’s what you should be paying attention to anyway.

Of course, make sure you have external sync activated in Cubase.

Correct. Cubase is locking its transport to ‘time-code’.

You want Dorico to IGNORE ‘tempo’ anytime Dorico is serving as the Master and you are doing precision recording work.

If you want the grid in Cubase to be more in alignment with what is happening in Dorico, export a MIDI tempo map from Dorico.

Dorico will generate a MIDI file.

Back in Cubase, put your cursor at the beginning of the project. Import the tempo track Dorico exported as a MIDI file.

Cubase will ask if you want to create a new project. Choose No, and locate the tempo map you’ve Exported from Dorico.

At this point, make time signature and tempo tracks in Cubase if you don’t already have them. You should notice that it now matches Dorico. Tempos, time signatures, etc. Your grid in Cubase should make a lot more sense in relation to the score over in Dorico.

If a matching grid is important to you, then you’ll need to manually update this from time to time as your project grows.

Note…anytime Dorico is serving as the Master, when ‘recording’ in Dorico you might want to keep this ‘tempo track’ disabled if you run into trouble (Experiment, might can keep it enabled, but the time code display will be far more ‘precise’ I think?).

Make sure ‘External Sync’ is active anytime that Dorico should be the Master.

Oh, I almost forgot!

Launch your Steinberg Download Assistant to check for any possible Dorico updates. I’m pretty sure there has been at least one ‘hotfix’ for Dorico 5.

Thanks…
I Don’t remember if it was okay for what i wanted to do.
It seems to me that as my project contained many flows with licks for saxophone that I wanted to replay in Cubase, the export of the midi tempo was not a single file but as many flows and then they had to be merged?!! I had given up on the idea!! Can you confirm that?
best regards

Brian,
Thanks for your extensive explanation. Danial, from Dorico, provided me with a hotfix. But didn’t seem to make a difference. I did setup using the exact same steps as you describe. Didn’t work. However, I now changed from 30fbs to 24. Now Cubase also start. Strange, since I did match these rates in Dorico, the plugin, and in Cubase.

Now the only issue is that the Cubase (and the timecode plugin in Dorico) start only after playing 10 seconds in Dorico. Although, I can set the offset in the plugin to fix this, I don’t understand why this is happening?

If you have several flows to work with, as in, different movements to the piece, I think you can append the tempo tracks in Cubase if you tick “Import to Left Locator” in Cubase Preferences/MIDI.

Set your left locator to where the next tempo track import should begin and it should ‘append’ to the track accordingly.

Where precisely should that left locator go? I’d have dorico send some kind of cue or something that you can ‘record’ in Cubase to get a precise mark. I.E. direct the first note of the first instrument that plays into Dorico over MIDI. Record a few bars in Cubase. Set the left locator exactly where that note falls and see how that goes.

Does Dorico ‘reset’ the clock with a new flow though? If it does, then I’m at a loss as to how to proceed for now. I’m thinking you’d do each flow in a separate Cubase project, and perhaps later you could render Dorico audio output (if you’re using that) and combine things into one massive Cubase project.

I’d grab the latest TXL plugin and reinstall it.
Version 2.1.0
Be careful that you’ve got the latest one.

If that one doesn’t work, maybe try 2.0.2

Versions older than these, you must manually make an offset in Cubase (Project Settings), as I’ve described way back in this thread (or a similar thread if not this one).

Here’s the link for all the versions if you need it:
Downloads - TXL20

I already tried both versions. Now use 2.1.0.

I only have a single flow. In fact, just a few tracks with spitfire instrunts loaded, to see if I can get it to work.
a

@Brian_Roland
Thank you for these explanations!
But I think I no longer have the courage to test (I have already done enough tests and finally I no longer use the flows for these reasons) and I must say that I got a little tired of all these workarounds in this software that unfortunately I can’t memorize without looking in my notebook.
I have also neglected this software a little for lack of rapid productivity from me in using it and obviously of all the requests that interested me, visible and requested in this forum, many have been put aside for some time in favor of things certainly more essential for other users. So: wait and see
Thanks again for taking the time to respond
best regards

Have it all working now. Dorico and Cubase perfectly in Sync with help of all your input. Based on my current knowledge I have added a post about this to my own website. In case of errors, just let me know. Still learning…

2 Likes

Hi everyone, I would love to get the timecode TXL20 plugin sync method working between Dorico and Pro Tools.

Would anyone have time to write me a clear set of instructions to implement it? If so, it would be much appreciated! If not, I’ll just keep tinkering tomorrow.

Just wanted to add that this is working very well with Studio One Pro V6