First impression & problems

I point out some things that I noticed after a couple of hours of testing:

Device-AudioSetup-Buffersize: it stays fixed at 16 (although I can change the value from my sound card - presonus studiolive 24R).
By changing the buffersize on the Presonus control panel I get a sound delay by increasing the buffer value, but no improvement in crackling and cracking

With the same VST insturments inserted in a layer compared to Cubase 12 with the same sound card and with the same settings, VST Live is unsusable for continuous cracking and crackling (omnisphere 2.8.2c with Keyscape library, a sound loaded LA C7 Grand Piano)

The same performance problem occurs when I load a very simple sound on Halionsonic (not SE), in a new layer.
Continuous creaks and crackles

In Edit> Preferences it is actually possible to change the buffer size from the drop-down menu, but it is not “remembered”, if you exit the window and re-enter it shows “16” again

A VERY important thing, you have to allow you to remove BARSPACE from the play / stop transport, because when you are looking for a sound in the library of a plugin, pressing the space bar will start the playback, crashing the program.

Similarly when you are looking for a sound and press the letter “e” on the keyboard the plugin window resizes itself

I would like to be able to move the layers freely up / down for better programming

Thank’s for your job

1 Like

Device buffer size can often only be set in the devices’ control panel. It depends on your system (Windows? OSX?), and hardware. Changing the buffersize to higher values increases latency but should reduce spikes in CPU load. How does the CPU load display read (bottom left of VST Live)?
VST Live itself should not use significant CPU when you start an empty project, correct? Then it’s down to finding the culprit (what happens when you add which plugin or anything else).
Btw a buffer size of 16 will hardly work on any regular system, not even if you have a very fast computer, because the reaction time from when audio hardware wants to start processing until VST Live (or any other audio program) gets notified gets significant then. That timespan is jittering, and determined by the Operating System and audio hardware driver capabilities, which only marginally depend on CPU speed.
We have heavy loaded systems without crackling, so it would be good to find out what causes your problem. Also make sure to close all other applications when checking, thanks!

Spacebar: key commands (and more) to come soon. Nothing should crash so please, send us crash reports!

Press where? In your plugin editor? Then that’s the plugin reacting to keyboard input. Else let us know which view is visible when you press “e”.

Yes, coming.

Hello,
in the meantime, thanks for the replies.

my configuration is PC Windows 10 21H2, CPU intel i7 4790 3.60 Ghz, 16Gb Ram

Presonus studiolive 24R Series III sound card

With this configuration I work calmly on Cubase with important projects (many Virtual instruments, effects etc.)

I know what the buffer size means, in fact the thing that is very strange is that if I change the buffer from the control panel of the sound card, it does NOT change in the program, remaining fixed at “16”.

If I change the buffer settings on the sound card panel (increase from 256 to 512, to 1024, to 2048) the response is obviously slower, but it does NOT solve the problems related to crunches and clicks, also the audio cuts out.
It seems that every action on buffersize, even just “touching” it sends Live’s audio engine into crisis.

I have no other applications in use at the same time

Buffersize

Can you elaborate on the CPU display pls?

How can I create a diagnostic report to send?

In Halionsonic, I position the cursor inside the box to type the name of the sound

later, with the PC keyboard I write “Tine”
When I press “e” letter this is the result:

Thank you so much for your support!

The CPU display is very “dancing” even without playing any keys …

That’s weird. Can you try: start VST Live, New Project, set Layer Instrument to “” - CPU still dancing?
Also, we can reproduce weird behaviour of Halion Sonic when pressing the “e” key, will check and get back to you.

Thank you, i’ll try It tomorrow, now i’m out of home

if I select the CPU is unused.

If I load “halionSonic SE” with any sound from the “HalionSonic SE PRO” library I get a very small increase in the CPU, with small jumps, this without playing any notes.

In the meantime, I was pleased to see an update come out, so now I’ll update Live and see what happens!

That is ok. So narrow it down to the instrument which teases your CPU too much (but make sure to have a buffer size larger than 16 samples).

I repeat that the buffer from the control panel of the sound card is set to 512, but “live” still shows 16. this also with version 1.0.1

I’ve looked it up. The number displayed in VST Live is what the ASIO driver tells us. And it is the size that VST Live uses. Usually, that number should be the same as set in the devices Control Panel. However, that Control Panel is a black box to us so we don’t know what happens inside.
Many ASIO drviers require to restart any audio application after changing the buffer size. Some offer to set the buffer size (blocksize) when no audio app is running, others only show if an audio app is active. I don’t know about your interface, but it seems wrong to me. Maybe try a different order, try restarting VST Live after changing buffer size in Control Panel, or try another ASIO driver (for instance Generic Low Latency ASIO) to check if that explains your CPU behaviour. And make sure to have the latest ASIO driver for your hardware.

believe me, I tried in every way, but that “16” does not change … I closed and reopened the sw, restarted … nothing. if I increase the buffer I feel the latency increase, but that “16” is always there