Flow title position

In a method book there are numbered exercises. I want to have this numbers on the left of the system. Is it possible to create them automatically from the flow titles? It should look like the attached picture (where the numbers are created as text objects and then moved in engrave mode).

Your picture is just black for me.
From what you describe, I don’t think there’s an automatic way to do this.

You cannot use tokens outside masterpages (yet). In this case, you should use {@flowNumber@} where the staff label lies, and this is not possible, as Florian has confirmed.

Here’s a workaround:

  1. Create a Section Player > Piano

  2. Set the following Layout Options:

  1. Write your music (three separate flows).

  2. Create a Divisi at the start of your first flow. This bit’s tricky: you have to fool Dorico by creating an additional division, then deleting it. Only then will Dorico let you edit the name.

  1. Alt+Click the Divisi signpost to the start of each flow, then double-click it and replace the “1” with a “2”.

Sure, this isn’t automated, but it’s much more stable than using Shift+X text and dragging it into place - the number will always be where it should be.

I made these all codas, hid the coda symbol, and added rehearsal marks.

The nice thing is that you can Select More and drag them all at once. Super-quick.

Watch here, starting at 37:14. https://youtu.be/hRHO_vw1pkI

Leo’s trick is brilliant as usual, but it doesn’t work for me. I get through step 3, but then there are no staff or divisi or group labels of any kind on the score. I can manipulate the layout options to give me the divisi labels above the staves, but I can’t get anything to appear to the left of the grand staff. Is this a trick that Dorico 3.5.1 breaks?

Make sure that the settings on the Staves and Systems page of Layout Options are not set such that the staff labels for divisi are not permitted to appear.

Thanks, that is indeed the case in my Layout Options. Upon further inspection it looks to me like I can make divisi labels appear for single-staff section players (i.e., Violin or Voice) but not for grand staff instruments like Piano. I’ve been able to enact a work-around by using divisi staves on Violin to imitate a Piano staff, copying the music into the added staff and adding manual bracket changes. But, shouldn’t I be able to make the Piano staves show divisi labels too?

You can only add divisi to section players, not solo players. If your piano is a solo player, you need to add a new section player and then copy the music into that player. Then divisi should work.

If you add an empty section player (by pressing Shift-Alt-P in Setup mode but not selecting an instrument in the picker, just press Esc) you can just drag the piano instrument from its original solo player to the empty section player.