(for SMufl pioneers) Font Forge authorisation

Continuing the discussion from 1800 Style Font:

Font Designers on here - @NorFonts and @DanKreider

Do you use Font Forge? and have you had any issues importing files on Big Sur? It doesn’t appear to have authorised access to any files, and no way that I can see to grant it in the security and privacy prefs panel.

Sorry to ask this on the Dorico forum - looked on the SF GitHub and some very unhelpful people on there…

Hi Edd (is that your name? :smiley: )

Yes I use FF on my macOS Big Sur, I also noticed that it does no longer get access to desktop or documents, I sometimes move my fonts to another place like Shared folder where I can point FF there to load and tweak more the font in question.

But frankly, I use FontLab 7, in conjonction with Glyphs 3 app. I was a FontLab user since the early days of Fontographer 4, I do still run the latest version of FontLab 5 on macOS Bug Sur inside Wineskin app windows emulator :wink:

So, all my fonts were drawn on Ai and FL… just to say that I rarely use FF, except for very exceptional reasons.

You’re welcome :slight_smile:

—Nor Eddine Bahha (call me Nordine or just Nor)

:face_with_raised_eyebrow:
Why does everybody doubt this?? It’s my name yes. When I was young, I decided that Ed wasn’t long enough, and although I didn’t decide this at this point, my later enjoyment of Andy Peter’s Broom Cupboard and his puppet Edd the Duck rather cemented it.

I’ll have a look at that thanks :slight_smile:

1 Like

The fix is to allow “Full Disk Access” in System Preferences > Security & Privacy > Privacy to /bin/sh.

You’ll need to locate this file first: press shiftCommand. to show hidden files in the Finder. Then navigate to /bin. Then (after un-padlocking the Preference panel), drop the sh file onto the panel. (Or you can click on the + button, and navigate to the file.

You can repeat the same key press to toggle hidden files off.

2 Likes

Hey! Actually I terminalled that like a boss. However - shocked to learn that I have no sh in usr/bin/! I have ssh - perhaps that’ll do it?

Sorry! It’s /bin/sh, not usr.

What I did, I clicked on + then just added the FontForge app there, now It can open my desktop and any folder on my Mac. Thanks a lot @benwiggy !

AAhah! Got it, and now I can do it. YAY! Thanks @benwiggy !

Yes, if the app itself works, that’s a better fix. It didn’t work, last time I tried it, which was some time ago.

@eddjcaine you make me laugh, I juts noticed this:
image
But I’m not a pioneer of SMuFL, :joy:
My dream is to become a pioneer of Dorico, from time to time I struggle doing some stuff. :face_with_head_bandage:

2 Likes