Force Brother to print NON-duplex

Hi Dorico-Team,
I have a strange problem in Dorico (3): My Printer always prints duplex even though I set the duplex mode in Dorico explicitly to one side only. I do not know this problem from other applications - a workaround is to first export as PDF and then use the normal system dialog from any PDF reader, which actually does what I tell it to do regarding duplex printing.

Is there another possibility to print from Dorico? I remember that at the first time I used the printer (Brother MFC-2700), duplex was enabled, but I disabled it and now every app remembers it except Dorico. Any ideas will be welcome…
Thanks in advance
Waldbaer

We’ve had a couple of reports of this and we even bought a Brother printer to try to reproduce the problem, but we’ve unable to reproduce it to date, I’m afraid. Until such time as we’re able to figure it out, you’ll need to continue to export PDFs and then print that.

Wow, thank you for your efforts! I use Mojave 10.14.6 on an iMac 2017. Printing from my MS Surface does work as expected. So probably it’s because of the MacOS printer drivers, I suppose? I didn’t install anything special, I think, so I just rely on the apple drivers, I suppose. It’s PrinterProxy 14.4 (555.6) and says driver version 2.0 (Brother_MFX_L2700DW_series). If you want me to look up or test anything else, I’ll be happy to help!

I use a Brother DCP-9020CDW and Dorico 3 always prints duplex. Duplex mode is off. From W10 to the same printer works well.

This has to do with the default printer settings. I have to print to a large copy machine over a network, and it too forces duplex every single time unless I specifically go in under “printer features > two sided printing” and manually change it via the dropdown to single sided. This is also a ‘sticky’ setting set by the IT admin so even if I change it for one job, I have to manually override it the very next time.

Unfortunately, the dorico dialogue doesn’t work the same way as the macOS one, so this option is never available to me (I find that if I use the print options on the left I have other issues). When I’m particularly in need, I just open the pdf in preview and print from there. Dorico is (rightly, I presume) working off of the model that you should get what you ask for, ie: if you want double, click the checkbox. The problem is, in a situation like ours, this feature needs to be DISABLED (ie- overridden), not simply enabled.

Hello, I’m on MacOs, I have a Brother HL-3150CDW Laser printer and I’m the same problem.
Every time I print from Dorico Pro3.1 the printer force the duplex on papers!

Tom,

What happens when you uncheck/untick the ‘Two-sided’ box in the Print dialogue?
Single-sided.png

Unfortunately this is the case for some printers, and we’re not sure why. The workaround is to export a PDF using the options on the right-hand side of Print mode, and then print that from Preview.

Hello! Same problem here! My printer is a Brother HL-L2350DW

Hello all. I have had this same problem forever with Mac OS and all of my printers. The problem is the default setting on the Macs (at least mine) is set to double sided and this setting overrides Dorico’s setting. I did some digging about how to change it and came across this video showing how to change it on Macs. I would have never know without this video. But NOW IT WORKS! I do not have to do the work around of exporting to PDF first and then printing from Preview. Below is the link on Youtube.

https://www.youtube.com/watch?v=s9HzqdYO8u4

2 Likes

Thank you, Austin, for this.

My HP print is set to duplex by default in CUPS, but it obeys Dorico’s settings (and other Print Presets in the Print menu). It must be some weird Brother thing.

Daniel is this a problem that will be solved in future version? My Brother HL-3150CDW Laser printer continue to force the duplex printing, I was hoping that Dorico 3.5.x solved this issue…
I go with the pdf export workaround but would be great to print directly from Dorico, I don’t have this problem on other applications on my Mac.
greetings

Tommaso

I have a Brother HL-4150CWD and Dorico correctly prints one side from Mac. I’d also suspect an errant setting somewhere, your printer probably has a web page interface you can check.

When was the last time you updated the firmware for your Brother printer? I just received notice that I have another update waiting to be run and remember that the last was a few months ago. Guess what I’m doing as soon as I’m done with this post? My Brother printer is over 3 years old.

Also, for Brother printers on a Mac, drivers and updates are not included in the OS unlike HP, Canon and Epson (grrrr…). Although they will run over the Air Print drivers, you have much better control and way more functionality if you download the CUPS drivers recommended for your specific printer. Brother has this info on their web site.

Mine remembers its last settings, even for Dorico.

unfortunately in the printer web page settings I don’t found useful settings to change to solve the problem.
Thanks for your reply

I’ll try soon your suggestion and let you know if it works, thanks :wink:

@PF Slow you saved me, many many thanks.
My printer was connected via the AirPrint method via wireless. I downloaded the drivers from the Brother website and installed the printer. Then I printed by selecting the new installed printer and everything works fine! Perhaps this could be a known issue to talk about in the software knowledge base.
Again, many thanks my friend.

Tommaso

You’re very welcome. Hopefully, you downloaded and ran the utility that installs the print drivers and updates the firmware. That way, when your printer squawks at you for a firmware update, you can run it from your desktop.

I have got the same problem with a Canon i-sensys MF635x – Dorico ignores the duplex (un-) setting. Native printer settings are set to print one-sided, too.