Fortepiano issue

Dorico refuses to play this back properly:
Screen Shot 2019-03-30 at 1.41.09 PM.png
It instead plays back like a forte tenuto quarter note.

I use NotePerformer for playback, so this might actually be Wallander’s fault.

Have you tried it using Halion for playback?

I just now tried that. It made it worse. Now it plays it like a staccato eighth note.

This is more likely a current limitation in Dorico… it does play back with NP3.2 in Finale (and probably Sibelius…?) …

how did you get the staccato to work simultaneously with the tie?

i my hands, when i tie a note to a staccato note, the staccato indication vanishes. that being said, when i write out what you’ve indicated (say for the flute) in your screen shot (sans staccato dot), playback (with NotePerformer 3) is as expected.

In Dorico a “tied note” is a single note, not two notes tied together.

If you tie two notes, in effect the second note is deleted and the first note is made longer. Any articulations on the second note disappear, but those on the first note remain.

You can add articulations to the tied note afterwards, just like any other note. By default the staccato dot will be drawn on the last note of the tie, but you can change that in Engraving Options / Articulations / Ties if you want.

EDIT: for some reason “t b a b c o c k 1 2 3” is being displayed as “rock” - after a bit of experimentation “c o c k” is also displayed as “rock”. A bug in some new “naughty work censorship” in the forum, maybe?

After further experimentation, it seems like fortepiano, in general, does not work. At all. It just acts like forte. : (

[quote=for some reason “t b a b c o c k 1 2 3” is being displayed as “rock” - after a bit of experimentation “c o c k” is also displayed as “rock”. A bug in some new “naughty work censorship” in the forum, maybe?
[/quote]

it’s something i’ve learned not to worry about…

https://www.steinberg.net/forums/viewtopic.php?f=246&t=155479&p=834976#p834976

actually in that other software, fp plays back as a plain p as far as I can tell (NP3.2)

This doesn’t play back. It’s playing piano immediately. No fortepiano.
If I get this topic right, it’s a kind of ‘missing function’ in Dorico at the moment, right?
Bildschirmfoto 2019-05-26 um 13.36.06.png
So the workaround will be to write a forte and a 16th or 32rd later a piano and hide the dynamic signs so that one can see only the ‘fp-sign’ I guess.

Dorico does indeed not yet play back these kind of “envelope-based” dynamics automatically.

Or possible to draw in the effect in the Automation lanes of Play mode.

I’m not a too big fan of that, cause then I get mixed up with ‘normal velocities’ of my dynamic signs.
With Sibelius I made the bad experience that once I started drawing automations for the dynamics, it didn’t stop anymore for the rest of the piece because I have to do it on the same midi-channel than I use for my playback expressions.

I could not get this to work. the dynamic does not fix into the correct spot, and then you can’t move it or adjust it subsequently.

Are you adding the dynamic while in note input mode? You can move the caret anywhere on the rhythmic grid and place the dynamic there, and it will stay affixed to that rhythmic position.

You have to input the dynamic with the caret mode enabled. Put the caret into a position, invoke the dynamics popover, enter the first dynamic. Press space to advance the value of your rhythmic choice, invoke dynamic popover and enter the second dynamic. It does work flawlessly.

Yes it does.
But it’s kind of a big detour to playback a forte-piano :laughing:
And shr23 don’t forget this very important part in Marc’s explanation:

Take small rhytmic values to advance so that you can bring the crescendo/decrescendo close to the dynamic signs.
What I did to make it sound quite ok is:
On the ‘1’ I wrote a forte on the ‘1and’ I wrote a piano and from the forte to the piano a decrescendo. Hide all this and mute the ‘fp’ sign in the control panel and it will sound quite like a forte-piano (depending in which tempo you are of course)
Good luck.

thanks, I had a whole note at forte(f), and then 1/32 later I put a piano§. Didn’t bother with the hairpin
I noticed however,

  • the p sounded like it was 1/4 later instead of 1/32 (ie, conspicuously delayed).
  • I could not subsequently move these dynamics. They seem to try to snap back to the note position and won’t move again.

I tried to look at the velocity track in the play mode, but realized dorico doesn’t support that yet.

Correct, that’s because they aren’t attached to an explicit note event, so if you want to move them, you’d need to re-enter note input mode and input them again.

The alt-arrows for moving dynamics send them right or left to the next note, not according to the rhythmic grid.