Frontier Tranzport not recognized on latest Windows10

Hi all,
I own a Frontier Design Tranzport and it worked just fine until now.
I have upgraded my system with 2 SSD drives and got it back (as wished) with the latest Windows 10 on it.
So it was time to re-install all my DAW software (among much Steinberg) and computer related hardware. Now the issue, the Tranzport controller is not recognized at all by Windows. It is listed as having no drivers, and what I do, it does not have effect on that.

Anyone else with the same issue on the latest (april) Windows 10 version?
As I put the USB connector in my hub, it lights up for several seconds and then the led on the USB hub goes out again and that’s it. I always had the RF reciever on this same hub with previous Windows versions and worked just fine. Any ideas?
I have copy/paste the driver in the same folder in Cubase as it was on the previous system (also Cubase Pro 9) and there it worked fine. P.S. copy/paste the driver is the workaround for the non-supported Frontier products (I do not know if they are bankrupt or what, but there have not been new drivers since 2010). http://www.frontierdesign.com/Products

A thought…

Try running the Windows compatibility troubleshooter (right click on the icon). You may have to run it in the Win 7 compatibility mode.

Regards :sunglasses:

Hi Prock,
Why didn’t I think of this?
Thank you so much for the tip. It works!
You made someone happy today :slight_smile:

Kind regards,
Arno

Good news. One thing less to worry about when it’s time to switch to Win 10.

Excelente!!! Still works. Great solution!!! Thnx a lot

… and just FYI: the AlphaTrack also still works in Windows 10 and Cubase 11 using the same trick with the installer.