FX channel tracks can't route to groups!

Why was the ability to route output of FX channels to groups removed in Cubase 7? This sucks! It used to be great to be able to route anything to anything, but it seems that Cubase is going backwards. What is the deal with this?
:angry:

It wasn’t.

Take a deep breath, provide more details and maybe someone can figure it out.
Which version are you using? (i.e. Elements, Artist, etc…)
Also, make sure you are not making a feedback loop. You may have to disconnect the output first before it will give you the input as an option for another output (if that connection would create a feedback loop).
J.L.

Thanks for your reply, Jaslan. Ha, you’re right. It was not there in Cubase 6, even though I would swear I used it. I am using full version of Cubase 7.5.1.

Output FX channel can not be routed to a group channel. Group channel output can be routed to FX channel, but not the other way around.
There is no feedback loop involved. Don’t see the point of this. I have to use a group channel instead of FX channel to add effects and then route to another group. If group to group can work, there is no sense in not enabling FX to group.

Try it for yourself. Create a blank project. Create a FX channel and a group channel. Try routing the FX channel to the group one. Impossible.

Am I missing something?

What I meant was that the feature was not removed. It is still there. Here is a project I created where there are several tiers of routing Instrument Channels, to FX Channels to Group Channels, etc.

https://www.dropbox.com/s/k27hso11378w7et/Fx%20Group%20Routing%20Test.cpr
HTH
J.L.

Now I am really confused! Thank you for that project. I really appreciate it.
I opened it fine and the routing is as you say. But, when I try to create a new project and connect FX’s to groups, it doesn’t work. This is insane!
Here is the link to my test project. See if you can open it and connect FX’s to groups.
http://we.tl/gMpSx4kNFU

Thank you.

You have sends on Group 1 and Group 2 that go back to FX 1 and FX2. Cubase will not allow feedback loops like this. Select “No Bus” for those Sends on Group 1 and Group 2 and then it will allow you to select Group 1 and Group 2 as destinations for the FX Tracks.
HTH
J.L.
p.s. I know the Sends were not “Activated” but I guess Cubase still considers it “connected” and will not allow it.

You’re the man, Jaslan!
Those sends were automatically created. Now I know.
Thank you so much for demystifying this issue!

[quote=“GoranGrooves”]You’re the man, Jaslan!/quote]

+1
{’-’}

Thanks for this…

Always learning! :wink:

The following won’t change the situation for already-existing tracks, but, go into Preferences>VST, and disable the option “Connenct Sends automatically for each newly created Channel”.

You can use groups as fx returns. Just insert a fx plugin on the first “group insert” as you would normaly do when using an fx return. Now you can route fx returns to other groups, make a submix with EVERY channel in it ( including fx returns this is) , send the whole mix to different hardware outputs and so on.

The lack of aux busses on the master, the inability to route fx to something else but the main out, it is all gone once you start NOT USING fx returns, but use just groups instead. They are the same actualy, the fx return just has limited routing. ( I wonder why…)

I was having the same problems as GoranGrooves and found this thread.

jaslans test project gave me hope I could solve this riddle…

… I downloaded the Fx Group Routing Test Porject and I can see it’s working fine when I load it up.

But still, when I try and replicate this I simply cannot. Routing to an FX Channel is just not an option. I thought I would test more on the Fx Group…

  1. Opened the Test Project from fresh
  2. Removed the routing to FX Channel 1 selecting No Bus.
  3. Then try to add the routing to FX Channel 1 as it was - but cannot because it’s not selectable. Argh

The test here was just to see if I could create a link to an FX Channel. Obviously it works when I open jaslans project, but I just can’t do it ?

Please help. Could it be because I’m using Cubase Artists (v8) ?

Another test that fails …

  1. Create blank project
  2. Add a VST track and drag in a MIDI onto it
  3. Create a FX Channel with Reverb
  4. Try to route VST track to FX Channel

But cannot… argh!

https://www.dropbox.com/s/fvlvjhjgbd4yeiq/routing.png?dl=0

Continuing on…

  1. Add a Group Channel Track
  2. Try and route the FX Channel to the group

Again just cannot… :frowning:

https://www.dropbox.com/s/v2w7f4o5s604xnv/routing2.png?dl=0

The only thing i can do is route the VST Channel to the Group Channel :cry:

Any ideas why jaslan able to route VST to FX and also able to route FX to Groups, but for me its not an option?

Hello! I’m writing in 2016, using Cubase AI 7 and having the exact same problem as described by NeilTheNine.
Please, help!

Routing capabiliteies are limited in “smaller” Cubase versions like yours.

I am having a similar problem: when I make an FX Channel (a Send) I am not getting any destination options. It is completely blank on the right side. Any insight? Cubase Elements 8 on Win7.

Where / what is “on the right side” ?
In VST connections?
In the project Window?
Screenshot?

Hey there. Thank you for taking the time to reply.
Here is a link to a picture of my screen: https://s31.postimg.org/sylntlwtn/image.jpg

I have tried to Google Search for a solution to my problem, but no luck.
I can make the FX channel, but I cannot figure out how to “get it to work.”

Yeah that´s one of the limitations I was talking of. Nut you don´t need that to make a send work. You need to send from the audio track to[/] the FX track. The Fx track is then automatically routed to the stereo out (as you can see on the top middle of your screenshot “->stereo out”)