Gap after grace notes

In this screenshot
Screenshot 2023-05-11 at 16.02.28
the second of the two grace notes seems to me to be too close to the next full sized note. The parameter of “minimum distance between rightmost grace note and rhythmic item” is set to 1/2 spaces. But this doesn’t seem like half a space to me?

I tried to reproduce this.
To me, it looks like the minimum distance you set, applies to the first grace note and not to the last. In your case nothing changes until 1 1/4 or bigger. (intentional or buggy i don’t know)

If there is only one grace note, the gap looks ok to my eyes.

The score was a Musicxml import. Could that be anything to do with it? The gap setting is the factory default.

I just tried deleting the grace notes and the following rhythmic note and replacing them. It looks exactly the same!

Dorico allows grace notes to tuck in close to the main note: once the grace note is two staff positions above the main note, it can tuck in closer.

No. It’s the same in a brand new project. It’s just the way the setting seems to work.

Just realized. the grace notes are only closer, like in your case, if the last note is more than a third apart. It also depense on the direction of the stems.

Is there a way of adjusting the settings?

You can adjust Minimum distance between rightmost grace note and rhythmic item on the Notes page of Engraving Options.

Ok - I tried that, I changed it to 7/8 then to 1, but there’s no change in the appearance of the score.

Flipping them does improve the distancing of the note heads. But it looks a little untidy though with the stems of the grace notes going in the opposite direction to the succeeding rhythmic notes.

Ok I’ve managed to get a change in the appearance, I had to enter a much larger space setting than I had realized. So now in this new screenshot, the grace notes are getting closer to what I would like to see, but the grace note in the last bar is still too close to the rhythmic note, and it clearly hasn’t been affected by the new Engraving settings.

And in this screenshot
Screenshot 2023-05-11 at 17.58.31
the setting is clearly too big

You start to see a difference if you set i above 1 1/4. But it also changes all other grace notes in the score. So this doesn’t solve your problem.
As Daniel said, the notes can tuck in closer (closer than 1/2 space) if the interval is a third or more. So it is intended to be like that and there is no “global” setting for your specific problem.

If I read this passage it doesn’t bother me, that they are that close.

If there aren’t to many passages like the mentioned one, you can

…go to Engrave mode,
…select the second grace note,
…open the Properties Panel,
…go to “Note Spacing”,
…change the “Voice column X offset” to a negativ number.

now the grace notes are closer, but theres a gap between second grace note an the eight.

ok, the grace note before the whole note is really too close.

Have you tried respacing in Engrave mode (if you are using Dorico Pro)?


Yes of course I can do that, but I wanted to get sensible settings first, but as Nukkut says, there isn’t a global setting for all occasions. That’s ok, now that I know that I won’t spend time adjusting that parameter, I’ll just tinker in Engrave mode. Thanks for your help everyone.

I’m getting good results with the spacing of grace notes by moving them now, though it is very time consuming. However slurs from grace notes leave a lot to be desired. In the following snapshot, what is shown is the default. Clearly the end of the slur should go under the full size note head. I can get the result I want by manipulating the Besseler curves in Graphic editing mode, but it can be a bit hit and miss sometimes. Is there a better way of doing it?
Screenshot 2023-05-18 at 20.35.53

If you flip the stem and slur of the grace note, it works fine. Do you want/need an upstream grace note?

In your picture it looks like the “main”-slur starts at the grace note?

Edit: just realized in a few parts, that most grace are most time upstem.

If you copy the note following the grace note to a downstem voice, add a slur between the grace note and the upstem note which follows and flip the slur, you get this:

Finally, hide the stem of the upstem note following the grace note in engrave mode.

1 Like

Thank you John, that worked - and it looks much better. A trifle laborious though!

So having improved the appearance of grace note to regular note slurs when there is just one rhythmic note, what about in this case. The default slure is ok, but it could look better. I tried the same trick as above, but flipping it makes it attach to the lower note in the chord. I can produce a better result by manipulating the curves in Engrave, but is there a better way?
Screenshot 2023-05-20 at 20.33.49

Flipping the slur will work if you put the lower whole note in a downstem voice:

To tie the downstem note to the lower note in the following chord, select both notes and press T.

1 Like