GEAR Install Uninstall

PG, it’s been 8 years since one very bright person came up with a simple registry mod to get around the fact that the GEAR installer/repair/uninstaller couldn’t install and uninstall properly after some recommended Microsoft optical drive troubleshooting. (thank you RayThomas and Mljung for the link)

http://ccm.net/forum/affich-77186-itunes-registry-settings-missing

Can you please ask GEAR when they will issue updated installers that can address this issue. This has probably been the source of many of the difficulties with Windows optical drive troubleshooting over the years, as it requires a tremendous amount of trial and error, and back and forth.

When Microsoft Method #5 is used below as suggested by Microsoft to fix problems with drives in explorer and device manager:

https://support.microsoft.com/en-us/help/314060/

Microsoft specifies that the CD/DVD programs/drivers might need to be uninstalled and reinstalled afterward. But doing that with the GEAR install/repair/uninstall doesn’t work. Having to do the convoluted GEAR manual registry uninstall to continue at this point is just unacceptable for an end user, and certainly not what Microsoft would expect a manufacturer to offer to the end user. Especially for a company that can’t be contacted by end users for support, like GEAR can’t be contacted. And it usually takes hours of trial and error and research just to get to the point where you find out that a painful GEAR manual registry uninstall is the only way to fix this, outside of the simple ccm.net forum fix.


I think there are probably 3 simple steps to fix nearly any optical drive problems with Wavelab on Windows:
(I would make a System Restore Point before running these so you could go back if you want to).

  1. Make sure the drive is plugged in and turned on. Install or reinstall(repair) GEAR Drivers:
    http://www.gearsoftware.com/support/drivers.php

if that doesn’t work,

  1. Run Microsoft checklist:
    https://support.microsoft.com/en-us/help/314060/

if you delete the registry entries in Microsoft method #5, do this:

  1. http://ccm.net/forum/affich-77186-itunes-registry-settings-missing

Honestly, I think that covers just about everything.

But the GEAR installers/repair/uninstallers should be fixed to replace the ccm.net forum registry mod in step 3 above.

Seriously, it’s been 8 years.

As one of the respondents says on the ccm page, “Microsoft instructs to delete the values - but only this thread explains how to replace them to get the damn thing to work. Thank you.”

That’s what uninstalling and reinstalling GEAR afterwards should do (as Microsoft specifies). But it doesn’t work. It’s GEAR, not Microsoft who needs to fix this, 8 years later.

GEAR has told me they haven’t been able to reliably reproduce this problem, but will produce a utility to do the registry fix, in case of problem.

Thank you PG. That’s great.

PG, I can’t find the utility anywhere on their site. Do you know where they put it?

I will ask them

And they said? Just wondering??? How do YOU reach them they never answer my emails. Thanks in advance!

Normally i get a quick answer. Not last time.

Maybe they are hard at work making some updates and creating an uninstaller.
The serious side is there anyway that you can find another company that provides this type of software and use them instead?


Thanks for making WL such a superior piece of software…now if we could get the burning problem solved once and for all it would be the best Holiday present ever.

PG
So are you saying that they have not even replied to you in over a month? If this is the case then Steinberg should be seriously looking for an alternative company as any future Windows update could break the drivers with no way to move forward.

Jim

Cubase uses EAC, for example … but of course we don’t know what the precise requirements are for WaveLab, which I assume are much higher than for Cubase.

PG
Any answer from them yet?

Also, are Steinberg considering alternative drivers for WL?

Jim

@JimP

What is currently your problem?

PG

As mentioned above I went through the tortuous process of uninstalling the driver which involved editing the registry and it worked. Thomas had to get one of his IT wizards to sort his problem out using the same process.
My worry is that a future Windows update could stop the drivers working again and it seems very much like GEAR would not issue a fix as they have completely ignored this problem and not updated their uninstaller/installer process as far as I can see.
If they are not responding to your emails does that not send a worrying signal to you?

Jim

PG, I didn’t say anything before because I thought they were going to make a utility or removal tool, but I don’t see how they can say they can’t reliably reproduce the problem, because it happens every time someone uses Method 5 in the standard Microsoft troubleshooting instructions.

https://support.microsoft.com/en-us/help/314060/

Microsoft says the user “might have to uninstall and reinstall the affected app” after doing Method 5, but when you do that with the Gear Uninstall and Install it doesn’t create and fill the needed Upper Filters entry, so the drive and system is still broken. Seems like Gear probably could have attempted to fix it to account for this eight years ago when it first came up, but they didn’t, and the problem still exists, so they at least need to make the utility if they’re not going to fix the installer and uninstaller. (which is really what I think they should do - fix the uninstaller so the installer can create that entry).

I’m pretty sure Microsoft didn’t mean the user would have to do an unusual registry manual uninstall after Method 5, or have to figure out that such a thing was even required, which it is - the user has to figure out that a manual Gear registry uninstall is required, and like I said before, just getting to the point of that realization wastes a lot of time… not to mention the time to do the convoluted manual uninstall.

Also their manual removal instructions have some incorrect registry paths.

like:
HKEY_LOCAL_MACHINE\SYSTEM\System\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}

it should be:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}

It seems that Steinberg should have some leverage over GEAR since they seemingly would have to pay a licensing fee for its use in ever WaveLab software sold and thought could be a substantial amount

PG did you ever get a response from GEAR? any attempts at contacting them on a user level never works. Thanks!

I will attempt a new contact this week.

GEAR has released a tool “GEARAspi_Remover.exe”
found there: http://www.gearsoftware.com/downloads.php?dir=freebies/

Removes files and registry entries associated with the GEARAspi driver set. This is NOT an uninstaller, this is only meant to remove files and registry entries in the event that the installer is not able to fully uninstall the driver

Thank you PG. And thank you Gear. I’m anxious to try it out.

Thanks PG it seems to work fine. It requires 2 steps and 2 reboots, like the Manual Removal. It seems to do everything the Manual Removal does if you look at the log, but Gear still appears in Installed Programs on Win 10 after you run it. So I guess that’s why they say it’s not an uninstaller, but the “Manual Removal” does the same thing (Gear still appears in Installed Programs), so I guess the Manual Removal is not considered an uninstaller either. I don’t really understand that, but I’m just glad they took the time to do this and have it cover all the different systems, so I really do appreciate their time and your time to do this.

So, if the Gear Aspi Check utility says Gear is not installed correctly (make sure your drive is plugged in and turned on when you run AspiCheck - that’s thrown me off more than a few times because it’ll often say Gear is not installed correctly when it is, if the drive is not plugged in), and no amount of normal repair/uninstall/reinstall of Gear makes it better, you can run this new GearAspi_Remover, then run the Gear installer repair or install, and everything should be fine.