getting to the next to input notes

I’m a new Dorico user and really struggling with absolute basics. I’ve looked through the FAQ on this forum without joy; can’t find anything in the help files either.
I have a 3/4 bar containing a minim with a note value, followed by an (automatic) crotchet rest, which I want. How on earth do I get to the next bar to input a note.
FWIW, I come from 20 years of using Sibelius and do realise Dorico works entirely differently, but all I want to do is enter a rest so I can get to the next bar.
And while I’m at it: a dotted minim tied to another dotted minim: how do I alter the second dotted minim to a crotchet. The only way was to untie the notes, then alter the second dotted minim to a crotchet, then retie the notes. Until I did that, when I selected the second dotted minim, both notes were highlighted and selecting crotchet altered the first, not the second. There’s surely a better way.
Sorry these are dumb questions. If there’s another FAQ I’ve missed, please let me know.

Welcome to the forum, piano888. I hope you will quickly find yourself becoming more comfortable with Dorico as you learn the software.

You don’t need to input rests in Dorico: simply move the orange caret to the rhythmic position at which you want to input the next note, and put it in. If you are on e.g. the third beat of 3/4, then you can simply hit Space to advance the caret to the next bar, then input a note. You can also move the caret with the arrow keys.

Once you get used to this, it’s really liberating and feels a lot less fussy than having to input rests all the time as you are used to in Sibelius.

Check out the Write mode playlist on our YouTube channel. Watching that with a cup of tea or coffee will reap big dividends and you’ll be off and running in no time!

1 Like

Thanks! I’ve had 20 years of never using space unless I want to play back - it’s engrained! So that’s sorted. Thanks for the link too - hadn’t managed to find that before. I’d seen there were numerous Youtube clips, but I wonder whether it would be worth having direct links to relevant ones from the help pages - it could save you a lot of time…

To change the duration of a note group, select it and press Ctrl-alt-shift-left or right. That’ll change it by the value of your rhythmic grid.

Thanks Dan. That’s very useful to know. I still can’t work out how to alter the length of the second note in a pair of tied notes though.

Daniel - I’ve watched the Youtube video - thanks - I’ve had to install Windows 10 to get Dorico to install :frowning: and though I’m getting sound through Dorico, I’m not getting sound through any Youtube videos. I’ll keep trying; I imagine there’s some setting somewhere that needs tweaking as a result of the W10 installation. There’s a useful button that subtitles the commentary, however.

If you want to hear other sounds while Dorico is open, you should make sure Dorico is not taking exclusive control fo your sound card. To do this with Dorico’s Generic Low Latency ASIO Driver, go to Edit > Device Setup…

…click the Device Control Panel

…And make sure the box to take Exclusive Control is not checked.
SoundOut2.png

In Dorico’s UI, there is no “second note.” A tie is a single note, represented by a tie chain as required by the meter. Click on either note, and the whole thing will be selected. Then lengthen and shorten the overall duration using the key commands.

You can untie the note by pressing U, which breaks the tie (U=untie).

Related to this, you’ll find it very helpful to keep track of your rhythmic grid, which is located in the bottom left corner. It’s the rhythmic “resolution” that you’re working in (probably usually eighths or sixteenths). You can quickly change it using Alt-[ and Alt-].

Derek - yep, that was it. Thanks - I’d not have got there on my own.

Dan - thanks too. Still can’t persuade a tie to extend by just a crotchet though. I’ve got crotchet displayed in the bottom left hand corner; semibreve in the note panel because the note is a semibreve long. Using any of the Alt options just takes the existing note length - a semibreve - and adds that on; I really can’t fathom how to get it to extend by just a crotchet. I can untie it and fix it, but then that gets fiddly because I’ve got some stems-down notes in the first bar (Voice 2 in Sibelius terminology) so when I go to re-tie the notes, everything gets re-tied.

I’m sure basic input is fine but I’m finding it quite annoying to amend things; moving a rest up and down is very fiddly for example and I find myself yearning for the ability to drag it. Do other (former Sibelius) users find the same, I wonder?

Dear piano888,
There’s something wrong with your keyboard shortcuts because using shift-alt-arrow to lengthen/shorten a rhythmic value (by the grid increment) is one of Dorico’s big assets when it comes to note inputting! You might want to check your preferences > Key Commands > Selection and Navigation > Lengthen Duration by Grid Value (just input lengthen in the search field, you should be there in a second), and check that there are Key Commands assigned to that function.
Hope it helps !
Marc

I’d be interested to know, piano888, under what sorts of circumstances you’re finding it necessary to move rests up and down. In general we try to make rest positioning pretty good by default, so if there are situations you’re running into commonly in which you find that you would prefer rests in different positions, I’d love to know what they are. Thanks!

Marc - don’t know why but it seems to be OK now. It was also useful to get me into the Preferences screens, too - thanks. (It was set fine, as I would expect, since I’ve not fiddled with anything so everything’s on factory pre-sets.) And I’ve finally sorted out in my mind what adding Shift to the mix does. All good stuff.

Daniel - the thing I’m creating is for piano solo, in 3/4. The RH has a melody and the accompanying oom-cha-cha chords are split between both hands. So in the bar in question, the RH has a low B (below middle C), dotted minim, the melody, stem up. In the same hand, crotchet rest, then two two-note crotchet chords, stems down, the accompaniment. I want the crotchet rest to appear below the dotted minim, since it’s part of the lower part. It appears above it though, so I have to force it show below. Maybe there’s a keyboard shortcut that would help? I have a LOT of bars that need this!

piano888,
once you have adjusted one bar to your liking, select it with all it’s content and press the R key repeatedly (to repeat the contents of that bar).
Then go back to the beginning, hit the L key (lock to duration), hit the Enter key (to invoke Note Input/the caret) and retype your music.

I’m not sure I can visualise exactly what you want, but if you use voices correctly, then the rests should be in the right place. Generally, if you find yourself manually moving every single thing, there’s going to be an easier way.

I would recommend the Tutorial that can be found on this blog page:
https://blog.dorico.com/2018/09/getting-started-with-note-input/

It’s well worth running through it, as it covers pretty all the issues you’ve mentioned.

piano888, I think this is what you want, and all I can tell you is that this is what Dorico does by default. I haven’t moved anything manually at all.

Make sure that the dotted minims are entered in upstem voice 1 (which is the default voice) and the crotchet chords are entered in downstem voice 1 (which can be created by typing Shift-V whilst in input mode, or if it already exists on the staff you can switch between voices using just V).

Hello pianoleo. Thank you! A useful tip about switching voices. The difficulty arises I suspect because the ‘oom-cha’ crotchets are pitched higher than the melody line, so their crotchet rest on the first beat ends up above the melody, which is not what I want.

Daniel - thanks for this link. I’ll go through that tomorrow. Had you not told me about it, where would I have found it? Isn’t this the sort of thing that should be pointed at when you first go into the help file and click on Guided Tour? I had no idea there was a blog - how am I meant to know? I don’t use blogs. I just use the software (and goodness knows I’ve had enough difficulty installing it, and it’s still not right). If there’s something that’s going to be useful (and save me wasting your time!), I can’t help thinking it would be a Good Thing to point new users at it before we have to ask the forum.
Anyway, I hope it’ll solve another layout difficulty I’m having concerning voices, when the stem-up voice goes rest-note-note (with notes above the middle line), and the stem-down voice goes note-rest-rest, but what should be stem-up notes (voice 1) stay determinedly stem-down. Heigh-ho.

In that case you’ve probably just got things in the wrong voices.
In this example I’ve turned on Note and Rest Colours (on the View menu). In the top (R.H.) stave blue is Upstem Voice 1 and green is Downstem Voice 1. Bars 5-8 are an exact copy of bars 1-4, except I selected everything on that stave in bars 5-8, right-clicked and then Voices > Swap Voice Contents. Again, that’s the only manual adjustment I’ve made.

edit: to clarify: you could, of course, flip the stems of any or all of the notes and chords. Alternatively you could shunt the rests down using the “rest position” property available in the bottom properties panel. Bear in mind that whilst you can’t define a shortcut for this (unless you use external macro software), you CAN apply this to all of the rests in one go, by selecting a load of similar bars and filtering rests.

Be aware that there could be a very useful feature in the context menu : swap voices content. This would change all your selection of upstem voice/downstem voice to swap, which could either make a real mess or solve your problem. I usually use it on small selections where I know what I’m doing (and turning on voices colors do help to understand where you are, as Leo suggested).

One could always try it on a copy of the file to be safe.

Thanks to all for all of this. Showing the colours shows I’ve got a right mess. Goodness knows how I’ve managed that! but exploring the Filter and voices (again, thanks for pointing me at that), has sorted it out (both the mess and the stem directions). Some of those colours are a bit virulent, aren’t they. But having sorted it, some of the rests really are in odd places; yes I can move them manually (and have done), but as Daniel and others have said, it shouldn’t be necessary. I’d include a screenshot but I can’t get it to paste; how have you (those of you who have) pasted those images into your replies?

To attach an actual Dorico project, either Zip it or just add .zip to the end of the filename.

For showing screenshots I use Greenshot. There’s a method that involves attaching images directly to the forum post, then previewing the post, then editing the post and linking the image into the body of the text, but for some reason the forum software has a vendetta against me. For Greenshot details read down this thread: https://www.steinberg.net/forums/viewtopic.php?f=246&t=143172&p=770594&hilit=Greenshot#p770448