Glissando Bug

I’ve come across what I believe to be a pretty nasty glissando bug.

Whenever I try to change the angle or length of a gliss in Engrave mode the object snaps back to where it was, BUT, it’s actually moved. The only way I can see it’s new placement is by moving to another part (or the full score) and back to the original part (which doesn’t always work) or by closing the project and reopening it. It is almost impossible to work this way. Please help!! :wink:

I’m on a brand new iMacPro and 10.13.2, with Dorico 1.2.

B

UPDATE - I just loaded up the same Dorico files on my laptop running 10.12.6 (Sierra), and indeed the bug isn’t there… So it seems to be a High Sierra bug. Is this a known one??!

Sorry, I spoke too soon. The same behavior is showing up on my laptop, running Sierra. Now I’m really confused if no one else is seeing this behavior.

I can’t reproduce this at will: do you find the same behaviour in every project, or just in one? If it’s isolated to a particular project, can you attach it here (zip it up first) so I can take a look?

Okay, I deleted the music except for a few spots with glisses. Be sure to try it out on all of the notes, as sometimes the first gliss on the violin works as expected. The others snap back to their original position when I try to move them but they did in fact move. I can see the updated position only if I save and reload.

I tried uploading it here but it said that the file was too big so I placed it here: http://www.mediafire.com/file/22y0iehgv1glm4f/Gliss-BUG.dorico.zip

Are you seeing this behavior? If not I can make a video and upload that as well.

Thanks!
B

Daniel, perhaps unrelated, but sometimes when I input a glissando I get the result as shown (without the “gliss.” text), and have to manually use note spacing to give it room to show the text. Could Dorico’s default behavior always space the notes at a minimum so that this text shows without user intervention?
after note spacing gliss.png
original gliss.png

B, thank you for uploading the project – we will take a look and see if we can figure out what’s going on.

musicmaven, you can adjust the minimum space Dorico leaves for a glissando line on the Glissando Lines page of Engraving Options, which although not exactly what you’re asking for should allow you to get closer to what you want more of the time.

The original problem occurs because those glissando lines are connecting two note heads that are tied to each other too. This is not really supported at the moment, but you can create such a glissando line in some cases accidentally. What you can do is to create the two notes without tie, add the glissando line, and then use a slur to make them appear as tied notes. You shouldn’t experience any odd snapping back behaviour in that case.

Thanks for the response Andras. I wondered if that might be the case but didn’t want to believe it as this seems like core functionality to me. I often want to gliss out of and back to the same note. Will this be addressed in an update soon?

And I’m glad to hear that there’s a workaround but the behavior as it is now, where it doesn’t allow you to move it BUT actually does move it, leads to messy, frustrating confusion.

Thanks in advance.
B

Bump.
Would love to know if this is planned, as it’s important to me.

Thx!

Please don’t bump threads – it’s considered bad etiquette on this forum. That said, I’m sorry for the delay in coming back to you (I was travelling last week for work and am still catching up following my return to the UK).

I would suggest you join such notes with slurs rather than ties, as you can have a glissando between two notes of the same pitch, just not on a single note that’s shown with ties.

Interesting… Haven’t seen that etiquette on any other forums, but okay!

The issue is really when inputting a large amount of MIDI from a Cubase. It becomes a pain to do this workaround, but I’m glad to know that it’s there. Please consider adding this ability in the future. It honestly does seem to me like this ability should be part of the program. Glissing away and back to the same note is a common thing, I’m sure I don’t have to tell you :slight_smile:

Thanks either way.
B

Please explain how you can gliss away from a note and then back to it without repeating the note when the gliss returns to it. That would suggest a slur is just as appropriate as a tie anyway.

This is about workflow. After importing MIDI from Cubase, I’d have to delete a bunch of notes and re-make them, just to do glisses. As Dorico, from my perspective, is really smart about speeding up workflow, this is not the best way to do it.

I wouldn’t claim to be an expert in every kind of idiomatic notation, but I do wonder whether it really makes sense to consider the starting and ending notes of the glissando as the same note, given that the pitch moves away from and returns to that note, so what meaning does the tie really add?

The tie isn’t really that important to me, but currently it feels like a lot of hoops to jump though because I can’t figure out how to only delete the tie on imported MIDI notes (and not the notes themselves), so I need to delete the notes, re-enter them, and then do my glisses.

Maybe there’s a better way to do this? That’s really all I’m looking for.

Right, I understand. Perhaps use the scissors tool to cut the tie (select it and hit U) before you add the glissando line?

Ah yes, that is much faster thanks!

Hello, everyone.

I have an issue that is somewhat similar, but a bit different nonetheless. I would like to gliss from a tied note to a different pitch over a barline. However, I am unable to do so, for some reason. I am able to put in a glissando if I untie the notes with the Scissor tool, but as soon as I put the tie back in, the glissando disappears. Is using a slur, rather than a tie, my only option here? I’m not too concerned with playback for this piece, so faking it works alright, but in future projects playback might be more important, so I’d really like that clarified. In the picture below, the two notes in the red oval are the ones between which I want glissando to occur.


Many thanks!

P.S. I have also been able to fake it by creating a note in a different voice and “hiding” it, glissing between the voices, and then shortening the “fake” note to nothing in the play mode, in order to remove it from playback. However, it’s still a workaround.

What happens when you try? I have no problems inputting the glissando. This is how it looks without any tweaking or workarounds:


Note: This was input without any use of Force duration, maybe that’s the clue.