Global Workspace, multiple monitors, maximised windows (Win 10)?

Hi

I’ve just got a 2nd monitor. My 1st idea is to have the main window in the main monitor maximised, and the mixer maximised on the 2nd monitor.

I added a Global Workspace for that layout. But when I quit and re-opened Cubase (10.5, Windows 10 Pro), the mixer window was maximised behind the main window, both on the main monitor.

To get back to my desired layout I had to:

  • Switch to the mixer window
  • Unmaximise mixer window - it pops onto 2nd monitor at this point
  • Maximise mixer window again - it maximises on 2nd monitor (desired behaviour)

Is this a known “Oh God Cubase, it’s like literally 2020”, or is there a way I can fix it… or is it some weird Windows mess I’ve got myself into (EG I changed which monitor is the primary, from Windows’ point of view).

Thanks!

Hi,

Unfortunately this is one of the known old(er) issue.

Hi,

as a work-around, you can create two dual-screen workspaces with the same windows/editors, but inverted. Let me elaborate.

I also have a dual monitor setup:
25601080, bottom, set as main monitor.
1920
1080, top, set as secondary monitor.

Saving a workspace with MixConsole -> top and Project -> bottom will behave as you describe when recalling it after reopening Cubase.

If you create two such top-bottom workspaces, recalling the first one will fail, but recalling the second will work and place the windows correctly.
From that moment on, dual-monitor workspaces should all be recalled correctly and allow you to switch between them.
In short, it happens on the first dual-monitor recall only - if you don’t need another workspace, you might just want to create a dummy one for that purpose. Not extremely elegant, but works here.

Fabio, thanks for this - you have pretty much exactly my monitor setup, so I’ll step through your advice and hopefully that’ll help. I don’t mind hitting a couple of hotkeys when I start Cubase, that’ll be quicker than switching to Mixer and mousing round the screen resize buttons.

Don’t forget that you can use macro to avoid hitting shortcut key twice :wink:

http://winsize2.sourceforge.net/en/

This program runs in the background on windows. It’s free. In short: with a keycomand you can " store" a windows position. You can also edit what happens, always (the window is not movable) or only set to the desired position when opened. I use it all the time, for example for forcing plugins to open always at a specific position on the screen, this works great, even when the file comes from another computer. And to keep cubase project, transport and mixer windows where I want them.

https://www.steinberg.net/forums/viewtopic.php?f=250&t=120512

Unless this only applies to Mac, or I don’t understand the issue, there is no issue here, and there never has been an issue with this.

3 monitors wide screen 2560x1080. Project page in one, mix consoles in the other 2. (The Cubase menu is included in the Project Page. All 3 are maximized (windows)

Since the OP is using only 2 screens I’ll do the same.

  1. Set up Project Page Window on monitor 1. Set up mix console 2 on monitor 2…both windows are maximized.
  2. Workspace>add workspace> global workspace>testing, then press OK.
  3. Quit (no need to save the project)
  4. Open Cubase 10.5 latest version, Steinberg hub opens, choose my default project to open.
  5. Workspaces>testing

Workspace opens exactly like it should. Project page on monitor 1, mix console 1 on monitor 2.
There is nothing behind the Project page.

So what am I doing wrong?..or I mean right? :smiley:

So what am I doing wrong?..or I mean right?

Same here workspaces always working right with 4 monitors extended and non extented windows… But I’m on windows :wink:

I have never used workspaces per se, but i have three monitors (main project on monitor one, second - mixconsole 1, third - mixconsole 2) and it stays that way because its saved in my selfmade startup template. So since all projects origin in that template, all three monitors are in use and my windows configs (including plugins) stays inplace in all projects.

Hi,

You are probably right, this issue is Mac only.

I’m on Windows and can reproduce it 100% of the times without fail.
Keep in mind it might occur only with different screen resolutions at play, so not everyone will see this; I don’t in a 3*Full HD horizontal layout.

Have you tried moving the menu bar to the monitor where you want the mixer to appear?

Workspaces dont work here correctly on a 4 monitor setup with a matrox multi-display card. The monitors work with a non HD screen resulution.
So Fabio might be right and the behaviour might depend on certain factors. THe deeper lying cause might be in the way cubase does window handling (including the menu bar window…). I suspect this because when I move the menu bar to a separate 5th display and open all other windows on the other 4 screens the workspaces work correctly…
Cubase btw. is the only application here that does not handle the multi-screen thing correctly.

Please do not neglect non-HD and non-4K screens.

This program is amazing! It took a while to get to know but now, when I open any mixer it opens maximized, audio editor, pool window and media bay all open the same size and place not to mention so muck more.
Thanks jb

There are so many variables here it’s hard to guess.

Would monitor placement, vertical vs horizontal and corresponding Windows 10/video card settings make a difference?

Good to know your solution was to move the menu bar to a separate 5th display and it works correctly.

With my current 3 screen horizontal set-up using 3 34-inch 2560x1080, all from Matrix GForce GTX 1070ti…I had all kinds of initial problems setting them up properly. It took a few days, and finally a customer service call and the 1st tier support person said “are you sure you are using the included HDMI cables?” I thought why open up new HDMI cables when I have ones already in place? As it turned out I learned a lesson the hard way…there are different versions of HDMI cables. I’m not used to cable versions when the pins are identical :laughing:
https://www.lifewire.com/hdmi-facts-high-definition-multimedia-interface-1847337

On one of my older systems.
Windows 7 64. 4 identical 18 inch monitors side-by-side set up 1280x1024. Gforce 750ti? I cant remember for sure.
They worked almost flawlessly for years. The one issue is that I was forced to plug 3 of the 4 into my GForce, and the remaining one into the motherboard video out. Intermittently I would get screens in the wrong order. The solution was to unplug, plug back in and it would usually correct itself. My PC builder said he didn’t think it was a good idea to use both motherboard video out and GForce outs. I think he is right.