Go to left locator - auto-scroll problem

Not sure if this can be seen as a “bug” (I think it is), but it at least can be quite annoying.

I use my shortcut to “go to left locator” of a song. It goes there
Now I zoom in using mouse wheel somewhere in middle/end of song.
If I again press “go to left locator” nothing happens.
You could say “well the cursor/playhead is already at left locator”… but I think the focus/view should go there too

Sounds like you have Suspend Auto-Scroll when Editing active.

see Suspend Auto-Scroll when Editing

I think that this is a different key command. But can’t remember which…

With the pref noted above, you have to hit F (by default) to reinstate auto-scroll


Auto-scroll gets suspended if you are editing when the project is rolling so I am really appreciative of the info to use F. I didn’t know that/or forgot it.

…unless you deactivate Suspend Auto-Scroll when Editing…

1 Like

I forget this all the time! I just did yesterday, which is why it’s at the forefront of (what’s left of) my mind!

Ok try this, just to see what I mean in action.
Put the playhead at a late part of a song and zoom in.
Use whatever shortcut you have for “go to left locator”. Both the view and the playhead goes there. All good..
Now (while still zoomed in): scroll horizontally, just away from the left locator so you no longer see it.
Again, use whatever shortcut you have for “go to left locator”.
Nope. The view stays where it is.

Because “the playhead is already at the left locator” I guess
But in my mind the view point should also bring focus to to left locator, hence “go to”. Right?

Pressing F twice does get the view focus to where the playhead is.
I just wish I didn’t have to do that on top of the go-to shortcut

Could you start Cubase in Safe Mode and try the same steps to verify that this is not caused by settings corruption?

Well I’m guess you have more left of your mind than me.

1 Like

There must be something else going on here. I followed your instructions and expanded the screen out side the two monitors I use for the arrange page. My playhead is in the middle. I press 1 (Number) and the left locator comes into view with the playhead… I press 2 for the right locator and the view moves to that although the playhead stays in the same position on the screen. This still works when I am editing midi whilst rolling. What does happen is thatwhen I stop after editing the playhead is out of view. However, now that I have stopped the auto-scroll has reengaged and either I restart and the playhead is visible, or I press F twice and the the playhead is visible if I don’t want to restart.

The official shortcut for going to the left locator is the number 1 on the right of the keyboard and not the top left.

That’s what happens here as well.

You can also do a mordent on 1. 1, 2, 1, that will also work.

I would like it if it did scroll there, no matter what.

I have seen this problem, and when I disabled prefs in safe mode it started working correctly. Can you check?

Disabled preferences through safe mode, same behaviour.

I think a clear repro sequence is needed

I just followed @MortenT 's instructions.

  1. New project.
  2. Set LR locators by click and drag on timeline to measure 1 and 5.
  3. Zoom to locators. (This step is here to ensure we are on the same zoom level.)
  4. Scroll via Shift mousewheel to measure 50.
  5. Press numpad 1.
  6. Confirm correct position and scrolling to left locator.
  7. Scroll right via Shift mousewheel to measure 25, zoom in and out via Ctrl mousewheel.
  8. Press numpad 1.
  9. Result?
1 Like

Can’t repro.

What color is the Auto-Scroll icon while you are doing this? Does it change?

Is Suspend Auto-Scroll when Editing active?

For me it’s same behavior, wether suspend auto-scroll is enabled or not.
I guess “go to” means “playhead go to” not “view go to”, but it should do both


Auto scroll is on, either page scroll or stationary cursor.
Suspend auto-scroll when editing on or off.

Same behaviour under all conditions.

Numpad 1 is pointing to Transport → Go to Left Locator in key commands.

1 Like