(Google Issue) Cubasis 3 not working with ur22c on Android

Hi, i am not able to get any sound when picking the ur22c as as my output. When i try it stops working completely until i restart my phone. I’m using a galaxy s22 ultra.

Is this expected behaviour or does the ur22c usually work for Android? Is the ur22c even suppored on Cubasis?

Many thanks

1 Like

Hi @jotty1993,

Thank you for your message.

Please note that Cubasis for Android offers limited audio and MIDI hardware support only, Steinberg does not currently guarantee full compatibility.

Furthermore the performance and available options are strongly related to the Android device in use.

Please have a look if the following tips are helpful to make the UR22C work with your Android device in use:

  • Try another cable
  • Use a very good USB-B to USB-C cable instead of the OTG adapter
  • Quit all apps
  • Restart device
  • Try both sequences: First start Cubasis, then plug in the audio device, or vice versa.
  • Update Android
  • Disable Setup / Audio / Studio Quality
  • Is the UR22C selectable in Setup / Audio under Output Device and Input Device?

Please let me know if this helps to resolve your current issues.


Thanks, I’ve tried those suggestions. None of them have helped unfortunately. The device is selectable in Cubasis as an audio input and output.

Hi @jotty1993 again,

Thanks for your updated message. We are sorry to read that the tips have not been helpful to resolving the problem.

Our engineering successfully uses the UR44C with the Samsung Galaxy Tab S6, connected via an Apple USB-C cable.

Please give it a try, if disabling “Multi-core Processing” (located under Setup/Audio) helps to make it work.

In addition, please let us know what Android version you have in use.

If the problem persists, it might work to check things again with the next Cubasis update, which is planned to be released this month.

Please keep me updated!

Thanks in advance
& stay well,

Disabling multi core processing doesnt seem to fix it either. I am running Android 13 on a Galaxy S22 Ultra (Exynos).

I will look out for the next update, hopefully that fixes it.

I have the same problem with the UR-44C
It appears in the Output Devices but cannot be selected.
I’ve read about this problem here quite often and Steinberg should gradually realize that it must be a bug in Cubasis!

1 Like

Same issue with Samsung Tab A8 and A71.
But same setup works on Moto Edge 20.
All of them are Android 13.

With Android 12 Cubasis worked nicely on the A71.

Funny part is that nTrack studio seems to work with the UR22C on all devices!!!

I did my post too.
They have to fix!

UR22 not working here either. It’s selectable in the Cubasis menu however the sound still comes from the phone speaker after its selected. Please look into this Steinberg

Why can’t it be that all steinberg audio interfaces like ur22 or ur44 don’t work?
I only get the sound through the Samsung internal speakers even though the UR44 is selected for input and output. Steinberg should get to the bottom of the matter seriously.
I’ve tried everything Steinberg recommends. Spent €150 on different cables and connectors but it doesn’t work. I’m starting to regret buying Cubasis and the UR44 :frowning:

The funny part is that with some other Android apps (like the n- Track daw) they works nicely.
Ah and also with Linux running Ardour.

I mean with UR-22C via USBC with mic on ch1 and guitar on ch2.

Hopefully is just something around Android13 release that they can fix.

Hi all,

Thanks for your message which has been shared with the team who is currently evaluating the problem. We are sorry for your inconvenience and hope to be able to provide a feedback soon.

Best wishes,

1 Like

My cubasis 3 hasn’t been working for 3 weeks now. I usually record using my galaxy z fold 3, plugged into an audio interface via type c usb to type c usb. Ever since I updated my phone, I have been unable to hear any playback of any sounds except what’s coming through the mic at the moment of playback. Please help with this issue. I can not record on my favorite DAW

Still not working after the December update. In fact, seems worse.

Cubasis and the interface are a huge waste of money for all of us at this point. Disappointing considering both are made by the same company and work flawlessly on Apple.

I’m hoping Steinberg are able to address this as it would be an extremely useful tool if it worked.

My case:
Redmi Note 8T - snaprdagon- output work with ur22c with latency min14 max 54. Input apear but dont record
Galaxy Tab S6 lite -exynos- output work with ur22c with latency ~500ms. Unusable

Hi all,

For all users using external audio devices with Cubasis 3 on Android 13

Google introduced the issue with their newly added MIDI 2.0 support in Android 13, and are working on a solution. In parallel, we aim to provide a workaround solution in the upcoming Cubasis 3.5.1 update, via disabling the MIDI I/O function.

In the meantime, if you’re still on Android 12 and use Cubasis with an audio interface, we recommend holding off on the Android 13 update for now.


1 Like

Today, after some weeks I decided to try again to record two guitar with Cubasis 3 on Android (version 13 on a Samsung A71) and Ur22C.
I found that finally works, but not at the first try, only if I power the UR22C externally (with micro USB) and then I connect the USB-C and start Cubasis.
Finally I spent some ours with no issues at all!

1 Like

xiaomi mi12t pro
android 13
cubasis 3.5.2
nux mp3 as a sound card
midi device i\o off
no midi in((((
audio out is working)))

midi device i\o on
no audio((((
midi working fine))))

can i have midi and audio working at the same time please?

also same setup but with uteck extarnal audio card - all works fine, audio yes, midi yes))))
but uteck doesnt have all that cool fx guitar stuff as nux mp3((((((

redmi note 8
cubasis 3.4.3
android 11
nux mp3 as an external souncard
all works fine: midi+audio
but with greater latency
it says same 14-15 ms but sounds with a greater latency…

Hello there. I’m using the Sony Xperia 5 IV (XQ-CQ72) with the latest Android 13 (64.1.A.0.929 release-keys). I’m having the same issue when I try to connect my UR22C to my phone in Cubasis 3.5.2: either there is no audio or no MIDI (when switching MIDI device input/output on/off). Additionally, my phone is unable to route audio from the UR22C to Instagram for livestreaming. Every time, the audio is cast from the internal microphone. Is there any solution to force the Android phone to use the MIDI 1.0 protocol if it’s causing the problem? By the way, all the features of the UR22C are working properly on my OPO 5T (Android 10 stock firmware): Cubasis and Instagram recognize the device and route audio properly.

Hello leonardosalvatore.
You mean that if you power UR22C externally, in that case both audio and midi input from UR22C is working properly?

Hi all,

Google introduced the following issue with the release of Android 13:

Could the same issue leading to your audio interface issues?