GrooveAgent 5 "Instrument" option does not display drum parts

GrooveAgent 5 “Instrument” option does not display drum parts.Reinstalling the software does not solve the problem,and my library is the latest version.
GA5SE can read instruments correctly, but the full version of GA5 cannot…
Is this because some settings have been changed? If it’s a bug, how can I tell the strinberg software engineer to fix it? This problem has been bothering me for months, and I really hope to get help!



Please make sure that Groove Agent 5 is up to date. Click the Groove Agent 5 logo to the top left to check which version you have installed. The current version is 5.1.11.

Also check if the Steinberg Download Assistant is offering any VST Content updates. These will show up above “My product downloads” if any are available.

Then follow these instructions, replacing “HALion Sonic SE_64” with “Groove Agent_64”:
https://helpcenter.steinberg.de/hc/en-us/articles/115001720190-FLUX-Wavetable-Synth-missing-in-HALion-Sonic-SE-3

dont you need to load a kit in order to display and hear? try loading beat agent into the slot. then try.

The topic starter is referring to the Instruments tab in the Load panel. This tab is supposed to allow you to load individual pad sounds (like a single kick, a single snare…) to make it easier to build your own drum kits. This tab isn’t working for him for some reason, instead showing the full drum kit presets.

I tried it, and when I drag a list instrument onto a pad, it automatically loads beat agent into the first slot.I wonder if OP has enable a lock of some sort.

Your column filters have reset to factory defaults somehow - maybe after an update.
In full GA, change your filters on the Instrument tab to Sub category etc, just like they are with SE, and your drums should reappear. If they’re still missing, check to see if the VST Sound folder in MediaBay has become unselected, and tick it if it has.

Hello, I followed your first instructions, but I still couldn’t see the individual instrument.
And I don’t know where the mediabay path is. Can you tell me more details?

It works!Now I can see and replace the instrument pad with individual instruments. Thank you very much!

Hello, I deleted the corresponding file according to the instructions you gave, and GA5 still seems to be unable to read individual instruments in some cases.

Then I tried to delete all the “.xml” suffix files under this path, and found that GA is now working properly. Thank you very much for your help!

I’m experiencing the same problem. I see the kits, but I cannot see the instruments. I remember that I used to change instruments on the pads easily since I just had to search for “clap” or “hihat” and could then browse through the different sounds.

Now, it does not do that any more. The idea of deleting said files has not improved anything for me. All the latest updates of everything are installed.

Any other ideas?

Please try to delete all the selected files in my screenshot.

Then run Cubase12 again.

1 Like

Thanks for the quick reply. I had done so but it was of no awail. I’m currently reinstalling everything as a last resort.

I problably should mention that I’m only using GA5SE.

Ok, I’ve reinstalled everything and, as you suggested, deleted and restarted C12, but still, there are instruments visible in my screen.

Please make sure to close Cubase before deleting the contents of your "Groove Agent SE_64"folder.

Did you unregister/remove the libraries from the Steinberg Library Manager first before attempting to reinstall them? Are you sure you have the latest version of the Groove Agent SE content?

1 Like

If you only use GA5SE, you can try to delete all the “.xml” files in the GA5SE folder.

If it still can’t read the instrument, then I don’t have any other solutions.
I’m sorry about that.
I hope you can find another solution.

1 Like

Yes, I removed them completely from the Library Manager and also deleted the downloaded files and redownloaded them completely from scratch. Cubase was not running at that time.

@wnlyt Yes, I’ve resorted to this folder since the other one does not exist without GA5.

Thanks!!