GrooveAgent 5 "Instrument" option does not display drum parts

Good luck! I’ve been struggling with it for almost 2 months now. No answer found on the forums and no answer from my support request either; They just don’t give a ■■■■. I’m on Mac OS someone told me on reddit that perhaps Ventura would solve it but I really doubt it will do anything…

I’ve also uninstalled / reinstalled everything but nothing works… It started when I bought GA5 full version I think. It worked the first time I used it then it never worked again…

1 Like

Holy trout ! Thank you! In fact this works great as a work around. Even if the sounds don’t show in GA5 and you can’t pre listen in place going though media > Soundbrother allows you to drag and drop on GA5 pads! Thanks!

2 Likes

Wow. I have the GA5Se Load Panel showing me the individual drum sounds. Not sure why, because I didn’t change anything since last time I tried it.

  • I did have to set the column headers manually. I have sub-category as the first column now, sub-style as second, and nothing for third column.
  • I did have to click on “Rescan Disk” after that, so that it would show the sub-categories.
  • And unfortunately, “pre-listen in place” is not working correctly. Neither are any of the buttons next to it. The little area above the buttons, keeps showing the same sample name.
  • So I have to commit to the individual drum sounds by double-clicking them. And then it gets loaded on the selected drum pad. And I can play it from there.

Still not quite what it should be. But it is an improvement. And it suggests to me that somehow it should be fixable. Annoying however that it isn’t more user-friendly to get it working correctly.

1 Like

Hi everyone.
I have this exact same problem.
I read all the comments and i see there is no “fix” for this yet.
I cant recall since when i started having this problem but is not for a long time.
It´s terrible not being able to change/swap individual instruments from the browsing panel.
I unregistered the soundbanks, i uninstalled and re installed GA5, i deleted preferences and nothing seems to work. In my GASE5 all ok.

Windows 10 20h2
Cubase 12.0.50 (updated today)
Groove Agent 5 .1.11.176

I think i found something related to the problem that migth help

1 - Open control panel, add/remove programs and uninstall all grove agents (Full and SE)
2- Install ccleaner and run a few times the registry clean (scan for issues - review selected issues, will ask for a registry backup say no, fix issue)
3- Reboot the PC (very important)
4- Do a fresh install of Groove Agent 5

When you open GA it will display everything OK. As soon you open a project that was “buggy” GA no longer behaves normal. It has to be something related to previous projects and maybe Cubase updates.

Replacing the preferences from the GA Standalone to the plugin version under %appdata% folder makes it ok, till you open a buggy GA project.

That Saved me from Madness today, thank you!

That first helped. (Ableton Live, GA5 VST, Windows 11)
Closed the DAW, deleted all of the directory content from the windows11 directory.
“C:\Users\username\AppData\Roaming\Steinberg\Content\VST Sound\User Content”
Started Live and a new project. GA5 now showed all instruments.

But when I opened a project which has crashed and had to restore, the same problem.
No instruments, onlz kits are shown.

Thank you very much though

Btw, this is definitely a regression, because I installed an older version of the plugin and it worked as expected.
The worse part is that I couldn’t even use Steinberg Download Manager to get the older version, I had to download it from an unofficial webstie.

Guess what, it’s now 16th Feb 2023 and the problem has still not been solved.

I’ve got the same problem,it’s pathetic.

I deleted Groove_Agent_64 preference folder. It will create a new one when you load Groove Agent. It worked for me.

They closed my support request without providing a solution! So I started a new one.

At this point I can’t believe they are not aware. They’re probably working on GA6 and won’t be solving this, my guess.

I think I’m going to file a complaint on the european consumer protection service. I didn’t pay for something that is only half usable.

In my side, I have deleted the subfolder:
C:\Users"your user"\AppData\Roaming\Steinberg\Groove Agent_64
I reload Cubase, then Groove Agent 5 recreate all xml files and that’s ok now!
I can see the correct content list of intruments (kick, crash, hihat etc.)
… some times further…
Hem… yes it was working on a new project but ! With my previous one the same result.
So I tryed to update the default.xml file to find the issue but the first time ok but then… the same!
Finally I found a workaround when I select only (not all) but only one instruments sets!!

I think I found something. I decided to try and load cubase from another session on my mac. So I booted the guest session and launched Cubase. It asked for my account / password and boom everything works as it should! What is different? The software scanned folders that it no longer scans on my session. I had to click OK at least 20 times because it couldn’t find some softs and was scanning every directory. My guess is the one on my session doesn’t scan everything and yet one file missing in there is provoking this mess.

Hey ! After 6 months. I’m the bearer of good news. I feel like the GA messiah, I have finally resolved the problem and this involved absolutely none of the various solution proposed anywhere and absolutely without steinberg customer service being of any help.

Long story short :

It start like some other solutions. (I’m on iMac M1, but I guess this transposes to windows too?)
1- Close anything Cubase related
2- Go to library (cmd-shift-L) / Preferences.
3-In there remove both Cubase and Groove Agent folder. Not just some files, THE WHOLE folders and empty the bin.
4- Launch Cubase. The software will now rebuild everything properly BUT don’t go and open an old song yet.
5-Start a new project and try to add a groove agent track. This should work. Save the project and close it.
6- Now you can open an old song and the GA in it will be bugged. Don’t play anything. Now you’re going to ‘repair’ your track.
7 (optional)- If you made a custom drum kit and want to keep the settings then save your kit’s settings so you can recall them in another instance.
8- Create a new GA track and load the kit you’ve just save from the other track.
9- Drag your midi part to the new track.
10-Remove the old track.

You’ll see that everything works fine.
Reinstalling libraries or even Cubase won’t change anything. I’ve tried. Just do these 10 steps and you’ll be good to go.

Longer story :

I had tried everything and I gave up. But earlier this week my wife ask me if she could use my iMac and I made a session for her. I thought “What if I tried launching cubase on her session?” and everything worked perfectly. I started to think it had something to do with the files and folder that are created at first launch so I decided to find what these files were. And I didn’t find anything.

So I started enquiring “cubase factory reset” as this basically the same as launching from a new session. Going through various threads I found someone talking about removing the whole cubase folder and how it would reset the software. I felt this was it and gave it a try and boom it worked. Interestingly re-installing doesn’t work even if this could be considered as a factory reset too. I have no answer for that, maybe some files are staying when reinstalling I have no idea.

Anyway it works and I’m happy.
I hope this helps !

1 Like

Really helpful, Jojo- it worked! On PC, step 2 is:
C/Users/Username/AppData/Roaming/Steinberg/ .

Thanks!

1 Like

I’m happy this helped! Thanks for sharing the windows version for step 2

Jojo,

I thought this worked but actually, I discovered that GA is just no longer looking for the Instruments and other presets for the various kits.

1 Like

Jojo-lafrite… It’s been a week since I tried your solution, and so far it’s worked for me. Thanks for taking the time to share!