Halion 7 - factory presets with red circles

Halion 7 doesn’t list any programs. I can load them via the Cubase 12 media bay though.
Any ideas?

Update: they just appeared, but a lot of them have a red circle next to them. e.g. all B-box presets. They load fine through Cubase media bay though.

I can delete all the non-working ones and drag the working ones in from Cubase media library.
What a mess!

Please run the Steinberg Download Assistant and click the About button to the top right to make sure that the “Steinberg MediaBay” is being installed. These are the current versions of all supporting programs:


The Download Assistant should also show updates for the Halion factory libraries under the “Updates” category.

Yes, my About window looks the same as yours.

Update 3:
After deleting the non-working programs, they just get picked up again. (screenshot)

It’s possible that you have an outdated version of the library. Please check Windows’ “Programs and Features” panel and make sure that no Halion content is listed there. The content is now managed exclusively by the Steinberg Library Manager.

Can you check the what’s the library version shown by the Steinberg Library Manager? These are the latest versions of B-Box and World Percussions:

No Halion Content installed in Windows. The versions of B-box & World Perc in the Library manager are the same as in your screenshot.

I only have this issue with the following libraries:
World Instruments
World Percussion

All the rest works fine…

I tried removing them in the Library Manager and installing them again from the downloaded Halion 7 Content. Doesn’t help.

There’s a readme as part of the download, and i’m sure if you’re upgrading from old version you have to download the updates for a lot of those libraries - it will show as the top item in the Steinberg download manager. Update / VST Sounds.

Don’t go messing about with your libraries or you’ll cause more harm than good being that there’s different versions out there.

I did the update in the download manager.

If you open the details up in Library manager, have you got them all in the correct place? Some libraries have a preset file and a sample file. I messed mine up last week, and had to re-download everything after I tried manually moving them around.

Just decided it was easier to wipe the lot and download fresh. :frowning:

Yes, the path in the library manager is the same for all libraries (working AND non-working).

I haven’t moved anything manually.

Have you tried dragging one of those .vstsound files already listed onto the download manager? It will recheck the contents again.

Dragging doesn’t work (Windows). But like I said, I’ve tried removing one and installing it again.

All of those libraries were introduced with Halion 5. That’s strangely specific.

A bit of a shot in the dark: Close Cubase, run the Steinberg Activation Manager and click the refresh button to the top right.

You can also try the following to force a full MediaBay rescan:

  • Open the “Run” command prompt by pressing the Windows logo key + R simultaneously.
  • In the command line of the “Run” window, enter the following path shortcut:
  • A new Windows Explorer Window opens.
  • Open the “Steinberg” folder.
  • Delete the “Steinberg MediaBay Server” folder.

Next time you start Halion 7, all of your libraries will be rescanned.

I restarted my PC and everything’s fine now! (I have no idea why that solved it)
Side effect: the initial scanning of libraries when first loading the plugin is now also a lot faster.

Thank you Romantique_Tp and skijumptoes for trying to help!