Heads Up! New update - Plugin Alliance crash Cubase PRO8!

Hey guys, I had to reinstall my whole system Windows 7 x64 professional from scratch-coming from Pro Tools9/10/11-and wanted to start working in Cubase 8.5 now. EVERY SINGLE PLUGIN OF PLUGIN ALLIANCES I OWN (Bx hybrid v2, bx dynEq v2, bx saturator v1, spl deesser, spl deverb, vertigo vsc 2, elysia musec, elysia alpha, bx boom,bx stereo maker, bx opto) makes the daw either freeze or there is simply no sound, continuing disc cache peaks, cubase crashing (ntdll.dll) delayed sound of single tracks, distorted sound of single tracks, white noise peaks on single tracks. In other words its a desaster.

Is there ANY workaround to get into a mix project including the mentioned plugins to bounce the single tracks for using them in another daw?

ANY help is much appreciated

Respectfully ML

Been having crazy issues with newer versions of BXv2 and Stereo maker here myself, they’re running some great deals at the moment too but i’m reluctant to partake for obviuous reasons.

I’m using an older version of the plugs, 2.5.2 which seem to be fairly stable… ish… you could ask them for earlier versions, if available, and try those.
PA have been aware of this for quite some time now though :imp: :imp:

I am in contact with them. Hopefully they send me the legacy versions, the only question is, which one? I ve asked for the version dated to the end last year /beginning of 2015.
2.5.2 running stable, meaning no peaks etc?
I was interestet too in some new things they are offering. But under these circumstances I defenitely wont buy anything until there is an OFFICIAL fix/patch/whatever.

Greetings ML

Seems to be ok here… apart from the vst2 versions just don’t seem to want to show in cubase despite checking the path to them is correct, also if i accidentally click on the ‘key’ icon on stereomaker it will crash cubase…
I’ve been in contact with them since early this year so they’ve known about these issues for quite some time now.

I recently bought the bx_boom plugin (it was on sale at a really good price), it too has a problem. When loading it as an insert, or changing a preset, it seems to randomly freeze Cubase, and loads very sluggishly.

I’ve pretty much given up on a fix with these products, the support is very nice but nothing gets done about these issues. I use the older versions where possible.

Is there an offical web site where we can download legacy versions of the plugs?
bx_meter version 1.3.2 works, new version crashes Cubase…

Not as far as i’m aware… try contacting their support, that’s how i got mine.

Ok thanks, got a email yesterday by jeremy about an older plug for bx_meter.
bx_meter works now, but i want to get older stuff from my other plugs.
i’m going to ask jeremy again…

Now i got all legacy versions by jeremy. Well done.

I hope PA gonna fix these issues as sonn as possible.

I’ve had some dialogue with Jeremy for some time now regarding this… It seems it’s related to Win7 from what he tells me… reading between the lines here… i kind of got the impression it’s not going to be sorted for Win7 so we’re all going to need to move to Win 10 to get a resolution… he didn’t come out and say that but that’s the impression i got…


unfortunately I didn’t go very deep on this one, I only have PA on my home DAW and have had time restrictions… but I only have problems with recent PA builds in conjuction with FabFilter (my FF versions might need to be updated). When both are in the same project, FF GUIs / meters become very sluggish, to the point of freezing and eventualy crashing Cubase - sometimes the crash occurs just operating PA plugins, without even opening a FF GUI / editor.

Using older PA builds (I still have a few SPL, Elysia and BX which I didn’t update), the issue is not there. If not used in conjuction with FF, newer PA builds do not show issues as well.

This is on a Windows 8.1 x64 system. I didn’t test it in neither Win 7 nor Win 10 at this point in time.

So none of the current offerings by Plugin Alliance are working on Cubase 8.5 with windows 7? I was about to pull the trigger on a couple and saw this thread.


That’s how it seems yes… i’m running older installs of the plugs i have but i tried the BX V3 and it played havoc on my system as do all of their most recent installs…i’d like to take advantage of the deal they’re offering on UAD plugins too with the SPL transient designer but it’ll just crash my system… it’s been going on for quite some time now too

From what I understand UAD is not officially supported under Win10 yet either?..?

I didn’t realize UAD was affected as well! Can anyone else confirm this?

The issue might be specific to the other plugins you have loaded in your project. I had one project where the SPL Transient Designer worked just fine. That project loads only SoundToys, UAD, and Plugin Alliance. I have another project that adds FabFilter and SoftTube plugins and all hell broke loose. I managed to recover it after dozens of crashes. Good thing, I really needed to remix it.

The UAD SPL Transient Designer works just fine for me, I’ve yet to have a problem with it. I’m not running Windows 10 though, locked on 7 for at least another year.

BY Luck I’ve found this fantastic Thread!!!
I was getting crazy. Weeks spent trying to understand why my system had such an extreme behaviour.
I could not work on my projects during this time:(

I simply can’t believe that PA plugs were responsible of my system destruction :imp: :imp: :imp: :smiling_imp: :smiling_imp: :smiling_imp: :imp: :imp:

This should be sticky and a clear warning to everybody.

Sorry for the dumb questions here … are the plug-ins themselves the cause of these problems, or does PA somehow mark them for trouble when they act as the middle man?

I’m on W10 … is all this a moot issue in that OS? … has anyone gotten rid of problems they had in W7 when they moved to W10?

Thanks -

I suspect PA’s ‘protection’/licencing system, or the installer, because these plugins are produced by quite a few different developers.

I’m on W10 Pro x64, occasionally an audio track will freak out with white noise at the same point in the track, if I scroll back, hit play, I get the noise at the same point again and again. If I scroll past (forward) that point and hit play, the noise does not appear, even if I go back past the point where it happened before.
It seems like something is ‘marking’ that point in time on the audio track, weird.

Thanks Mauri. Wow, even on Windows 10. How can they keep selling/advertising when they know their product is broken? Seems at a minimum at least a little bit unethical.