Hello, I have tried 'midi remote' custom map Frontier AlphaTrack, but I failed

So, I have myself 3rd party driver for mac osx from Synclavier and this Alphatrack manager app allows me to choose:

  • AlphaTrack Native
  • ProTools (HUI)
  • Live (MCU)
  • Logic
  • Final Cut Pro (MCU)
  • Soundtrack Pro (MCU)

My first thought was,
AS LONG AS I can make Cubase 12 Pro and Alphatrack communicate through Midi ports,
it should work, so I did.

Midi Remote editor read Alphatrack (though its NATIVE driver does not get recognised on mac cubase since original developers have never developed it sadly…)

But when I attempted to assign each keys and buttons and one motorizing fader…
Cubase simply does not recognize it…

Do you think Cubase is not yet ready to fully communicate…?
especially old USB midi controller such as my Alphatrack…?

I am on mac osx mojave 10.14.6.

I have successfully mapped Komplete Kontrol S25, I know when I move each button/key/knobs cubase instantly ‘recognises’ it and then assign every single ones.

But with Alphatrack it just does not work and only cubase recognises is one moving fader.
So, one button for ‘touch’ part, another button for fader value and another one(?) surprisingly cubase mistakes as if it is another on/off button.

PERHAPS… alphatrack’s midi communication is a little complicated…?

My hunches:

  • Cubase MIDI remote not yet fully support HUI protocol.
  • My Alphatrack HUI driver is not stable.
  • This 3rd party driver does not have Cubase implemented driver protocol… so maybe that could be the reason?

Very strange. Only fader is recognized and all other buttons/transport buttons/ knobs do not get ‘added’ onto the custom midi remote editor.

I am not familiar with the AlphaTrack, but here’s my “shot in the dark”:
THere seems to be no “mode” of the Alpha Track that simply allows to send and receive midi commands. Instead you have (as the manager app’s choices seem to indicate) “special protocols” . Controllers that are connected to cubase this way and interact with cubase this way are not supposed to work with the midi controller editor (one might be able to program appropriate scripts manually)! These controllers in those modes communicate with their pendants on the computer side that can handle the protocol. THis is why they are set up separatedly in the midi controller section of the studio tab!
Just my 2 cents

1 Like

I’ve been dying to know more about it, had a little hope on Cubase 12 Pro, but now, I am finally letting my Alphatrack go for good :slight_smile:
I am sure you are right… this thing is too old and developers did not update anyways…

Yeah… I think I will just keep it for my old PC… which has cubase 5 there…

Wish it worked, but yes, 100 percent no-go on OSX cubase. (*Though I hear it works on windows cubase fully)

Hi you,

I used to have one of the wireless remotes from Alphatrack - at some point in time the drivers were not working under windows any more. So I gave it away. Some months later someone offered a solution that could make it work (again)…
Things like that are a pain generally - since we all get used to our hardware (especially controllers) and it always takes a certain effort to get familiar with a new one - at least for me. Compared to this the extra money we spend seems to be neglectable … but well… sometimes this is how things are.
All the best!

1 Like

Most definitely! Digital gears, come and go :slight_smile:
Perhaps that is why old engineers and new too, they prefer main gears to be ‘analog’ hehe.

I thought, Alphatrack was really ahead of its time, for a single motorized fader unit, with its capability of controlling, ‘stock’ EQ, vst plugin parameters etc… but, yeah! I mean I do actually own enough good ones including MC MIX, BCF2000, Maschine mk1, Komplete Kontrol S25 (this now, can work with midi remote controller as Quick Control unit! simply wow…!)

Yeah… so this time, I hold nothing back and I will just keep Alphatrack as more like a souvenir haha…


Oh you are welcome!
I suggest you “monitor” the thread and maybe repeat your issue here in the forum. It happened again and again in the past that things that seemed NOT to work over time changed into something that DID work - because of some helpful user that found a solution!

1 Like

Yes I will Elien! Thank you so much for being super kind :slight_smile:

I seem to remember that i had to have it in native mode to work with Cubase. But that was with its own device entry though you could customise some of the buttons.

It might be that if native mode is not working then thats the issues. But thats just my guess. I was using it in windows at the time, running it in windows 10 but using Windows 7 compatibility mode.

I have never tried it with C12.

This guy did some amazing work customizing a control driver for the AlphaTrack to work in Cakewalk Sonar and Reaper. He might be a good resource to answer questions about the AlphaTrack.

Wow… wow… I have just read one post related to ‘Alphatrack’ and… seems to me… better off just giving up. Speculation was right. Alphatrack’s native protocol should be decoded/re-encoded etc by programmer… also AZSlow cautiously mentioned about API and I think doing this can be risky… (due to licensing problem?) But yeah… I guess ‘Synclavier’ guys’ latest 10$ driver was the only hope ‘and’ it still did not have ‘Cubase’ integration driver but Protools, Logic, Live etc…

Thanks! AZSlow seems to know the answer already :slight_smile:

Yes, no! :slight_smile: oh, on Windows unlike Mac, it still can work natively without any limitations…
only on osx it never had its ‘native’ driver developed (64bit one) by original developers.

And… I (dummy) bought it 2 years ago, thought, it would work lol…

Though I tried it out on my old PC cubase 5… I was surprised how it can be so~~~ handy.
It has transport/stock eq editor/plugin editor/motor fader… yeah… sad to let this one go.
Such a shame. Even till this day, no one motor fader has all functions as this one :slight_smile: ha…

After the announcement of Cubase 12’s midi remote function, I got excited to try it out…
and yesturday, found out, Alphatrack has its own protocol that is not typical MIDI so…
C12 just does not recognize it well…

1 Like

There is, it’s referred to as “native MIDI mode” in this document (direct PDF download).

The AlphaTrack can be set to “native MIDI mode” by sending this sysex string:
f0 00 01 40 20 01 00 f7
Once that is done, all the controls send (and receive, where appropriate) standard MIDI.

This opens up the possibility of creating a Cubase MIDI Remote script for it.

Hello… I…

Do not fully understand… do you mean,
I can force my alpha track to be native midi mode?!
By sending sysex message manually?!?!

How do I do it?!!? So I don’t need no more driver?!

Also, Alphatrack does not have DIN midi in/out so…
How should I send that message through…?!

With which freeware program?

I do own a PC laptop, and a mac.

The AlphaTrack appears as a USB MIDI device as soon as it’s plugged in. On my Windows machine, for example, it shows up in Cubase as “2 - AlphaTrack”. If no driver for it is loaded, it defaults to “native MIDI mode”, so you don’t have to do anything. Plug it in, start Cubase, create a project, add a MIDI track with the channel set to MIDI channel 1, and select the AlphaTrack as the input to that MIDI track. Press some buttons on the AlphaTrack and you’ll see MIDI input activity.

Not for the AlphaTrack to appear as a USB MIDI device, no, however to be able to do anything useful with it in Cubase, you’ll have to write a MIDI Remote script for it.

On Windows, the most recent Cubase driver still works fine on Windows 10 x64. There’s no point in writing a MIDI Remote script because I can’t see how it could be any better than what’s already there. On Mac, yes, this is one way to make the device usable again, but it would be a lot of work.

You can try the attached Cubase project … you’ll have to figure out what the AlphaTrack MIDI input and output are called on your machine, on mine they appear as “2 - AlphaTrack”.
AlphaTrackPlayground.zip (16.1 KB)
This project demonstrates how to control the Frontier AlphaTrack using MIDI.

When the AlphaTrack is powered up, it is already in “native MIDI mode”, however it can be forced into that mode if necessary by sending the SysEx data contained on the (muted) track “AlphaTrack native MIDI mode”.

The AlphaTrack uses SysEx to write text to the LCD.

For activating the LEDs, note information is sent on MIDI channel 1, therefore the track “AlphaTrack play” is set to MIDI channel 1, and the MIDI output of the track must be sent to the AlphaTrack.

The documentation is on the Frontier website.

Ok ok ok…
But wait!

You are missing something!

To fully up to date, I am aware that it can be worked on Windows ‘but’ not on mac osx.

I bought the 20 dollars latest Alpha Track driver of Mac OSX that was actually for Digital Performer DAW… so… unfortunately, I still have that driver installed on my mac Mojave… and also:
I can choose different mode,

  • Native
  • HUI


But my question here is…

I ‘actually’ did try even, the ‘NATIVE’ mode of it.

So my last bet is, what you have mentioned, I need to force send that message to work perfectly as ‘native’ midi mode controller, do you now know what I mean?

Without doing anything, it will not work on my Cubase on MAC osx (different from Windows…)

So, since the device is USB-midi, how do you think I can send that message and force-making it to be native midi device as you have explained above?

THERE is no Alphatrack CUBASE driver for mac Mojave OSX 64bit <— not for 64bit.
So yeah… I think you are speculating this part…

So, that is why, the MIDI remote editing,
could not be done…? on my mac 64bit Cubase 12 Pro?
You see…?

But yeah, what you are saying would be correct!
if I can force send that sysex maybe I have hope…?

I don’t know what that is, but it’s not an official driver for the device.

The Frontier AlphaTrack USB class compliant which means all modern operating systems – Windows, MacOS, Linux – recognise it, and load a basic driver (no installation required) so that it appears as a MIDI device, with a MIDI input and a MIDI output, like any other MIDI controller.

No, it will not work on Mac in the same way as it does on Windows with the manufacturer’s driver, BUT it will appear as a MIDI device. That makes it possible for you to write a Cubase MIDI Remote script to enable you to use it to control Cubase.

You don’t have to. Just plug it in. It already powers up in native MIDI mode. Use the MIDI input and output and create a new MIDI Remote script in Cubase.

Right right!
Thank you for kindly explaining but,
I did try it… I tried to customise,
fader, knobs, buttons…
All random error… yeah… I actually tried it on Cubase 12 Pro, mac osx intel Mojave…
Um… maybe, shall I try it again without opening the…Alphatrack app…?

I bought that driver from, here,
*This page is not a scam, guys who worked on the project made the very last driver for some DAWs…
I thought it also works on Cubase on mac osx, but I was wrong… so yeah.

It might be best to temporarily uninstall any other drivers you may have for the AlphaTrack.
That way you know that you are working directly with the AlphaTrack and that nothing else is interfering.
If I have time, I’ll try to generate a basic “.midiremote” file to get you started, and upload it here.