HELP: Cubase 11 and M-Audio Oxygen 61 MK4 Problems

Win 10 Pro 64-bit, Cubase 11 Pro, M-Audio Oxygen 61 MK4.

No buttons work in Cubase when pressed on the Oxy, not even the transport. Pressing the Auto button does nothing, and yes, have downloaded the M-Audio Directlink driver for Cubase. MIDI messages are incomming, as the blue bars light up with every press on every button, but they don’t do squat in the DAW.

Keyboard seems to work fine, but I bought it so I could have the seemless plug and play with Cubase as promised, so I really want to get all 30 controllers assigned. Not managed to assign a sinlge one!

Also, trying to even set up the MIDI Learn in Cubase has been a complete failiure. Not even able to assign one parameter to anything. I can’t make head nor tail of it. If a control is already assigned it will control a paramenter on a VST, but I have found no way to change them in the DAW.

Read the online manual, Oxy manual, watched online videos, but nothing has helped so far.

Utterly exhausted now…

M-Audio Directlink is really old software – but there are many topics about it here. The search on this forum is excellent:
https://forums.steinberg.net/search?expanded=true&q=M-Audio%20directlink

Already did a search on here, already read through some of those threads. And yes, I know it’s old software. Some guy said that it was working for him, so that’s why I tried it.

Also, doesn’t help with the fact that I can’t set up MIDI Learn in Cubase, which is obviously not the same issue.

Nor does it help with the fact that the Oxy is supposed to be class compliant, which therefore means that the transport control should work regardless of DirectLink.

Unless I’m missing something…

I’m not familiar with this but maybe a couple answers will jog my memory (or someone else’s) on something – Does this use the generic remote, and/or does Directlink add an entry to the list of remotes in Studio Setup?

Also, Are you referring to midi learn in the generic remote, or elsewhere?

Of course, you verified your midi connections? Often devices like this have multiple midi ports with different names and functions.

I have no idea, as I’ve not tried to set up a MIDI controller before. I’ve just used MIDI keyboards to play music on the keys. The reason I bought this one is because the knobs, buttons and faders are all supposed to be plug and play with Cubase.

I was reffering to MIDI Learn in Cubase, it has nothing to do with Directlink, as that is only (supposed to be) enabled when the Oxy is in Auto mode. Anyways, I’ve removed DL from my system now as it was clearly not working.

Messed around with Studio/Studio Set Up Track Quick & VST Quick Controls, all to no avail. Quick Controls and Note Expression in the Inspector, messed around with that, and can’t get anything working. Like I said, I can’t make head nor tail of it!

I need to map all the controllers manually, one by one, and save them as presets on the Oxy, but have no idea how to go about doing it in Cubase. Using the Oxy is pretty straight forward, I found a good tutorial on it on YouTube. But, I can’t find any information that’s understandable on how to do this in Cubase; the manual might as well be written in another language!

In Cubase 11 midi learn exists in the Generic Remote, but elsewhere, Cubase does not have a feature wherein you select an item, and then assign a continuous controller to it.

Cubase does not know about any modes in the Oxy, or any external controller unless a driver for it has been installed.

The Generic Remote can be used for this though.

1 Like

Just looked in the Cubase help manual regarding Generic Remote, and it’s about as useful as a hole in the head!

Will look at some proper actually useful tutorials on how to set it up tomorrow…

Cheers.

Well, I use one hole in my head to stuff food into, and two of them for sound. So I guess you mean very useful? :innocent: :crazy_face:

No, I mean completely and utterly useless in how to set it all up. It just tells you where it is and what the buttons do, but has nothing that would help in actually setting something up. Utterly bewildering!

Found this video, where a guy shows how to set up transport controls, will post it here if someone finds it useful. Still doesn’t explain what I need to know, not really.

How on earth am I supposed to use this keyboard to control different VSTs, as well as Cubase?

Using the Track and VST Quick Controls.

Cubase Pro 12 has the new Midi Remote which is lightyears beyond the G.R.

Already said that I spent ages trying that, and couldn’t get anything to work. Not interested in a Cubase update, just bought Cubase 11 recently.

Generic Remote is extraordinarily archaic, convoluted, and user unfreindly. It should not be this hard to map a controller.

This is how it should be done;

After sleeping on it, I had another crack at setting up Directlink, and found this guide.

https://inmusicbrands.force.com/headrush/s/article/M-Audio-Oxygen-MKIV-Series-DirectLink-Setup-for-Cubase-6-7-8

I followed that, and managed to get Directlink working in Cubase 11, however, it’s a case of one step forward and two steps back as when it is enabled I have no use of the keys on my Oxy and can’t play any instrumments. Changing the input to All MIDI allows use of both DL and Oxy keys, but the controls now affect both Cubase and the current VST at the same time, changing parameters on both simultaneously, which is not at all useable.

And, the troubleshooting continues…

I had the same problem and for me switching to ‘Auto’ on the keyboard did solve it.
Now everything works fine and I can set up every button.

Here is my script, for everyone who is just setting it up, maybe it works for you.
(If it doesn’t, changing the channel on the keyboard to 16 might help)

M-Audio_Oxygen 49 Mk4.midiremote (10.8 KB)

Slider 9 and button control the selected track and the buttons switch on/off writing automation.
You can easily change that.

Thanks for the reply Robbi. However, when I try to import the file into Cubase 11 it is not recognised, please advise.

Hmmm, sorry, I have no idea why it would not be recognised.

I guess you are importing it via script import?

It’s a very simple script anyways. If switching to ‘Auto’ works for you, then you can easily set up the keyboard.
If it doesn’t work, then my script also won’t work.

Are you using Cubase 11, or some other version? That screenshot looks nothing like the screen I see in Cubase 11…

I am using Cubase 12 AI, the german version

Not sure how it looked in Cubase 11, but there must be a similar dialogue to add a new midi controller, or at least for importing a script for the controller.

The MIDI Remote visual editor and scripts are new to Cubase 12.

@robbi28 In Cubase 11, you’re stuck with the Generic Remote and Mackie emulation. You cannot import user scripts for Cubase 12.

As I suspected. This thread clearly states in the title that it is a problem with Cubase ELEVEN! Posting about how to solve this issue in Cubase 12 is therefore off topic and not helpful.

@coaj
My answer was not about the script, if you read closely, it’s about the ‘Auto’ Mode on the keyboard.
I added the script, because it might have been helpful, sorry that it wasn’t.
Later I just answered your questions.
No need to be unfriendly if you don’t read closely yourself.

@Romantique_Tp - thank you for setting it straight!