Help! Synsopos errors!

Synsopos errors have brought me to a halt! I can’t use Dorico for more than 10 minutes or so without encountering some sort of Synsopos error. After the error I can’t save, and when I reopen and try to recover the file Dorico hangs. I’ve run “Online Synchronization and Maintenance” with the eLicenser Control Center and my licenses are on the dongle attached to my system. Here are a couple of sample errors:

Is “Dorico LE” Dorico Elements? If so, that error seems really odd as I’ve never had anything other than Dorico Pro installed. I’m assuming the Synsopos errors have something to do with reading the license, but I’m not really sure what to do. I’ve tried plugging the dongle into different USB ports and it doesn’t seem to make any difference in error frequency.

Any suggestions? I’m really stuck here and can’t work!

I can’t answer the bigger question, I’m afraid, but it’s not particularly odd that “Dorico LE” is giving the complaint - LE is the old name for SE. There’s only one Dorico 3 application; it runs either with or without restrictions (so as Pro or Elements or SE/LE) dependent on which license it finds. At the moment, for some reason, it’s not finding your Pro license.

I’m now thinking it’s possibly related to this issue I had a few days ago:
https://www.steinberg.net/forums/viewtopic.php?f=246&t=168884#p995991

If I don’t use any Halion sounds at all, it seems to be stable. I also have a license for HALion 6 on my eLicenser. Probably unlikely, but could there possibly be a conflict between the HALion Sonic SE that ships and the regular Sonic or HALion 6? Also, probably unrelated, but I just realized the ASIO driver on my standalone versions of these had been changed to “Generic Low Latency ASIO Driver” instead of my “Universal Audio Thunderbolt” driver. Just mentioning anything that might be conflicting in case it matters.

Have you tried rebooting your machine or plugging the USB-eLicenser into a different port?

Yes, both. In fact after a crash, when I would restart Dorico it would always hang unless I rebooted.

I’ve been working for about an hour straight now without any Halion sounds loaded using Aria and the Garritan JABB library. I’ve also had the Grand 3 standalone open during this period with no issues as well. It could just be coincidence but it definitely seems odd I’ve had serious issues with different files when using Halion sounds in the past few days. Would those sounds keep calling for the license authorization on their own?

I’m not an expert on HALion (and all it’s derivates) but they all reach out to the license from time to time. And also most sound packages are protected in way, that they check the license once, namely when loading in.
Do you have your Steinberg licenses all on a USB-eLicenser? And is it an older type or the newer, shorter one?

Hi Ulf, I have the shorter USB eLicenser and all my licenses are just on that one. It could be entirely unrelated to HALion, I was just wondering as this is the second time in 3 days where I’ve had a Dorico file that crashes or hangs with HALion sounds, but then works fine once I switched to Garritan JABB sounds. I just wrote for about 6 hours straight without a crash once I switched the sound library.

If you had crashes, could you please do Help > Create Diagnostics Report ? That creates silently a zip file on your desktop, containing also the most recent crash dumps. Please attach that zip file here. The crash dumps tell us best what and where was going wrong. Thanks

I get a “File too large: Dorico Diagnostics.zip” error when I try to upload it to the forum. Is there another way to send it? There are 3 VSTAudioEngine3 dump files from this morning in there:

There are file sharing services like e.g. DropBox that you could use. You’d then post a link here and I could download.
Alternatively, you could zip up each dmp file separately and attach one by one to this thread.

I have been having Elicenser problems in the last few days. Symptoms vary. Sometimes Cubase won’t start and shows the DCOM error, then next time it will start, but then crashes whilst loading a project, with the same error. Also whilst loading a plugin (usually seems to be Halion SE) Cubase sometimes quits suddenly.

Until the last few days, everything has been rock steady. I am on latest Windows version and updates.

I read that somewhere that someone found they can work OK with Elicenser program running, so I thought I’d try that, but I got the same error before I even started Cubase!

That made me realise that the error is probably in the recent ELicenser app update not Cubase. The version is: v6.12.1.1267 which I installed on 1st of May 2020. this fits the timeline of my recent issues.

I rolled back to 6.11.10.2266 and so far I haven’t had been able to invoke any further failures.

One more worrying thing is that during the last few days, I have also been noticing that Cubase feels sluggish and In frustration I trashed preferences and then also swept my system for viruses, cleaned registry, prefetch data and all of the usual tricks, none of which made any difference. However as soon as I reverted to the older Elicenser program (6.11.10.2266), Cubase feels bright and responsive. Even the Elicenser program flashes up almost instantly when started.

So, I don’t think it’s Cubase or Windows, or Dorico, I think it is almost certainly the eLicenser app itself.

FYI I don’t even own Dorico, but I think this all relates directly to the app, so anything that Cubase has to refer to the Elicenser for is affected (in my case that’s usually only Halion)

I’ll respond here if I have any further problems, but fingers crossed all ok.

Update to above, after a busy morning, no more errors.

Sure, here’s a Dropbox link, let me know if you can’t access it for some reason:
https://www.dropbox.com/s/152b1dt53n9y1rj/Dorico%20Diagnostics.zip?dl=0

Thanks, just rolled back too. Fingers crossed this solves the error issues!

Thanks for the data, Fred. There are 3 crash dumps, all deep in system libraries, but one come from HALionSonic and one from TheGrand, so I do assume it has something to do with the eLC. Now that you downgraded, let us know how it goes. And please send new dumps if it is unstable again.

Solution found, it seems this problem is coming directly from Windows “DCOM service”…

https://www.steinberg.net/forums/viewtopic.php?f=283&t=188701

Thanks for posting this! Rolling back the eLicenser seems to have solved it for me for now, but if it creeps up again I’ll definitely follow these instructions.