Help Troubleshoot MIDI Jitter(?) Issue

Edit: see this post below:

Hi, I’ve never had a midi timing problem before but a new song I’m working on is acting very strange. All the midi I record is clumped into spaces of about 12 ticks. Normally when I record notes will fall randomly around the beat, say anywhere from 20 ticks behind or ahead. On this one song, every midi note comes out either exactly on the beat, 1 tick late, or 11 or 12 or 24 or 25 or 36 ticks late…or on the early side it will be at 109, 108, 96, etc. There are no notes between 2 and 10 ticks late, which is not possible. Even the note off times behave the same. This occurs whether I’m trying to play with the beat or just randomly hitting notes to test this.

Interestingly, at the very end of the project, I have a tempo-mapped slowdown, and at that point the problem seems to disappear or at least lessen.

I’ve tried all the obvious things I can think of, with no success - auto quantize isn’t on (tried the reset quantize function just to make sure), toggled the timestamp and asio guard settings. Tried resetting, etc. Changing buffer size on interface from 128 samples to 64, no effect.

I can open any old project, and everything records normally (I might be 5 ticks late, 3 ticks early, etc.) Open up the problem project again and the problem is back. Any new project has the problem.

My keyboard is the newest Oxygen61.

Anyone run into this kind of thing or have any suggestions? Thanks!

But if I open any previous project (still created in Cubase 8.10), everything records normally like it used to. And all the settings are the same as far as I can see.

Hi you,

try Setting “use System time stamp” in the device Setup/midi dialogue.

all the best!

Cheers, ernst

Thanks for the suggestion, but no luck. I’ve tried everything I could find but none of it worked, such as:

System Timestamp
Safe Mode
Reset Midi Ports
Emulated Ports
ASIO buffer size
Changing system clock source
ASIO Guard settings
Constrain Delay Compensation
Generic ASIO driver
Quantize/Snap settings

None of it fixes the problem projects or any new projects I create, yet most of my old projects continue to work fine.

It seems it must be a problem with Cubase, not my hardware or anything else, because some projects work fine.

I have a ticket open with Steinberg but so far they haven’t been able to come up with anything.

sounds very much like its being quantized…

I agree, but quantize is off. I’m not even sure Cubase is capable of quantizing that finely - it would be like a thousandth of a note or something.

The only thing I can think of left to try is uninstalling and reinstalling Cubase totally fresh.

I tried opening the problem projects in Cubase 7 and I can record normally. Unfortunately saving them and then opening them in Cubase 8 doesn’t enable me to record normally in it. I can also create new projects that work in 7, unlike 8.

Guess this points to the need for a reinstall?

Hi there,

what about “ASIO Latency Compensation”? is it on or off?


It’s on, but turning it off has no effect.

I uninstalled and reinstalled C8 and tried to delete the preferences (not sure this really works since they seem to be remembered) but it’s still broken. C7 still works normally.

Cubase 8 (all versions) has major problems with inaccurate midi timing. No such problem exists in Cubase 7.5.4.

The problem is midi notes are recorded a little before or after you play them. Cubase uses an internal buffer of a few ms, and notes can only be recorded at the beginning or end of the buffer, even if you play them in between. (I believe it’s a form of midi buffer jitter.)

You can tell the degree that you are suffering the problem by opening Midi list editor. It’s very obvious once you know about it, though somewhat subtle which is why I believe this problem hasn’t been reported before.

Let’s say you’re using a Midi Display Resolution of 120 ticks and playing notes that fall on beats. If you’re like me your timing will be slightly off but notes generally fall somewhere between about 20 ticks early to 20 ticks late. The notes will be totally random in between so you could have one that’s 3 ticks late, one that’s 7 ticks late, one that’s 15 ticks late, etc. This is how Cubase 7.5 behaves.

But when Cubase 8 is acting up, you can only record about every 10 ticks. So notes will all be 3 ticks late, or 13 ticks late, or 7 ticks early, or 17 ticks early, but nothing in between.

Obviously this totally destroys the musicality of the playing.

Sometimes Cubase 8 won’t “act up” as much for me, and the Note On times are recorded normally. But upon closer inspection, the Note Lengths exhibit that “every 10 ticks” bug.

The dead giveaway that this is a Cubase bug is I just was working on a project that recorded normally for the first 8 bars, and then at bar 9 Cubase went into total bug mode. I do have a tempo change there, so I thought I might have just finally figured out a possible source of the bug. But I have a tempo change at bar 5 too and that doesn’t cause any problem. And anyway, if I just create a new project with a fixed temp, it will always exhibit some form of midi timing problems, so it doesn’t look like this bug is related to tempo, at least not solely.

I have reported the issue to Steinberg and they can’t fix it as of now. We tried email support, phone support, and I sent them project files demonstrating the problem.

Of course the first thing I did was adjust every single possible Midi or other setting (timestamp, buffer, delay compensation, etc.) but none of it has any effect whatsoever - this is definitely not a configuration issue on my end.

To repeat, Cubase 7.5 works 100% perfectly for me so it’s not an issue with my hardware setup either.

I would advise anyone recording Midi in Cubase 8 to look carefully to see how much this issue may be affecting you.

That matches with my observations as well. It really is crucial that this be corrected

I learned that this is probably Midi buffer jitter from this Sound on Sound article, which has pictures and a description of a problem very similar to the bug in Cubase 8:

I’m seeing a similar issue in Nuendo 7 but it is much more severe - general note-on timing is out to the point where it is very audibly out of time, and many note-offs don’t get recorded at all, so that a bunch of notes that should be staccato go on for 10 bars and upwards. In short, MIDI recording is broken to the point of not really being able to work with this version of Nuendo.

I also have Cubase 8 but have not tested MIDI performance specifically. I presume the issue is the same though as the code base is identical.

MIDI performance in Nuendo 6.5 and Cubase 7.5 was fine.

I just read this article on Abeltons site

Maybe steinberg is favoring low latency over jitter.

From my experience loop back testing with different settings is the best way to attempt to obtain an ideal MIDI situation in cubase.

Also I have read but have not tried that using a virtual loop back device can test the driver and software eliminating the plausibility of external MIDI hardware as being the issue.

I’ve always had a bit of trouble with jitter in cubase as notes playing early with low jitter can be corrected much more easily than high MIDI input Jitter.

The goal in cubase is to get Latency and Jitter the lowest possible.

That is why loop back testing is important so you can test all settings and hardware configs available to you.

In a DAW like abelton you trade less jitter for more latency as described in the article above.

Now there may very well be a bug here, but I have always had this “issue” in cubase almost exclusively when playing VST instruments live. The best solution is MIDI loop back testing through your vst instrument while testing for optimal settings as well as lowering your latency to the lowest possible ms during live playing of VST instruments which should reduce the jitter to “acceptable” amounts. YMMV

Personally I think other daws have traded lower latency for less jitter which I think is very smart as it is way easier to compensate for that.

Again from my experience and education in school from MIDI engineers = yes those exist, testing on your own system is the only way to get this in line with your current hardware or make you aware that your hardware and or DAW choice, and or Operating System may need to be re-evaluated.

How you would learn to deal with this situation other than a really great sos articel here:

I do not know, I learned this in school from professionals many years ago some daws are more forgiving than others about hardware choices, from my experience cubase can work right but at the expense of some testing and tweaking and hardware configurations.

Trust me though Cubase is not the only daw to have issues like this with MIDI timing, it may be that at it’s core it is programmed differently favoring latency over jitter. This is just a theory though.

I’ve heard of people having issues somewhat like this in other DAWS which is why a scientific loopback test it the only real way to trouble shoot this issue.

Personally as other DAWS evolve I am on the fense about cubase, have not upgraded to 8 yet and am testing other DAWS, but I do prefer cubase over them as I test, I feel at home in the program so I deal with these issues the best I can as described above.

I don’t know what latency has to do with it, but midi timing is perfect in Cubase 7 and broken in Cubase 8.

If it’s not fixed soon, perhaps starting a huge thread about it on Gearslutz will help.

I also wanted to add that, when I was in school the MOO for dealing with this was to have an external sound module, play that live to get the feel and then send it through your VST instrument, not sure if that is still how it’s being done today, as some DAWS have dealt with this issue as well as lower latency on faster PC’s, but this was what was taught to us at that time. Times change though and I have not really kept up with whether or not that is still the trend.

Well latency effects live played VSTs as described in the sos article. notes get stuck in a higher buffer and are placed wrong, maybe this has been resolved since that article though.

okay I hear you so cubase 8 has introduced an internal midi timing bug. I have not gone to 8 yet but if that is correct I’d say that is NOT good at all!!

Also, at least for me MIDI timing was not always right in cubase 7 although acceptable for me at least. so I would say it got worse. As opposed to one was perfect and one is not.

If I were having this issue I would contact the company that I have spent money on the product by phone. I am a business consultant, and it always amazes me how few people actually pick up the phone these days. You paid money for a product that is not functioning correctly at the core level.

Find the support number and ask to please talk to a supervisor, ask that supervisor to help you create this as a confirmed bug to be analysed and fixed at steinberg things like this always get resolved faster during a two way conversation.

I have had multiple bugs looked at and fixed this way myself.

I apologize if you have already done this if not try it out and see what happens…

I have talked to them on the phone, after a few weeks because they didn’t call me the first time they made an appointment. I had earlier sent them project files showing the problem. But it didn’t matter because they didn’t have any suggestions, much less ability to fix the problem. It seemed obvious to me from their reaction that this is a bug that they don’t want to admit they have no idea how to fix.

You may have a separate issue with Cubase 7 Midi timing, but is it the one we’re talking about here, jitter?

Right, the article mentions latency as a trade-off for jitter, but my guess is that’s very outdated, for slow computers. Cubase 7 has no problem with latency or jitter.

The problem has something to do with the way the Cubase 8 engine was rewritten, likely relating to Asio Guard 2. In their quest to add advanced features, they broke the most simple one.

The disappointing thing is Steinberg may have thought they could get away with this, because maybe not many people look closely at the midi they record, and many actually quantize it! And judging from the few people who have noticed this bug, Steinberg seems to have gotten away with it, for now.