Hide empty staves with chord symbols

It seems that once a chord symbol is created somewhere, it’s shared among all the instruments. Somehow that would cause Dorico to treat an empty staff as non-empty and thus show it even when “hide empty staves” is turned on. Is there a way to hide a staff with chord symbols inherited from other instruments when it’s actually really empty?

Dear erpipec,
I would really be surprised if that were so… Are you sure there’s nothing else in those staves that prevents them from being hidden? Is it a Dorico file from scratch or an XML import? The latter use to have clefs you must delete and other kind of hidden surprises…

Hi Marc,
Yes, this is a Dorico file from scratch, created with Pro 2. If I remove the chord symbol, all the staves get hidden as desired. As soon as I put it back (on other non-empty staves), the empty staves come back again, both in Engrave mode and Print mode.

Ah, I found the solution! I need to explicitly select the chord symbols in those empty staves and hide them. Makes sense to me now. Thanks!

Great! Thanks for the feedback of your different actions

Yeah, no, this doesn’t seem to work for me. Whenever an instrument has chord symbols assigned, even if I hide them, empty staves are shown in the score in engrave mode, whereas staves without chord symbols are hidden correctly. And if I delete the chord symbols completely, these empty staves are also hidden correctly.

I’ve been very happy overall with chord symbol implementation , but this is an issue I hope gets addressed sooner than later. I’ve also noticed that chords in empty measures in ‘rhythm sections instruments’ end up displaying when I don’t want them too. I’m not happy about having to select and hide chord symbols for empty measures. The other side of the coin (which has been discussed in other threads) is creating a small section of chords for say a solo instrument. Currently the global chord settings require us in some cases to use workarounds which takes time…I’m sure this will be addressed in due course.

A year later and I’ still having problems with hiding empty measures with chord symbols. I’m not sure why, but no matter what I do, hiding chord symbols doesn’t automatically ‘hide empty measures’. I’ve tried everything I can think of. All my settings seem correct. If I delete the chord symbols, the empty staves hide correctly, but hiding those same chord symbols leaves a bunch of blank measures. I even tried a brand new project (no risk of XML import issues) and set all the ‘hide empty measures’ setting appropriately. No luck. Dorico hive mind, any ideas?

How do you hide the chords? Have you tried using the new chord region workflow ?

I’ve been in the properties panel…Is there a hide option in the chord regions? I know I can add a chord region and chords above slashes. Is there something else? I’ll pop into Dorico and see if maybe I’ve missed a new way of doing things in DP3.

[EDIT] I just had a look. I don’t see a different way of hiding symbols with the chord regions. Am I missing something?

The suggestion is that you only use Chord Regions where you want them, rather than applying chord symbols to the whole stave and then hiding some of them.

Thanks Pianoleo,

This is an impractical work-around for my case. I have multiple flows (close to 60) and would have to change all display settings and apply regions across the board. Any guesses as to why the expected behaviour (hiding chord symbols should allow empty staves to be hidden) is not working?

Where did your 60 flows originate? Were they MusicXML imports?

Some were XML but I’m pretty good at cleaning them up. To make sure it wasn’t an XML issue, I started an empty project and still had the issue. It must be a setting, but for the life of me, I can’t figure it out. I feel like I’ve covered all the bases.

Starting from a new project, I have absolutely no problem getting empty staves to hide, by hiding the chord symbols. What exactly are you trying at your end?

Pianoleo, That’s exactly what I’d expect to happen, but it’s not happening on my end (unless I delete the chords). How did you capture video? I’ll re-create and post.

Pianoleo, That’s exactly what I’d expect to happen, but it’s not happening on my end (unless I delete the chords). How did you capture video? (I’m on MAC if that’s relevant). I’ll re-create the problem and post.

I used Giphy Capture. I’m also on mac.

jamesppk, if you export one flow from your project, does that still reproduce the problem? If so, do Play > Playback Template and apply the ‘Silence’ playback template to reduce the file size, then attach the project here so we can stop guessing and actually solve the problem.

Thanks Daniel,

I’ll send it to you directly.

I have noticed that when I de-select “Allow individual staves of multi-staff instruments to be hidden” my results improve, but the example I’ll send you doesn’t seem to hide regardless. Full disclosure, it was ported over from Sibelius as an XML. I’ve done a ton of XML imports and know the usual quirks (independent time signatures, clefs and other objects.) I don’t think there are any more XML items that would cause it not to hide automatically, but maybe you’ll find something I can’t.

Thanks in advance for your help,


J