Hiding flow information

Hi, I am currently stuck on how to hide flow information.

As of Dorico 2.2, both the project and flow information are displayed in the score. How do I display just the project information while displaying the project title at the top of subsequent pages instead of the flow title? In other words, how do I get the title to display like in Dorico 2.1?

Also, if I remove the flow title from File > Project Info, the flow number is not removed and there is no way to edit the flow number from Project Info. Huh?

P.S. No disrespect to the developers. I can see the 2.2 way is preferable for multiples flows in a score, but in the scenario where I just want to insert a single flow, I’d rather have it look like 2.1.

Hmm, so I found I can double-click on the flow title and remove “{@flowNumber@}. {@flowTitle@}”. This way, if I insert a flow title in Project Info, it isn’t displayed on the first page but is on subsequent pages. I guess I’ve answered my own question. Still, I wonder if there’s a settings option for this, as I could not find one anywhere.

There are some settings in Layout Options / Page Setup / Flows that control what headings are displayed.

See this, starting at about 23:30. https://www.youtube.com/watch?v=zVv3n6TJRQc

Thank you, but this only seems to work for parts and not for the full score. I click Show Flow Headings > Not For First Flow in a part and the flow title disappears, but when I apply it to the full score, the systems re-adjust but the flow title doesn’t disappear. Is this a bug?

EDIT: Hmm, it works as expected in a new score, but not in a score I edited previously.

Would changing the token in the header frame of the Score Default Master Page to {@projecttitle@} accomplish what you need?

It’s hard to tell without seeing the document, and whatever settings you’ve applied. If you really don’t want Flow Headings, and the settings aren’t working, then just delete all the Frames from the Flow Heading Master.

If your “old” score was created in an earlier version of Dorico, it probably used an earlier version of the master page formats. Compare what you have in the old and new scores.

It would usually be a very bad idea if an old score “automatically” updated to the new page formats when you opened it, of course.

I don’t understand why
Layout Options > Flows > Show flow headings > never
only hides the flow heading on the first page and doesn’t change the “flow 1” heading on any subsequent page. I understand OP wants to show the project title in the header instead, but how do you just get rid of the header entirely on all pages? On the right side of engrave mode I edited the default flow heading to be completely blank/nothing, but “flow 1” is still showing in the header.

Edit: I see you can manually delete the frames one at a time in engrave mode, but there must be another way

If you’ve made manual alterations to the layout of the page (e.g. change the contents and position of text and music frames that are in the Master), then that page is “unlinked” from changes to the Master pages, and possibly also to other Layout Options.

Again, some screenshots or a sample document would be useful to identify what’s going on.

If sounds like you want to remove the header frame on the ‘Default’ master page pair. Try going to Engrave mode, double-clicking the ‘Default’ master page in the Master Pages section on the right-hand side, then in the editor that opens, delete the header text frame that contains the token {@flowTitle@}. Do this for both the left and right pages of the pair, then click Apply and Close. If you’ve already manually deleted the frames in your layout, also right-click on one of the pages in the Pages panel at the top right corner and choose Remove All Page Overrides.

Thanks for this - I had a similar problem to the OP, the flow number remained even when I turned off “Show flow headings” in Layout Options. Then I realized I had changed my first page, and in Engrave mode, “Remove All Page Overrides” did the trick.

Nevertheless, in Layout Options, I would like the ability to control both the flow headings and the flow number (see attached screenshot); this seems to me more intuitive than having to erase page overrides (especially if you want to keep some of those overrides). Apologies if this specific request has come up before, I didn’t see it in a search.



Dear Stephen,
I agree flow number should appear in that Layout options section (and the option of Roman numerals along).
I have the feeling you have deleted the flow number in your actual page, thus creating a page override, instead of deleting the flow number token in the flow header masterpage. Is that really what you wanted to do?

I agree that flow number could well be a switchable option but I also agree with Daniel’s advice about editing the default Master Page in Engrave Mode.

I find this approach very easy and succinct.

I can’t see us adding an option to Layout Options for whether the flow heading should show the flow number any time soon, any more than we would add options for what tokens are in the text frames on the ‘First’ master page in Layout Options. The whole point of having these things be editable in Engrave mode is that you can edit them to suit your own purposes directly and without us having to provide even more options than the hundreds already provided. So (and with apologies for my bluntness) I think that’s a bad idea and it’s not something you should expect to see.

Thanks! Yes, there are certainly lots of options already!

Ok, fair enough, as long as it is always possible to start with a blank “template”, where the options and tokens can be set as wished.

Is there a way to accomplish this - removing the leftover flow number for the flow title - in Dorico Elements?

Thanks,
Dan

I’m afraid not, Dan, because you can’t edit the default flow headings in Elements. But if you want to attach your project here or email it to me (d dot spreadbury at steinberg dot de) I’d be happy to fix this up and send it back to you.

I have a problem here.
I can see ‘1.I’ as ‘{@flowNumber@}. {@flowTitle@}’, but I only want to see my ‘flow title’, not the number.
As you can see on the screenshot, I have NO page overrides.


I aslo don’t have any {@flowNumber@} on my default first page. So why do I have the flownumber in every single player-score? Of course I could ‘Remove Header’ in Layout options, but if I do that, I will loose my flowtitle which I want to keep.

What is ‘wrong’ here?

That’s a flow heading, so you need to be editing this: