HiDPI 125% scalling issues (worked fine on Cubase 10)

I’m having issues with 125% scaling on 1440p + 1080p displays.

On Cubase 10 it worked great with HiDPI enabled + Windows’ Properties -> Compatibility -> Change high DPI settings -> Override DPI -> Application enabled.

On Cubase 11 with the same settings I get weird results, where text looks sharp(although noticeably bigger than in Cubase 10), but all UI elements with graphic and icons look blurry and out of scale. Tried every option, enabling/disabling HiDPI in Cubase and every combination of Windows scaling settings. Nothing works.

See the attached screenshots.

What the hell. Did I just paid 159€ for an update that make my eyes hurt?


Mixed windows also looks out of proportions.


+1, same here
we need an option to force Cubase to 100% independent of window setting
The GUI, fonts etc are just way too large and clunky with 125% scaling on WQHD monitors

1 Like

+1 same here

+1 here.

+1 Here

Hippo

How is it with using no zooming in Windows and no zooming in Cubase, just 100%?

I use 3840x1200 monitor and don’t need/want “HiDPI” settings, but I don’t want it blurry…

Hi guys,


Thanks for your feedback. I will discuss a custom scaling option with the team.


Cheers,
Armand

Hi Armand,
It’s nice to hear that, appreciate your response!

Thanks

+1

And great that you are already working on it. Pls push it fast. I can’t work with Cubase 11 right now because the whole UI is just too bulky with my resolution / dpi settings.

Hi Armand, are there any updates on the issue?

1 Like

Hi @sergeyotro we are currently working on making it possible to define whether Cubase should be -+25% or -+50% the scaling factor set in Windows. For instance if your Windows is set to 125% but that you want Cubase to be rendered “as if” 100% you will be able to go to this setting and choose -25%.

3 Likes

Hi Armand,
Thank you for the update, the solution sounds great! Now, waiting for the update release :slight_smile:

1 Like

Hi @Armand ,

Do you think the future fix will fix also this rendering issue ?

Thanks!

Hey Kash, I’ve describied a similar issue here:

For me Cubase doesn’t look blurry if I set Windows DPI scaling settings in Compatibility tab to “Scaling performed by application”. I’m also on 1440p screen with 125% global scaling, HiDPI on.

FabFilters plugins jump in size with those settings though ¯_(ツ)_/¯

Hi Kash

The problem you are referring to will not be affected.

Technically it’s a new option and not a fix. You will then have the choice to set the scaling factor to upper or lower values for Cubase only, while having HiDPi enabled no matter what. Note that by 100% HiDPI is basically irrelevant.

Cheers!

Howdy, I’m still struggling with this issue and thinking of switching DAWs after 15 years of buying and using cubase. Any updates on when this will be available?

1 Like

Hi

Yes the preference will be released in the upcoming release (planned for end of March). You will be then able to set your own scaling factor for Cubase only

Cheers,
Armand

1 Like

So the “end of March” ETA was kinda optimistic, I guess :slight_smile:
Is there any updated ETA?

2 Likes

It has been postponed to a couple of weeks, still coming very soon. :slight_smile:

2 Likes