High CPU usage during playback

Hi there,
I’m seeing very high CPU usage during playback for what I’d think wouldn’t require much CPU were I running the same instruments in another DAW.

I’m using the standard HaLION SONIC SE which comes with Dorico 3. The score has flute, clarinet, 4 solo violins, 2 viola, 2 cello, double bass, percussion.

I’m running on a new MBP on OSX 10.15.3. During playback in activity monitor I see on VST Engine:

CPU 107-114%
Threads: 16
Idle Wake-Ups: ca. 400

Dorico itself uses much less CPU, just the VST Engine that’s the issue.

It’s chewing through my battery. Any tips to reduce it? I’d be happy to just use MIDI playback sounds tbh rather than affect the life span of my laptop.

I’m also experiencing weird moments where certain notes or entire bars on certain instruments in the score don’t play back, they drop out. I posted about similar issues with playing techniques here:
but in these cases there are no new play technique instructions, so I have no idea what’s causing the drop outs.

Any tips would be much appreciated.

Would you be able to share that project? If maybe not publicly, but could you send it to ‘u dot stoermer at steinberg dot de’? We guarantee full confidentiality and only use it for the purpose of investigating into your issue.

Thanks Ulf, will email now :slight_smile:

It’s possible that the video engine is a factor in the high CPU usage on your system. See here.

May I jump on this?

Just picked up cubase 10.5 pro and got my environment built, and was working with Halion sonic SE3. Ive got an empty project with only Halion loaded, and even when I only have one single sound loaded into Halion I see major CPU spikes. If I load a few samples and trigger them at the same time, it hits the red and I even get dropouts. Nothing else I load into cubase comes even close to the CPU spikes I see with Halion right now. Halion warns me not to use multicore mode while in a hosts, so I leave that off. Any ideas? Thanks.

Fresh win10 64 system, 32GB RAM, i7 7800x @ 4.1ghz, focusrite red 2i2 gen2.

I think you might be better off posting this in the Cubase forum, but I’m surprised you’ve been advised not to use multi-core mode in HALion. Unless you’re running many, many virtual instruments, I don’t think you’re likely to run into any major bottlenecks if you allow one instance of HALion Sonic SE to access multiple cores. However, I’m by no means an expert in this area, which is why I think posting in the Cubase forum may be a better move.

Thanks, will do. Yeah it’s a default setup, all stock for now. Happens every time. Posted in the other forum, as well.

That is a standard warning that comes up. But it is a matter of balancing this out, the needs of HALion and that of the hosting app, i.e. Cubase. So it certainly is a bad idea to allow HALion to use all cores, because that will bog down Cubase, something that you surely don’t want. But you can let it use at least a few cores, that’s not a problem. You can also play around with the setting and see how either Cubase or HALion behave differently.

Understood, and thanks for the reply. 30 year net/sysadmin and custom builder here. I’ve tested Halion with multicore off, 2, 3, 4, etc, cores and see no difference at all.

This seems related, and is also an explanation for how to control multicore config in Cubase.


I will mess around with that properties file later and get my hands wrapped around Cubase 10s multicore stuff. Last Cubase I used was studio 5, which had “multicore ON or OFF” in settings inside the program.

I’m not entirely sure this will help either unless Cubase is gobbling all/most cores, but so far my analysis of system logs and active cores/threads does not show Cubase 10 eating them all up, but usually using only 2. Will check out this multicore suggestion on the page above and see if I can change this behavior at all. Halion SE has many great instruments and patches that I would love to use, and those dropouts are breaking that 75% of the time.