Horrible Performance with Cubase 12

Hi forum,
This post is not to trash cubase but to report my pain.
I have been using cubase for three weeks now and I moved from Studio one to cubase because of the sound engine. Cubase support surround mixing and that was my main reason for my migration to Cubase, but when it comes to performance its the worst coming from studio one.

I tried running 4 vst and my UI freezes, My audio performance peak runs high and this is without any effect added. My CPU runs normally

image

Am forced to increase my soundcard block size to 1024 but that adds delay on my midi response. I felt moving here will give me the best performance but its the worst pain I didnt plan for.

I need this to be fixed so I can continue with my work and hope to stop switching between daws and stick to C12 and upward.

My pc Spec:
Ryzen 9 5950x 16 core
64 GB ram
2TB NVME for OS
2TB NVME for Sample
2TB HDD for storage
12GB RTX 3060

2 Likes

What are the driver versions for your mainboard and video card?

That’s horrible considering it’s only 2 channels.
fwiw, Using all those komplete would wreak havoc on any machine.
Resource hogs!! I dread opening them up if I already have a heavy project…:woozy_face:

That Said, Is that PreSonus heavy duty enough for it? :robot:

@theRoyal1 I can run 6 or more kontakt/vst with multi sample instruments and it works with no issue. NO performance peak nothing and I really want to stick to Cubase because of some feature.
I moved from FL studio to Presonus Studio one 2012 because of performance with kontakt. I was to switch to Nuendo but saw the performance issue when playing with the trial then choose Cubase

@st10ss am runnig the latest for every drivers, bois and more

This performance is definitely not what you should see with Cubase. You have a pretty good PC and on first glance I couldn’t see anything with your configuration in Cubase as well. You should actually see a far better performance on you system.

That has to be some very strange issue or it is connected with that NI control plugin. I don’t have that one, but since it is free, I will try it tonight and see, what it does on my PC. I’ll report my findings later.

If I use a single instance of Kontakt and load all the samples (8) I still get the same performance. I really need help on this issue. I dont want to increase my block size always

Try it without the asioguard

That made it even worst when I turned it off

I would try to set high performance from your PC, also, go to:
power settings->Additional Power Settings->Change Plan Settings->Change Advanced Power Settings->

  • Turn Off the hard disc to Never

  • Sleep set to Never

  • Allow hybrid Sleep to Never
    Same for Hybernate

  • USB Settings: Disabled

  • PCI Express to OFF

  • Processor Power to 100% at all time

In addition, from the Cubase recovery console: Delete preferences.

I hope this helps.

1 Like

I will try this and hope it works

1 Like

What are the samples you use with Kontakt? I usually have at least two instances of Kontakt open, one for a piano from my library, one for strings (I use Spitfire studio strings a lot lately) and probably an occasional brass section which would be four instruments from Broadway Big Band lite.

I never had any problems with that, actually the only problem are the very slow loading times of the Spitfire stuff. Other than that, I actually consider one instance of Kontakt a very light load.

There must be something different going on with your system.

So what do you mean by “loading all 8 samples”? What library and which patch?

Have the same. Even with couple of audio tracks. I’m on Dell Precision 5570, Win 11, Intel i7-12700H, 64GB RAM, 2TB M.2 PCIe SSD, NVIDIA RTX A1000. Peak meter is going up like crazy. Did try all options and tips to improve performance. Without any success. Still the same. Have to set the buffer like 1024 to be able to work at all. On Cubase 11 Pro all projects work far better. I’m very disappointed with Cubase 12 Pro. I bought top shelf laptop - and with Cubase 12 I have the same performance like on my 7 years old Dell Latitude.

@Rainer_Hain the issue is not Kontakt, I recreated the same track in Studio One and it works perfectly. No glitch, no performance impact. But on cubase 12 pro its a pain with just three libraries.
Am just afraid I made a bad investment on cubase am hopeful someone can help me resolve this.

I do have many (known) bugs on C12, but this one is not one I can reproduce. I see you have an external clock sync, do you still have an issue when internal clock is selected?
I ask that because it could be a bad clock is fed to your audio interface.

@fab672000 I enabled it to see if it will fix the issues.

Are you using latest C12.0.54?
Which exact OS version are you using?
If you want better support, maybe add that to the title. I have a 5900x system and Komplete and it does not cause that much trouble.
Also is it intermittent or not?

After a year of wrestling with Cubase, this is what I do before firing it up. {Win 11]

  1. Disable Defender
  2. Disable Wi-Fi in Advanced network settings.
  3. Use Wise Memory Optimizer

LatencyMon also came in very handy for optimization purposes.

That is indeed strange. Your Computer should be roughly as fast as my 12900k. Over here the current project I am working on makes uses 18 VSTis (among them 2x Kontakt, 2x Superior Drummer 3, 2x Repro-5, 2x Zebra, The Legend, etc.). It also uses more than 100 VSTs (FX, Channel strips, etc.) and it runs flawlessly @64 samples.

You should be able to get a similar performance. While the Ryzen performs not quite as good, in my experience the difference is not to big. You should still have a really good performance.

I notice one thing in your configuration though:
The iostation 24c setup shows the clock source as “internal”. In your ASIO settings in Cubase it reads “external clocked”. Now I don’t know that interface from personal experience, but that looks odd. When something uses its internal clock that should be refelcted in Cubase’s Asio settings as well.

So I would check the configuration of your interface or it’s driver for that matter.

Take byesmonden.ja.o.t45’s advice and use Latency Monitor to see where the problem lies. Try it with Studio One, then with and without Cubase running. You should be able to see exactly what is stealing CPU time.