Horrible Performance with Cubase 12

WIll try that now Thanks @byesmonden.ja.o.t45 and @microapp . Also @Rainer_Hain I will disable the external clock option and see how everything works

This YouTube video has some tweak tips that might help. The Power plan might be useful.

Thanks everyone for the support. After a lot of testing configs, I came to a conclusion that C12 Pro is not for me. To be able to get good performance am forced to turn off alot of my boards feature, drop some windows feature and especially virtualization which I use for other products, like docker, jetbrains and other development tools.
I got to learn about latency monitor thanks @byesmonden.ja.o.t45 , was helpful and found out my Nvidia driver adds some latency, but with all that I will still say C12 need alot of work in this performance department.
With the current config and clean up no change at all but in the case of Studio one it still amazing. Below is a screenshot of all that’s running in Studio one compared to C12 running just three vst. My highest latency there is from Izone 10 with 72.0ms

I cant take the chance of slowing down my work to use cubase

Conclusion to get best performance from cubase turn off virtualization, update drivers that latency mon reports and watch the video @Trevor_H posted above.

Thanks again I will keep watching out for updates and C13 and hope it gets better


Glad I ran into this post, because I was considering using C12 Pro. I bought it when it first came out, but wanted to wait until I finished a major project before switching. I have a Rzyen 5900x on a B550 board with 32GB RAM, so there’s a chance I’ll run into similar issues as well.

Anyone on Mac OS Monterey or Venture running C12 Pro. My mobile rig is a MBP M1 Pro running C11 Pro on Monterey, but have been using it as audio playback ONLY. I’ll be running VSTi on it very soon and wonder how it performs in the Mac OS platform.

Thanks everyone for the great advise. (Molten has been/is a great site for tuning my Surface Pro for Cubase)

1 Like

Did you try the 99% trick, mentioned in around 37 minutes. It made Cubase 9.5 have a steady cpu stream. I know it’s Cubase 9.5, thought it might stabilize Cubase 12 as well.

Thanks @Trevor_H I dont see why Cubase dont just run well I dont care about my pc power consumption. I will try creating a project with Fl studio and see if its better. This post as I said is not to bash C12 Pro I invested into it on license and tutorials but I hope for the best in the future.

1 Like

That’s Okay @ehigiepaul . I know what you mean about Cubase should just run when you load it up. I didn’t get the impression you was bashing Cubase, you just want it to work.

It seems getting a constant cpu stream is key with Cubase. I did not know that, until I watched Molten Music Technology YouTube Video.

I hope you can get Cubase to work at some time in the near future.

1 Like

Since you own it already…it might be worth the trouble to simply dual boot to an alternate optimized system partition when you’d like to work with Cubase.

I know it’s far from ideal, but if you find enough advantages/features it might be worth it.

I’ll refer you to this post:

My issues were fixed with a bios update and disabling “Core Parking”
Also, I use the “Ultimate Performance” power plan and disable power management in all USB hubs (Device Manager).
Cubase 12 is running like a top for me now, good luck!

1 Like

Phase 2: Am not giving up yet.
This phase I will do the following to see if C12 is good or just there.

  • backup my data
  • format my os drive
  • remove the cmos battery to wipe all board settings
  • configure my motherboard not to throttle, step, disable raid 0 and visualization
  • install windows 10 not 11 as my last test was 11. maybe its may not be stable yet.
  • install the drivers first
  • install and run latencymon to help detect issue before installing DAWS
  • install all my DAW back (FL Studio 21, Studio one 6 and Cubase 12)
    -Install NI Komplete
  • create a midi project which I can load on all DAW

With all that I will do a final review on those DAWS and how much resources they each consumes.

Below is my full system specs
Ryzen 9 5950x 16 core
B550 Aorus Pro AC motherboard
2x Patriot Viper 32 GB 3600mhz (64GB) DDR4 ram
Zotac Nvidia 12GB RTX 3060
2TB NVME for Sample
2TB HDD for storage
Presonus IoStation 24C

I hope this gets an amazing result and final decision on my final DAW.

1 Like

I started phase 2 yesterday, taking all the steps I listed in the above post.
Turning of virtualization and all.
Install windows 10 then latencymon which helped me to make decision on what to kill.
Install all the latest driver from microsoft update then vendors. Installed avast drivers update that helped me get some updates. Did a bios update I didnt know existed.
I will say I came up with a new finding, if you want a system for studio or any creative work. Cut off your network devices wifi/wlan/lan they add latency to your system especially when downloading .
Kill/ disable all audio devices that are not needed like the onboard sound devices. Just leave your studio sound card drivers and others like midi, display card enabled.

That really gave me better latency and also switch to windows 10. I remembered that windows 11 held back games performance at a time I think it does the same for real time audio.
I loaded the kontact project I used to start this post investigation and it was good. Then I went back to my bois and enabled virtualization and this is what I got
It still peaks but this is much better than before.
This might have solved my performance issue with C12 but I still feel it needs a lot of work.

Before it was in the red under 2 minutes but now 11 minutes it still safe.

Also 25 minutes still amazing now.
If cubase perf is better than before just imaging what studio one will do with what I achieved. This was a journey I hope the devs notice and improve on it. I dont see why C13 needs to be released. I hope they fix this so C13 will be more stable at the start.
Conclusion : switching to windows 10 might resolve some latency issue, just installing all the latest and disabling drivers not needed might help you get the best latency real time audio performance.
I hope to see an update to fix this. Still thanks to everyone that supported me in this investigation and stay safe. Thanks
@system @steve


I once ran into something that latency monitor didn’t do much to help me find.

I’d picked up some SSD drives made by PNY. They did more than well enough on benchmarks and such to assume they’d be fine to hold some instrument libraries. In my case, Garritan Ultimate Collection, and some orchestral stuff by Sonnivox. NEITHER of these libraries are all that demanding…

So…I poked and prodded for months trying to figure out why Cubase kept red-lining and glitching all the time. I also had problems with other non-Steinberg hosts…even something like Finale or Sibelius, I’d have to use HUGE audio buffers up to 4 megabyte for them take off and run (and they’d still glitch from time to time). Cubase was the worst though…even with those massive buffers…ASIO guard on/off…no matter what I tried.

System kept passing those LatencyMon tests with flying colors, but I did finally notice a regular ‘interrupt’ that kept occurring.

A light blub came on in my head. Moved those libraries to a much older/slower platter drive that I had laying around, and never had a problem with it again!

So, those particular PNY SSD drives, or their drivers are simply awful for ‘real time streaming’.

That system was a rather modest one (Old Phenom II and DDR2 technology), but getting any samples or audio tracks off those PNY drives made a world of difference! Rig went from ‘unusable’ to sailing right along with pretty large orchestral templates (Garritan in particular doesn’t require much in the way of system resources).

For what it’s worth…those same drives suck just as hard with a Ryzen 9 3900XT build with 64gig. (Yes, tried them on multiple systems…different hosts…both SATA3 and SATA2, etc…) They weren’t a total loss though…they’re pretty zippy drives for other purposes. Just lousy at streaming audio and video files.

Point? If you keep getting spikes and can’t figure out why…it wouldn’t hurt to try moving anything that needs to stream D2D to a different brand/model drive.

For DAW work…it’s not so much about ‘burst speed’ or huge bandwidth as it is the ability to stream consistently without a lot of interrupt style system polling.

Since that fiasco, if it needs to play/record in real time…I’ve stuck with Samsung Plus or Pro for SSD media, or used platters rated for good A/V performance and haven’t run into nasty Cubase spikes since. I usually work at 48k or 44.1k, work with big orchestra plugins, and it’s pretty rare I ever need buffers any larger than 128k.

I’ve had the same issue for years now. Using low buffer settings in even empty projects. I’ve found Cbase seems to have more erratic core spread on certain systems compared to other DAWs. It’s not a universal issue, but is quite common. With 12.0.30 (Rolled back from .54 due to various issues) and the new 22H2 W11 update, things seem to be more stable, but still regular peaking.

Throttlestop has also been an absolute life-saver. Always amazing how some simple dedicated freeware created by kind individuals can trounce multi-billion company, overly complex apps.

1 Like

After building an updated comp i realised how much i had actually optimised my old 3370k to run absolutely perfect , i can’t tell you enough times how important it is to disable ALL running background features , my suggestion is (and it works for me ) to open the Settings tab and click on all the tabs and slowly work your way through the left side tabs and disable everything you are not using , there is a heap of shite , a lot more than what you think running in the background , if your not using it , dump it .
Display settings in advance :set to 'run in back ground ’ and NOT priority of programs ,
Disable all fancy features of the displays .
Keep an eye on Latency mon and see what drivers or programs run that you don’t need , search them out and disable , this is really important , if you have even one tiny process running in the background that causes a hold up then …
This is why over the course of 23 years on PC ive learnt to Build a dedicated Machine , just for Steinberg software (it’s worth it in the end ) and i couldn’t be happier .
Ive gone from This …

The wdf01000 is a pita as it is only the framework for ALL drivers so if you have one driver thats out of date you need to search , so click on processes and see what’s running , in my case one big one for me was the corsair Link program was out of date , removed Link set the fans on the motherboard and the US’s dropped quite a bit


2 and a half days of 7 hours a day tweaking weald results , it’s not a quick process so i suggest once done clone your drive .

Hope this helps a little be for any noe that needs


Would you mind expanding a little on this?

I am pretty OK with using my PC, which is a little more advanced than basic, and I would love to know how to go about what you described.

Many thanks!

Ok well things like Privacy and notifications , down the left handside you have sections that if you click on those , you will see things running in the back ground like phone link , you just need to slowly go through all the options to see which of the ones you don’t want running . There are a lot of them , also , type in search ‘background apps’ and you will see a list you can disable .

The image is only for reference .
You can se all the different sections on the left , you will need to go through all of them and turn off what you don’t need

1 Like

Many thanks!

I use O and O Shutup because it kills all extraneous processes, seems to work too as Cubase runs very clean and glitch free.

Any reason I shouldn’t use it?

1 Like

This really seems like it could be a Native Instruments issue. I have large projects with 40+ tracks and 100+ inserts and literally hundreds of recorded audio events + midi performances and they load just fine on my laptop with a Ryzen 5 + 16GB RAM. But I don’t use NI/Kontact plugins anymore—I switched to Addictive (Keys/Drums), Spitfire Audio and Decent Sampler.

What you could do is get the Kontact performances tight and the settings right and then render/bounce them separately and treat them like audio events. Then you can just ditch the NI plugins entirely and see if suddenly your performance is much better. Also check if there are any updates to your player.

If you read the post well, I loaded a project with 8+ native instrumental product and with effects on it and it runs perfectly on studio one but on cubase just 3 NI products, no effects it buffers, glitches, cracks like hell with the same block size I used of 512. I dont want to be switching block size to get better performance.
After going through my phase 2 process, am now getting better performance but with less glitch but in the other daws it much better too. I loaded the demo project for cubase and I still got bad performance.
Well I ended my research and went back to studio one to get work done. I just hope Cubase work on their performance and it seems that studio one was created but some ex developer from cubase