How do I delete a page?

Dorico 2 (latest version).

See attached file. Maybe I am total misunderstanding how the page layout tools work. But…

I used four flows in my file. One goes on page 1 and three on page 2. So page 2 is supposed to show these three specific flows. There is not supposed to be a third page - but, there it is. How do I get only the two pages I need?

Thanks

Peter

Turn on Frames so that we can see what each frame shows, and then take the screenshot again.

My suspicion is that your Interlude is shown on page 2 in an LA (Layout) frame, but it still appears in the master frame chain so Dorico thinks it has to put that flow somewhere in the MA (Master) frame chain, so it’s created page 3.

Attached is screen shot with frames on.
Played around some more but the information in the online docs is not very clear to me.

So, are you saying I have to use layout frames for the page 2 frames?

Thanks

Peter

Right click on page 3 and select “Remove Master Page Change”. Repeat for page 4 (which should become 3 after previous step). You have Master Page changes for pages 3 and 4 which will insert pages there.

Thanks for your help again. Didn’t quite work.
I attached the file in question. Maybe you have a chance to open it.
Obviously an extra page at the end is not a big deal - except you have to remember every time your print or export it…

Thanks
Carla Bley 05-11-1936.dorico.zip (326 KB)

Dorico has a useful option in Layout Options, here:

It strikes me that rather than selecting this option you’ve gone to great lengths to implement it manually, which, in my opinion, is a waste of time.

I’ve done three things to your file:

  1. I’ve set the above option to “Allow on existing page”.
  2. I’ve edited your master pages to NOT filter specific flows.
  3. I’ve right-clicked a page (any page) in the right panel of Engrave mode and clicked “Remove All Master Page Changes”.

I think these three simple steps entirely solve your problem.

Try it.

If you have previously unspecified reasons for using the method of separate frames that filter individual flows, you could do the following:

  1. Remove the master page changes from pages 3 and 4. Page 4 will disappear.
  2. Edit your “second page” master page so that the music frames on it are part of the MA frame chain.

As soon as you “Apply” you’ll see that page 3 disappears.

I really appreciate your help and input. I must be too ignorant to get this to work.

If I try your first suggestion of removing the filters I lose control of what shows on which page.
If I try the second, the extra pages vanish but so does the music on the second page.

Clearly I am doing this wrong.

I guess I have to put in some more study time and go back to Finale until I understand better what I am doing.

Thank you very much!

Hi Peter,

Try this file. The main problem was that on page 2, you had the MP change for all subsequent pages. It needs to be for Current Page Only.
Carla Bley 05-11-1936 (2).zip (356 KB)

I dug a little deeper. The real issue was you had the Solos and Interlude flows assigned to the ML chain. Removing Interlude from the ML frame chain also solved the problem.

Hi Graig

This is such a weird thing. I thought I understand how master pages, frames etc. work but apparently not. I received the file you changed and it looks the way I want. I open my file (the parent of the one you doctored) and try to implement your suggestions - to the point where everything (frames, flow settings, etc) look like in your file and I still retain a third page.

The only difference I can tell is what you see in the attachment. Your version has a single horizontal green line above page 2. Mine has a vertical line in addition. This implies to me that my page 2 sees itself as the left page of a spread while yours is a single page.

You really shouldn’t waste your valuable time on this, but I appreciate it none the less.

Peter
Dorico pages.png

That’s because I set it to apply to current page only. But, I found that wasn’t necessary.
To get rid of the third page…
Remove MP changes to pages 3 & 4.
Edit MP “second pages” and remove the Interlude flow from the ML frame chain.
That should do it.

But you were talking going back to Finale. I wouldn’t wish that on my worst enemy. :smiley:

Craig,

And this worked. Thanks!
While I am getting faster on Dorico Finale has been my goto tool since 1988 - warts and all. That means I have literally thousands of Finale files that customers need updated and redone. I’ll be stuck with it for a long time.

Unfortunately there are many features I need every day that require me to jump through hoops or are outright not available (like guitar tab).
And I am not your enemy :slight_smile:.

Glad you got it working. My Finale comment was, of course, a joke. :wink:

Are there instructions for this anywhere? I have three completely blank pages at the end of a flow for absolutely no reason. How do you do a master page change, and why is this simple task so impossible? More hours wasted on Dorico.

Bob, it’s difficult because, in the nicest possible way, blank pages are always there because the user has done something they either didn’t mean to do, or didn’t understand the consequences of.

A jolly good place to start is the Pages section in the right panel of Engrave mode. A coloured corner on a page indicates an override of some sort. Even if you’ve deleted everything from a page, if there is an override then Dorico will not delete that page (as you must have put the override there for a reason) so you have to right-click the page (in that panel) and remove the override.

Does that help?

P.S. This thread came up yesterday: https://www.steinberg.net/forums/viewtopic.php?f=246&t=145137&p=780360#p780360

This seems to happen quite a bit: users try to fiddle with the program for hours, and only after they’re incredibly frustrated do they ask the forum. I’m sorry for your frustration, which I certainly understand. Next time, post here before wasting your time! :nerd:

Read here: https://steinberg.help/dorico/v1/en/dorico/topics/engrave_mode/engrave_mode_master_pages_c.html

or watch here: https://youtu.be/G6jw44a05Ro

Just adding to this old thread.

Seems to me the ability to delete a blank page is fundamental and should be simple. The suggestion that “blank pages are always there because the user has done something they either didn’t mean to do, or didn’t understand the consequences of.” - is rather patronising in my view. So, whilst writing a piece of music it is entirely possible that one creates several bars that get deleted - this is where for example my unwanted page came from. Once I’d tidied up my simple score I’d removed a few bars at the end and - voila - I now have a blank page that (in Elements) I can see no simple way of deleting.

Now I understand that Dorico wants to have the most sophisticated layout options of any Scoring software - but please, not at the cost of a basic editing procedure - many of us really don’t want to have to learn the intricacies of the entire engraving mode (and anyway not in Elements) to “tidy up” a score.

Thoughts?

The suggestion that blank pages are only created because the user does something isn’t a suggestion, it’s fact.
Without Engrave mode you can’t, to my knowledge, introduce Page Overrides. Without introducing Page Overrides you can’t end up with a blank page. Sorry if you find this patronising.

My feeling is that it shouldn’t be possible to do anything in Elements that you then can’t undo in Elements, so if you can find or construct a file that has a page override (or Master Page Change) that was introduced in Elements, please share it (or share the method). It’s possible to end up with a blank page in Elements if the page already has an override, of course, but the file would still need to have previously been edited in Pro (unless I’m much mistaken).

In Pro, deleting blank pages is easy once you recognise they’re caused by an override.

Yes, I agree with Leo that I don’t think it should be possible to end up with an empty page in Dorico Elements. Please do zip up and attach your project here so I can see what’s happened to it. Thanks!