How do I delete a stave of empty bars at the start of the music

G’day from Australia.

I have a score with voice and piano and I want to delete the voice stave in the first system.

I have searched the forum for answers and

I have tried Layout Options, Vertical Spacing, Hide Empty Staves
After first system
All systems
Allow individual staves of multi-staff instruments to be hidden

and all combinations of the above, but the stave with empty bars still displays.

Here is a screen dump of my challenge.

Thank you for your help and seeya.


I think to delete that empty stave you need to delete voice instrument instrument in Setup.

Hi !
I had a similar problem, and the first system would not disappear (be hidden) because I had changed things in it (I changed the clef…). Deleting the clef change did the trick. It is possible that there are some “explicit” objects written on those first bars, even though any musician would say they are empty. You might want to show every flag possible (in edit menu, flags, show all), try deleting the rests… Then, hide empty staves all systems should work.

HI Andre,

thank you for your suggestion. Unfortunately when I delete the player all the staves related to that player are deleted. I probably didn’t express myself correctly as I only want one stave in one system hidden/deleted.

Hi Marc,

Thank you for your suggestion.

I have deleted the rests, and also deleted the tempo marking from the stave.

I have tried Layout Options, Vertical Spacing, Hide Empty Staves
After first system
All systems
Allow individual staves of multi-staff instruments to be hidden

and all combinations of the above, but the stave with empty bars still displays.

There must be a way to delete a stave on a system that doesn’t have any data, but I don’t know how. Please help.

Thank you.


Well, Paul,
Actually it SHOULD work ! Is your file with no copyright limitations ? Then you could zip it up here so we can see what’s going on… I sent one I was working on to Daniel, and he was the one who found out the problem came from a change of clef. Anyway, I always use the “hide empty staves” option, and it works, unless “something” is in the staves.

Hi Marc.

Thank you for your quick response.

The file is imported from an XML file so I don’t know if that would make a difference.

Here is the file full of all the bad formatting. I am just learning Dorico and the first thing I want to do is to get rid of the voice part in the first system. The music is my own arrangement so it is not copyright.

Thank you for your assistance.

3 For The Blind Can See without (431 KB)

I checked the score but can’t find a way either, there is something strange though because rests should be showing at least. That is how it is set in Layout Options. When I enter something in a bar in that system, all the rests in that system are showing, but deleting that note, all of them disappear again.

Marc is right, it’s the clef change in bar 1 that’s preventing the staff from hiding. Click it, hit delete, and select ‘Hide empty staves’ in layout options.

Note: Only the clef change will disappear - the predefined clef will still be there. The only visible difference is that the clef won’t selectable anymore.

This is the expected behavior when you use the ‘Remove rests’/‘End voice’ function

Yes, deleting the clef solves the problem.
I noticed that the instruments are not right — I never heard a flute singing…
In Dorico, some edits work differently for singers than for other instruments : dynamics are automatically above the staff and so on…
I upload your file with my corrections. I hope it helps !
3 For The Blind Can See without (462 KB)

Thank you Marc for spending time looking at the score and uploading the file. Very educational for me.

Best wishes in all that you do and seeya.


Paul, I have found that importing XML files often results in a duplicate [hidden] clef at the start of the system. Selecting the clef and deleting it seems to eliminate the duplicate and leaves the original intact. Then the system will be hidden (if this option is selected in the layout options).

I’ve also found it helpful to reassign the instruments in the Setup to get proper sounds and symbol placement (vocal staves vs. instrumental staves). Also Select ALL and Reset Appearance, Rest Position, Reset Beaming straightens out numerous issues for importing XML files. YMMV.

This came xml file and I deleted the beginning clefs and have set hide staves in setup but no joy.
What is wrong.
hidestave (1).zip (959 KB)

use Insert mode (I)
select the empty bars (throughout all staves)

Robert, I’ve taken a look and something weird is going on in your file. It seems as if there’s an invisible independent time signature at the beginning of the two singer staves. I could not select or delete it so I created two new players in Setup Mode, copied the music of Soprano and Baritone to these new players and then deleted the old players. Now the empty staves are hidden as expected. I also noticed that there are two pianos without any music attached to the two (!) piano (?) players. I created a new piano player, again, copied the music and deleted the old players. I attach the file so you can take a look. I hope it helps!
hidestave hopefully (949 KB)

Thanks so much. Well I’m glad it wasn’t something I did. But maybe it was. It’s a puzzle anyway. Getting those staves to hide solves my main problem which was extra pages.
Thanks again.

I have the same problem. I want to delete two staves at the beginning of a flow (the singer) but I don’t know how to do this and can’t find any hint. Can anybody tell me what I have to do and if this is written somewhere in the manual and where I can find it?
To be more clear: I don’t want an option to hide all empty staves in a flow, I just want to hide these two at the beginning. Is this possible? (It is very easy in Sibelius.)

Dear Auerbach,

You can’t, yet. Or you might have to use a workaround : hide all empty staves, and fill the bars with invisible stuff (like spaces in shift+X text attached to the staves you do not want to hide).
[Edit] I am thinking of another solution, if your project has only one movement — and you do not use the flows as different movements or pieces of music. You can create a first flow without those instruments you want to hide, and the next flow will include those instruments. Make sure you allow different flows on same page, and that the last bar line of the first flow (in notation options) is a standard one, et voilà. Make sure the labelling of instruments is consistent (in Layout options).

Slightly off the subject… I was wondering if ‘trim flow’ could be (in the future) put into the measures popover, with an option for an absolute delete of the last x bars regardless of content.

Steve, you know you don’t have to actually get the minus number correct, right?

If I want to delete a load of bars at the end I just type -1000 into the popover. It deletes exactly as many bars as are remaining in that flow.