How do you route signal to the reverb bus on the mixer?

I have created a new project in Dorico 2 from the setup window (not from a template). When I open the mixer, there is a reverb bus set up and it has the Steinberg reverb VST.

But nothing I do gets any signal into that reverb VST. I see this old thread
https://www.steinberg.net/forums/viewtopic.php?t=108938

which seems to have contradictory information. On one hand, it says that as of 2016, this was known not to work. At another point in the thread, it seems to imply that routing is possible, but sometimes broken if you change the VSTi synth. But I cannot find anywhere that says how one actually sets up the routing or repairs broken routing.

Does anybody get signal to the reverb bus in their mixer or is this a known thing that is not yet working?

Doing a little more experimentation, if I use one of the provided templates, then there is routing to the reverb bus. But when I set up an empty project, there is no routing. That isn’t particularly surprising, but I am trying to figure out where I can go to add the routing. I can’t find that anywhere.

This is definitely a bug. When you create an empty project and add player/instruments to it, the mixer is set up with routing, with the first FX bus set as reverb. But nothing is fed to that bus.

HOWEVER, in the mixer in the sends for the instrument, if you set the bus to “–” (nothing), and then set it back to the reverb bus, the signal flows correctly. This is a bug with the initial setup of empty projects.

Fwiw, it works perfectly for me if I load a preset of the REVerence plug-in (medium hall seems to fulfill my needs), with the insert page visible — click on the rounded e next to the plug-in to enter editor and load the preset there…

That does NOT work for me. When I create a project REVerence is fine, but no signal gets to it, and changing the REVerence settings does not fix it.

I am testing at Dorico 2. Maybe it worked correctly at Dorico 1, but I doubt it because I see earlier posts that are exactly the same as my results with no fixes indicated.

The key point is you must create the project from scratch, not from a template. If you load a template, the signal paths seem to be OK. It is only the case where building from an empty project that I see the problem, and I can recreate it at will. Takes only a minute to create it. You need only one player/instrument. Throw in a few notes open the mixer and play. NO signal to the reverb bus.

Then in the mixer’s channel strip for you one instrument, view the sends. Set the first send to “–”. Then set it back to the Reverb Bus, and now signal gets to REVerence.

All right. I remember writing a post about that, in Dorico’s early days… I thought this issue had been solved.
I don’t have any access to Dorico until Monday but I trust you. It looks as though there must be some kind of reinitialization of the sends before they work, which is not the intended behavior

I see you use Mac. I use Win 10. This could very easily be a bug that appears only on certain configurations.

A minor update: I extended the test a little to be:

  1. Open Dorico
  2. Create a new score from empty file (not from a template)
  3. Add one player/instrument
  4. Insert some notes that will play back
  5. Open the mixer window and stretch it so you can see the reverb bus strip. Display the sends for each strip. Display the inserts, which will show REVerence inserted on the reverb bus.
  6. Notice that the first channel strip has its first bus send turned on and set to the reverb bus.
  7. Play the score. Notice there is no activity on the reverb bus.
  8. Save the file and close Dorico
  9. Launch Dorico and open the score just created
  10. Play the score and notice that there is still no signal going to the reverb bus
  11. On the first VST channel strip (for the instrument you added in step 2), set the first send to “===” (nothing). Then set it back to the reverb bus.
  12. Play the file and notice there is now signal to the reverb bus

I fixed a related issue just before release where the FX channel wasn’t set up if you added VST instruments before adding Players to the score. It appears that it didn’t fix this case. I’ll log it to take a look.