How to apply colors and such to all tracks ?


I know you can set the output busses to all selected audio tracks by keeping the shift key pressed (or am i wrong ?). But i can’t set midi inputs nor outputs to all the selected midi tracks, nor can i set the same color to the selected tracks (audio or midi). Can i ? If not, we must be able to do that. We must.

Best wishes


For applying Inputs and outputs to selected channels, try using Shift+ALT in the mixer. This works on audio tracks, don’t know if it works on MIDI as well.
Cheers, Matze!

No, Shift+Alt is in ProTools. You only need Shift in Cubase.

But how to apply the same color to the selected tracks ? Come on Steinberg, i have 453 tracks full of 5.1 stems, aux, rulers, and such. HELP.



There’s a color button in the arrange window. If not, look for the preference (right click on the bar…).

  1. Select your track(s)
  2. Push this button and select the colour.
  3. Voila


Ahhhhh, thanks a lot :slight_smile: It’s much better. Although i would prefer a Shift + color on the tracks to color all selected tracks but still, i can live with that.


Even easier, Ctrl+Click the colored box of each track and select your color. No need to hover your mouse back and forth between toolbar and track. However, I don’t know if it is even possible to apply it to several tracks at once. That would be nice :slight_smile:

BTW, selecting a group of tracks and pressing Shift+Alt to select the output IS the way Cubase does this for multiple tracks/busses. Try it!


I assure you : select several tracks, click shift only (either in arrangement window or mixer) on the output of one of the selected tracks, select an output, all selected tracks will have this output. Maybe i own a special copy of Cubase but i don’t think :slight_smile: Or maybe i don’t understand what you say.



You must have a special copy of Cubase cause mine doesn’t do that. After selecting a group of tracks, which I do by clicking on one and then SHIFT-Clicking the last, I then have to SHIFT+Alt+Click and hold the mouse cursor on the output box of one of the tracks (doesn’t matter which one) and then select the output I want them to be routed to. Seems like that’s the way it works for DocMa too.

Maybe a guy not that familiar with Cubase shouldn’t be offering advice until he actually KNOWS what he’s talking about. :smiley:

And has anyone addressed the MIDI input selection issue of the OP?

Well, thats what I do and it works!

Are you saying you use “shift” only and you can assign multiple outputs to tracks?

No, I may of misunderstood. I use shift to assign multiple selected tracks to a group.

Yes. That’s what i meant : assign different selected tracks to a same bus. Sorry if it was misleading to use the word output for busses. Still, for me a bus is an output…



But you do this ONLY using the SHIFT key as a modifier? I’m sure I’ve read (and used) that you need to use both SHIFT+ALT to make this happen.


I think that was how you did it on C4, I can’t remember when it changed but C6 it’s just shift.

That is weird.

Even when you hover your mouse pointer on the output of a Track in the Mixer (assuming you have the display tooltip option enabled in the Preference menu) it will state that holding down Shift+Alt enables you to assign an output to multiple Tracks/Busses. I tried doing it with Shift alone and it doesn’t work. It needs to be combined with the Alt key, at least for me. We’re either talking about two different things or there is something else creating discrepancies (maybe some old preferences/settings being dragged into the new version?).

Well I just checked the manual, and it says Shif/Alt (option) for buss setting to all selected channels and Shift for incremental assignment to multiple busses?

Which is interesting as I always just use shift and select the buss from the drop down!

So I select channels with Ctrl and assing to buss with shift.

On a Mac you use Shift plus Option after you first select all the tracks you wish to assign using only Shift. When you roll over the output for the selected tracks, the rollover Tool Tip clearly indicates “Shift PLUS Option”. Shift alone does not do the job.

You only need to press ALT to assign ins and outs on multiple selected tracks in the Mixer. Works for audio and MIDI. PC, BTW.

OK, you guys are not gonna believe this and I swear I’m not making this up. So again, for the third time today, I did the exact same thing I did the last two times I tried using SHIFT alone to select multiple outs:

1- I opened a project in Cubase.
2- Selected all tracks using SHIFT.
3- Used only SHIFT to select an output for these tracks.

The first two times I did this, it didn’t work and that’s when I came back and posted what you’ve seen so far. I go to try it again, for the third time like I said, and it didn’t work. No surprise there…BUT, this time I kept on trying. With all the tracks still selected, I held down SHIFT to select an output and guess what? It worked! Right in front of my eyes. I couldn’t believe it so I tried again several times and it worked. I even closed Cubase, started a new project (using the ‘Empty’ template), created a few tracks and a group channel and tried it again. It worked! I’m still in shock here because this seems like magic to me, so I apologize for my behaviour here. I simply can’t understand why this is all of the suden working for me, even when Cubase itself says I should be holding the Alt key as well.

I’m gonna restart my computer and see if it still works after that. BRB!