How to play external midi modules from my controller in Cubase?

Hi guys,
I have a project going on where some of the instruments (bass, synths, drums) are external midi modules. I have a MOTU express 128.
The bass module is on port 5 channel 6. I would like to play this module in real time as I record but so far can’t see how to do this. If I use my Yamaha P200 controller to play it I set up the bass track in cubase for an input port of 1 and channel 1 which is my P200 controller board. The base module is on port 5 channel 6.
If I record with this setup it records the midi data and sounds from the P200…only when I play it back will it play this midi data back to the bass module.

Is there a way to patch things so I can have the P200 trigger the bass module on port 5 channel 6?

Thanks guys


The Channel you set on the track, is not an input channel, but the output channel. So sweet this to Channel 6 (Port 5), please.

Hi Martin,
I did that but it only allows it to play after it’s recorded not in realtime. I must be over looking something as this is a really basic feature. I just haven’t found it yet.
The output port in the track appears to only be used after there is audio or midi data within the track. I needed it to have the input set to the P200 (port 1 channel 1) but have it be patched (midi thru) to port 5 channel 6) so I can play the bass module.

Is there a midi “patch bay” feature that I can drag the routing around?
Thanks for your input Martin.


In Cubase you don’t specify the input MIDI Channel. It always comes over all MIDI Channels. As the In Port, you can set the Port 1, or All MIDI Inputs.

Hmm. Okay. If I recall, last night when trying to get this working I think I disabled that feature. Let me take another look. Thank you

I re-enabled the all midi inputs in the Studio/Studio Setup/MIDI Port Setup but no change.
I also noticed something else that surprised me that is related.
I just loaded up a VST Halion. Input port is set to my P200 master board (Port1 channel 1) and it too won’t play it in real time.
I’m confused…


Again… You cannot setup Input Channel…

What about the MIDI Filters from the Preferences > MIDI? By default only SysEx is filtered out.

ah yeah. Gotcha.
How is this a problem? Certainly there must be many others simply trying to play an external (or internal) midi device in realtime.
I’ll look into the MIDI filters but if SysEx is the only thing filter out shouldn’t this be working now?


How is the MIDI Thru setup in the Preferences? It should be enabled too.

Yes it is enabled. So the issue is not only that I can’t play external midi devices in realtime but also internal synths like Halion. I have to be missing something!


How does the MIDI Filter look like?

Could you try to Disable the Preferences from the Cubase Safe Start Mode?

I’m not sure what you mean. I have to ask; how is something as simple as playing a built in VST midi instrument in real time this much of a hassle?
This is how things have been since I started with Cubase. I hope it’s not going to continue going like this. I’ll be burnt out in a year.

hey guys. I’m still lost as to why I can’t play any internal or external device in real time with either of my master boards. I would think it has to be something really simple but so far it eludes me.


Could you answer my question, please?

Could you try in the Cubase Safe Start Mode [Disable preferences], please?

OK, few questions…

  1. What Cubase version are you using ?
  2. What do you have in this window (Studio > Studio Setup > MIDI Port Setup pane in C12 Pro, but I guess that it’s more or less the same with other Cubase versions like Artist, Elements…) ?

  1. In Edit > Preferences > MIDI pane, do you have the MIDI Thru Active setting enabled ?
  2. Are you sure that the MIDI routing is OK, in the inspector ? FWIW, here is my setup, using a VMK-188+ as controller with a Yamaha TX802 external synth module, set to receive data from both MIDI channels 11 and 12 (it is multitimbral) :

Thanks Cubic for the effort here. I truly appreciate it.
I’m using Cubase 12 pro with the latest update.
This is an image of the midi port setup.

I only use two keyboards to play these modules. Port 1 channel 1 which is my Yamaha P200 stage piano…used for piano only really…and port 2 channel 1 for my General Music S2 Turbo keyboard which I use to play everything but piano. So I assume that only these two devices should be set up as “In 'All MIDI Inputs” setting? I actually have all of the “ins” set for this but this is because I was trying to figure out what was going on here.

No, MIDI Thru Active was not enabled!
Well that took care of that issue. I thought it was going to be simple and almost stupid to fix it but wasn’t sure what to do to fix it.

The MIDI routing looked good to me. I do have some multitimbral modules like the NanoSynth.
Thanks for your help!
I feel like I should almost start over with Cubase and the configuration. I’m not sure where to begin but I’m not so sure why so many things (since I started with Cubase) have been not working as expected. The learning curve has been steep and I think it’s more because these defaults settings might not have been working out of the box as they should have.

So I see you are using, what looks like some external midi modules as I am. When using external modules you can not “render in place” the audio from these midi tracks because the devices are not a VST within Cubase? Is this correct?

I think I need a better way to learn the configuration of Cubase then fumbling through things. This is taking a long time and I don’t feel very confident in what I’m doing yet.

Also what complicates things quite a bit is my audio interface is a Behringer XR18 digital mixer which for sure adds a lot of options that I wouldn’t have had I gone with a simple audio interface. It’s a lot to understand.
I think I need a audio flow chart to understand more about how things work with this setup. Monitoring directly is a good thing, especially since the XR18 has it’s own effects but wow does it making things very confusing to learn.

Thank you again!

1 Like

Ha ! I didn’t know that the Express 128 is giving 8 different MIDI ports to the user : good to know,… :slightly_smiling_face:. Beside this, the operation manual has nearly 1400 pages whjich tell us something about the complexity of the whole system. And yes, it’s rather easy to forget a setting here or there : we have all went through this, I guess…

Yep… According to Cubase operation manual, you can only render MIDI parts in instrument tracks, not in pure MIDI ones used for MIDI external synth modules. So, what I do to “render” these is simply recording the audio stream coming in dedicated line inputs (I use a Behringer ADA-8200 for this). The process is simplified if you have set your synth modules as external instruments in the Studio > Audio Connections > External Instruments pane, and are using a dummy bus to route this stream to dedicated audio tracks.

Beside this, I never tried to use direct monitoring, as the RME ASIO driver allows me to monitor any audio signals with a minimal latency (usually, when tracking, I have my Fireface UCX set at 128 samples (3 ms at 44.1 kHz). And concerning the audio flow chart, at a time, there were several of them in the Operation manual (circa Cubase 5 / 6), and they were truely helpful. Why these have been removed since ? A mystery… :thinking:

Well the MOTU 128 MIDI Express is giving 8 ports to the user compared to the models with much less I/Os. This type of MIDI patch bay isn’t really used much anymore because most are using VST. I carried this over from my old setup where nearly every MIDI device was external to the PC. I replace my old MIDIMan Sport 8X8 with this MOTO due to the MIDIMan taking waaay too many coffee breaks in the middle of my sessions. I backed over it with my truck and never looked back. MOTU is the way to go and wish I purchased the MIDI Express 128 from the beginning.

Yes bouncing a MIDI track to audio, I learned simply needs to be recorded during play back of the midi. I wonder though…do you think a macro can be setup for this where one press of a button will configure things to do exactly that. Setup a new track, then record enable that track while muting the rest (better yet, solo the midi track)…etc. What’s your thoughts on this? So it would be like Render In Place for external MIDI devices!

Having the XR18 digital mixer certainly offer a ton of options for stuff like this but wow does it get confusing. The routing options are crazy but good. I just have to find a “standard” that works for my studio setup.

Reading the manual as a novel I don’t think is the way to learn. I don’t think it would work for me but I do refer to it quite a bit. It’s helpful but not nearly as detailed as I wish it was in some subject areas. Good thing for YouTube and this forum.

Thanks for all the information. Super helpful to me!

Interesting, but I’m wondering if this is doable, as there is no way to create a track and set the routing needed with only key commands, AFAIK. Here, and if I need it, I have all this already set in a project template in the following way, taking again the TX802 as synth module. It is defined as an external instrument, appearing in the instruments rack, and set as a MIDI device in the MIDI Device Manager window (for the use of its presets with a custom built programs list) :

This allows me to create :

  • a MIDI track with its Output Routing set to TX802 as external instrument, with an usable presets list,
  • a ‘dummy’ bus (No bus as Output Routing) which receives the incoming audio signal from the synth appearing in the VST instruments folder,
  • an audio track which has, as Input Routing, the bus defined above.

Works flawlessly, without having to bother creating these, each time I need them…

1 Like

Sick! Great idea!
I’ll have to look into this. I’m still fumbling through all of this. My brain goes on vacation whenever I look at anything in Cubase that requires more thought then creating a new track. It must be my ADHD. Drives me nuts but I’ll stick to it.

I’m trying to understand why the midi modules like the NanoSynth, NanoPiano and NanoBass, when setup in the Midi Device Manager won’t respond to bank settings. Was the TX802 a default present in the Midi Device list or did you create it? If you created did you also setup all the patches and banks for it?