How to set up sustain pedal on Akai MPK 249

Hi there, I just bought new keyboard controller: Akai MPK 249. It’s groovy but I have problem to set up sustain pedal. When I push it, it’s MUTE function. I’ve found that it’s probably Cubase problem - I dive into midi set up and can’t find command SUSTAIN, other words - there is no SUSTAIN message I can assign to pushed pedal! Is it possible? Pleasse help

Hi and welcome to the forum,

Obviously, you have setup Akci MPK249 as Mackie Control device. Please, remove the Mackie Control Device or set the MIDI Input to Not Connected.

Additionaly, I would suggest you to use the MIDI Monitor plugin, bundled with Cubase, as a MIDI insert on the track you are working with. You should get something like this when using your controller (sustain being CC64 - MIDI 1.0 specification) :

If you don’t get MIDI CC64 values when pressing your pedal, something is wrong in your MPK249 settings, as Cubase recognize these messages without issues, here.

Another way to check this is to record few MIDI notes with your controller, while using your pedal : when opening the key editor, a Sustain CC64 controller lane should appear at the bottom of it, displaying the values received.

There seems to be 3 posts with the same question.
The earliest being:

Hi !

So I tried to use the MIDI monitor and notice that Cubase doesn’t detect my pedal…
I have not any Mackie control device in my studio setup and the pedal still mute the track.
I’m on the last Cubase pro version.

any idee ?

Hi,

Could you please attach a screenshot of the Studio Setup?

Yes no problem !
I just have the MIDI Remote given by Cubase

And if I try to reassign It, there is not any correct assignation.
I had this problem in previous versions of Cubase and I solved it by giving the .xml of the MPK249 but now it is no longer possible to go through a generic remote

Found the solution !!


If It can help someone, I had to toogle the “direct music” checkbox and all is good !
(I notice I had to do It each time I launch Cuabase)

I really think that is a bad default setup made by Cubase. It really deserve a patch ! :slight_smile:

2 Likes