How to solve connection issues

Hi there,

If you are having problems connecting to your computer please read this troubleshooting article:



I am using Cubase AI6 with my Motif ES6 and Rack XS over FW16. Since I have also iPad2 and Yamaha applications, I saw very interesting possibilities with Cubase iC Pro remote control.
I have bought it from AppStore and set up as it is said in manual. I have installed SKI remote (latest version) enable it as a device in Cubase AI and set both PC (Win7 32bit) and iPad to the same wireless network.
iC Pro recognizes both Cubase and my computer (I could see under connection Cubase AI @ MYLAPTOPMSI) but connecting last about one minute and stops.
I have read all instructions for Windows and check everything:

  1. Bonjour service is running
  2. Cubase AI is enabled in Windows Firewall.
  3. All other network adapters (LAN, virtual WiFi) are disabled except Wifi.

I have even tried to set ad-hoc network between PC and iPad. Network works fine, but iC Pro still not. Then I have read that maybe on some Win PC’s problem could be if WLAN security is other than WEP. Mine was WAP-Personal and I have changed to WEP. Still nothing, situation is completely the same.
Does anyone have similar problems?
P.S. Provided link for troubleshooting article don’t work!


I have the excact same problem…spent hours on this and still no luck…

Read my post under the Cubase iC Pro official tutorial. You might be running into what I am running into.

Regarding the news that you allowed Cubase through your Win7 Firewall, in reading about Wi-Fi connection, it becomes clear that you can disengage the first Firewall in Win7 (there are two Firewalls) without any ill consequence. This would automatically allow your Home Network access to Cubase. You can leave the second Firewall up - the one that deals with the internet - but even that one is reported by some to not be necessary. Eh, I leave my second one up anyway.

If you read my post, you will learn that I am running into having to run the Home Network Diagnostic tool in order to establish connection from my Home Network to Cubase via the Ski software. Win7 does not want to easily move between the two different networks I have setup. Try what I suggest, do what you are doing and then run the Network diagnostic tool.

I have bought the IC Pro and have severe problems to connect to my Windows 8 PC.

My set up:

  • OS Windows 8 64-bit
  • Motherboard ASUS PT 6 SE
  • CPU I7 920
  • Latest Cubase Remote SKI
    -Realtek 8111C PCIe Gigabit LAN (latest Windows 8 drivers)


  • iPad 3 with iOS 6 (I have not done the last update)

I have tried the following:

  • Secured that Bonjour is working. I have tested to manually restart the service. Uninstall iTunes and ONLY install Bonjour
  • One IP for the computer (i.e. no WIFI, just an Ethernet cable connected to my WIFI router). NOTE: I do not use an ad hoc connection, I connect over a router.
  • Open the Windows firewall for Cubase
  • Disabled Bluetooth on my iPad
  • Disabled the firewall in my router
  • Changed the router to WEP from WPA (I did not like this however…).
  • Tried to connect the iPad to another router on my network (hidden SSID, locked MAC-address and WEP).

Notes (strange things found when trouble shooting for 24+ hours…) - I got the connection working flawlessly ONCE after the iTunes thread was killed using task manager (this worked one time only…). This worked one time only??! Now I do not even have iTunes installed any longer (only the “Bonjour Print Services for Windows v2.0.2” linked by Steinberg). NOTE: The version installed by iTunes is 3 something…

  • I normally “see” the iPad in Cubase but I normally do not see Cubase in my iPad (IF I see it, I can connect).
  • I did sometimes get the connection to work (but unstable) when fiddling with WPA/WEP.
  • I sometimes get the connection to work if I restart my router (starting like this will however hang Cubase after a few minutes work…). NOTE: The router has no firewall enabled. Both the PC and the iPad has full internet working.
  • This PC is also a “Hackintosh” running OS X Lion. When booting into OS X the connection is working flawlessly (but I do not like to run Cubase in Lion as the performance seems to be somewhat lower and I have some VST that are Windows only).

Please help! I have spent too much time and effort on this!

My guess: Apple has some undocumented “features” in the Windows version that you are not aware of…

1 Like

Almost a week since I made this post and still no reply or solution from Steinberg.
Do I really have to cancel the purchase in iTunes?

:imp: EDIT: Found the following when going through my error logs.
I guess this is the reason for our problems but why and how to solve? :imp:

_Client application bug: DNSServiceResolve(Cubase\032@\032MIMAN._smtrot.tcp.local.) active for over two minutes. This places considerable burden on the network.


ONSatan, all our apologies for having skipped your message so far.
Next time you’ll have to report a problem make sure to create a topic for your own issue on purpose.
It’s easier for us to track the pending problems and you allow it a top visibility. :wink:

Anyway, thank your for reporting that log.
It’s a new valuable information for us indeed.
I’ve googled that error shortly and based on the recent reports we’ve got it seems that sometimes the problem’s more related to the routers’ configuration.
One user got it recently working once he updated his router to the latest firmware. Did you?
You should also check this site: Recommended settings for Wi-Fi routers and access points - Apple Support

Moreover, since there are a few networking issues reported that we aren’t able to reproduce on our PCs here, we will implement a manual connection dialog box in an ongoing update which will allow you to connect to Cubase by only writing your DAW’s ip address. Should likely resole Bonjour’s lack of reliability on some machines.


Dear Armand,
Thanks for your reply.

I did check the provided link. Did fulfill all recommendations (had previously changed back to WPA from WEP as WEP did not change anything in a positive way for me).

I have not changed/updated the firmware in my router and it could very much be the thing that could “solve” this problem. Reason being, the router is provided by my network supplier and I do not have the possibility to update firmware on my own. A thing worth to note here is that I am randomly able to connect during the reboot of my router (i.e. it looks like the combination of my router, IC Pro, Windows 8 (64-bit) and Cubase is “guilty”).

And, note that the same router works (with the same actual PC) when I boot into OS X Lion and use the same iPad with same IC Pro to connect to the same version of Cubase 7, same version of SKI etc.

I have also some other strange information to give you about things I found when trouble shooting:

-There is in Google play a competitive product called “To….daw”. This is also using “bonjour” on the PC. This works perfectly and is very snappy when connecting from my Android phone. This is on the same Windows 8 installation that refuses to let IC Pro to connect to Cubase 7 (this is how I have “solved” the situation for now). One difference might be that the program installed on the PC for To….daw seems to be 32-bit (SKI for Windows 8 64 bit is 64 bit I guess?).

  • I will almost always in Cubase see the free version of IC but almost never the IC Pro. Even though I see the free version, it will normally not connect if I do not randomly start/stop iTunes, start/stop bonjour, reboot router, enable/disable Ethernet, etc (this can take hours so it is not an option). In fact, I will normally not see the computer in any of the free or Pro version but can frequently see the free version in Cubase…

Is there a difference how the free version and the Pro version communicate with the SKI?
What could cause the SKI/Cubase to see the free version but the free version not to see the computer?

Let me know if you would like to get any other logs or things like that.


I had problems at first but after following the adhoc ipv4 tutorial it gained the IP automatically.

Can’t you just create the ad-hoc network for the sake of using IC?

Dear all,

as announced yesterday, Cubase iC Pro 1.0.4 is now available at the iTunes App Store:

Besides fixing minor user reported problems, this update adds the option to enter the IP address of a computer manually to support all users having connection problems with Cubase iC Pro.

Furthermore we’ve added a Knowledge Base article that describes how to determine the correct IP address of your computer (to be entered in the IP address field in iC Pro):

Please give this update a try and let us know if it helps to solve the issue.

& greetings from Hamburg


I just bought IC pro, first time the connection worked and I have done a recording session succesfully. But if I put the ipad in sleep mode for some break, it looses its connection.

And one main thing is more annoying me. After I finish my recording session with IC pro for one prject, I close that project and opened another project. The IC pro never recognises my computer anymore. I feel very disappointed. If it is the way IC pro will work please let me know if I can get my money refunded. Or kindly help me to solve my problem.

I am using Windows 7 ultimate 64bit, with Cubase 6.5 64bit, latest SKI installed, Bonjour running, connected ipad via ad-hoc wifi network, disabled anti-virus program (Kaspersky) and I use iPad Mini 32GB(Cellular version).

I would be glad to receive a solution immediately as I’m in between my hectic session which need a remote app.

Anil nc

I posted this in another thread and I’ll repost it here in case it can help someone with connection issues. I’m using the Android version and Windows:

"About connection problems, my firewall had very restrictive settings for local network too, and so I had to ‘trust’ the computer’s local IP address to make it work. In fact, Cubase freezes at opening while loading the SKI module if the local IP is not trusted by the firewall.

Also, I need to ‘trust’ the local IP address of my Kindle tablet to make the computer’s name appear in the app’s opening page so that I don’t have to write the host’s IP every time."

Finally I found the solution!
I have checked everything as per instructions given on Steinberg site (link provided by Oliver):

  1. Bonjour service is running
  2. Cubase is activated in Windows Firewall (both private and public networks)
  3. I have set up a new ad-hoc network with WEP security. Previously my ad-hoc network don’t have any security and now it is a problem!
    So, to conclude, check your ad-hoc network, since for previous version of iC pro security option is not needed.
    Now everything works fine and smooth.


Hi all,

Im still not exactly sure what you did to make it work.

I have performed all the steps in this thread and although IC sees my PC it just hangs on the connecting dialogue.

I have created an ad-hoc network in Windows 8 using the command line but there are no options to created a network without a passphrase. Is this what you mean when you say ‘security option is not needed’?

I’ve tried using some hotspot software but haven’t found one that allows an open network with no passkey.

The annoying thing is that the basic version works fine and now I’ve paid for the Pro version it wont connect…

Hi all!

I know this topic is quite old, but just to offer some clarification:

Cubase IC Pro does not care if you use WEP, unsecured or WPA, adhoc or wifi access point as long as your network is properly setup. But the choice of encryption might be key to get your network stable. This depends on your network equipment (soft and hardware) and we have no influence on that.

Cubase IC has its own security mechanism to protect your mixer from unsolicited manipulation. This can be set in Cubase > Devices > Device Setup … > Remote Devices > Steinberg Remote SKI
If you type the wrong password, your connection will fail. but this has nothing to do with your network if it is stable.

I hope this information helps some of you out there pinning down where exactly your connection breaks.

Just thought I’d add my 5 cents. If you add a new hard-drive, the SKI remote plug-in might disappear!

This happened to me a while ago. IC pro, suddenly, connect. It claimed that there was no computer on the network. I found this strange. Everything else, including the iPad itself, worked perfectly over the Wifi network.

That the SKI remote plugin could be erased by installing a hard-drive, didn’t enter my mind. Also, the error message, indicated that there was something wrong with the network. It should have said that it couldn’t find a SKI remote plugin, not that there was no computer!

After a while I noticed that the SKI remote was missing in the Remote Devices pane. I reinstalled it, and IC pro worked perfectly.

So…if IC Pro suddenly can’t connect, have you installed some (seemingly totally unrelated) hardware?

Hi Svenne,

better late then never, a little reply.
I doubt that adding the hard drive deleted the SKI extension. It is possible though that IDs or labels or addresses where changed as you added the disk causing detection failure. Any ways, you solved it through reinstallation which is in doubt fixing almost all possible problems with most our products. Well done :slight_smile:
Regarding the error message:
The tablet side of IC Pro can not determine wether the SKI is just missing or if there is another connection issue. All it knows is that there is no reply from the other side, leaving troubleshooting to the user (ping would be the next logical step). I am not aware of any remote software (including RTP midi) which has network troubleshooting facilities built in as this is solved better in specialized tools.
Thanks for your understanding.

To prevent further single case posts popping up I am going to lock this thread, if anyone thinks the thread should be reopened please PM me.
Please open a separate thread if you have an issue that has not been solved in the forum already.