How to transfer Cubasis LE 2 instrument and effect plug-in in-app purchases

Dear all,

Please follow the steps below to transfer existing Cubasis LE 2 instrument and effect plug-in in app purchases to Cubasis LE 3 or Cubasis 3.

Best wishes,
Lars

(I) How to transfer Cubasis LE 2 instrument and effect plug-in in-app purchases to Cubasis LE 3

Pre-Requisite

  • Please make sure Cubasis LE 2.8.3 and Cubasis LE 3 (3.0.2) are installed on your iPad

Steps

  • Launch Cubasis LE 3 and open the in-app shop
  • Follow the instructions shown in the IAP Transfer pop-up

(II) How to transfer Cubasis LE 2 instrument and effect plug-in in-app purchases to Cubasis 3

Pre-Requisite

  • Please make sure Cubasis LE 2.8.3 and Cubasis 3.0.2 are installed on your iPad
  • Please make sure Cubasis LE 3 is not installed on your iPad (or else the existing instrument and effect plug-in in-app purchases are transferred to Cubasis LE 3)

Steps

  • Launch Cubasis LE 2.8.3 and open the in-app shop
  • Select “Cubasis LE 3” page and tap “Transfer” button

Hi Lars
LE3 activation via interface and IPA Transfer from LE2 worked perfectly :+1:t2: (after today’s update to LE2)
The full feature set upgrade is currently actually cheaper than when I did it in LE2 in 2017 in the sale so I’m happy and now have Cubasis on my iPad and iPhone
Thanks and keep safe
:grinning:

Good! Looks nice and unlocked immediately with my Hardware (UR22)!

IAP-Transfer worked after I had updated Cubasis LE 2.8.2 up to 2.8.3 (the update for LE2 didnt show up until now, but now its here) and:

I´m happy, all In-App-purchases are there again!
And MiniSampler allows me to Edit my own Samples!
And it all looks fresh and seems to run smooth!

Thanks a lot!

This is not working for me. I am on an iPad Pro with IOS 13.4. I have Cubasis 2 v 2.8.2 with many plugins purchased. I also just purchased Cubasis 3.0.2 on the app store.

Upon opening Cubasis 2 I have no option to “Transfer” any purchases, and upon opening Cubasis 3.0.2 When I go to the in-app Shop and attempt to restore purchases it tells me there is nothing to restore under my account.

How can this be resolved?

Please install the exact versions mentioned in the instructions, and follow the steps!

Best,
Lars

I didnt see CuBasis 2.8.3 available in the app store until just now. I installed THAT, opened it, and used the in-app transfer option. It worked. Problem solved!

Can you transfer your in-app purchases from Cubasis 2 to Cubasis LE 3?

Hi CharelsMay,

Glad to hear it worked!

Thanks,
Lars

on my ipad pro, I installed cubasis 3 LE. On this side everything works very well. I bought the full version and I successfully transferred all the in-app purchased from Cubasis 2 LE. But! I also have an iPhone XR - everything seems to be working except for one thing. The full version does not work! and yet it says “bought” in the shop … and there is nothing else to do. I have tried everything. restarted the iphone, reinstalled the app … nothing helps. it clearly strikes me as a bug. thanks for getting back to me

just to try, I re-installed cubase LE 3 on my ipad pro and the full feature set option says bought but no longer works!

Hi jeandoka,

Please check the following:

  • does the Cubasis LE launch screen shows the „Cubasis“ logo when launching the app?
  • Are you able to create more than 4 audio and/or more than 4 MIDI tracks?

This easily proofs that the Full Feature Set IAP has been properly installed.

Technically it is not possible to change the name or icon of the app.

Best,
Lars

———-

hello Lars!

I’m going to recap all of the steps I’ve taken.

First, I installed Cubasis LE 3 on my iPad Pro.
Then I plugged in my Irig pro duo to unlock the application.
Immediately, I transferred my in-app purchases that I had made on Cubasis LE 2 (I had bought all of them).
Then I registered for my Steinberg account.
And, finally, I bought the full feature set.
And there you go! everything worked perfectly.
When I started Cubasis LE 3, the display indicated Cubasis 3 and I could create an unlimited midi tracks.

I was really happy!

Then I wanted to install Cubasis 3 on my Iphone XR.
I only had to install the application and everything was done automatically.
The Full feature set and all plugins were 100% functional.
And when I started the application for the first time on the Iphone XR, it was well mentioned Cubasis 3 and not Cubasis LE 3.

It was great!

Some time later I take the Iphone XR and I restarted the application but this time it was Cubasis LE 3 which appeared on the screen …
Intrigued, I quickly realized that the full feature set was not activated …
I went to the shop and, strangely it said that the full feature set was well purchased (Bought!) …
With the exception of this, everything worked fine and all in-app purchases that I transferred are functional.

I tried everything … on the iphone XR - I uninstalled and reinstalled 2-3 times Cubasis LE 3.
Nothing to do. The only thing the application asks for is to reconnect my irig pro duo for unlock and afterwards the full feature set does not work and I cannot restore my purchase.
Anyway, again, it indicates that it’s already bought …

During this time, everything continued to work on the iPad Pro.
And when I started the application on the iPad pro, it was written Cubasis 3 on the screen.
And all the full feature sets worked.
Still doing tests, I then deleted the application on the iPad Pro to reinstall it.
Error!
Now I have no longer been able to make it work.
And as on the iphone XR, in the shop it indicates that the full feature set is purchased.
But it doesn’t work anymore!

I put a lot of details.
I can send photos if necessary.
I understand very well the difference between Cubasis 3 full feature and Cubasis LE 3.
For me, this is clearly a bug.
If I summarize one last time, I installed Cubasis LE 3, I bought the full feature set.
Now, it clearly indicates in the shop that the full feature set is purchased.
But it’s still the LE version that starts.

At this time, I can no longer use the app.
I imagine I’ll wait for an update.
Unless this is a problem with my Steinberg account. (?)
I remain at your disposal if you have any questions and hope that this problem will be resolved quickly.

Thank you

Hi jeandoka,

I would suggest to re-install the app.
Once done, please do this:

  • Start demo mode
  • Open in-app shop
  • Tap „Restore Purchases“

Best wishes,
Lars

hello Lars, I went into demo mode.
I went into the shop.
The restore purchases button does not appear anywhere …
neither on the ipad nor on the iphone

That may be the problem?

Jean

hello lars
I have exactly the same problem, installed on my ipad air 4 cubasis le3 ur 242 connected le3 unlocked, paid 20 € and transferred the iap from the cubasis le 2. everything great :wink:.
with my ipad mini the same procedure, only the full feature set is not activated, but is shown in the shop as “bought” (activation with the ur 242 also worked, so cubase is no longer in demo mode). if I now uninstall cubasis le3 and start it in demo mode, no restore button is displayed.

I would think that was a bug too, maybe?

hope for help marko

Hi Marko, Hi Jean,

When opening the shop, after having demo mode started, “Restore Purchases” should appear top right in the shop window.
Do you see it there?

Best wishes,
Lars

after new installation, no restore purchases button in demo mode.
not right not left not in the middle nowhere :wink:
marko

ps.
I would also have two further questions,

  1. Would it be possible to make the group folder collapsible (more space on the display)
  2. Would it be possible to move the cpu / dsp display to the first row?
    otherwise it is not visible when the effect or instrument window is open.
    but first, one by one

Hi marko,

I’ve just downloaded and installed Cubasis LE 3 from the App Store on my iPad Pro 12.9" 1st Gen.
Here, I am instantly able to see and use the “Restore Purchases” feature.

These are the steps again:

  • Launch Cubasis LE 3
  • Start demo mode
  • Open In-App Shop
  • Tap “Later” in IAP Transfer popup-window

Located top right in the in-app shop you should see the “Restore Purchases” feature.

Please let me know if this helps to solve the problem.

Best,
Lars