Hub doesn't Connect issue with Cubase Pro 9.5

Guess this is my first post. I picked up Cubase yesterday (so I’ve had it for less than 24 hours) since Cakewalk SONAR early end-of-life. So Hi!

When I start Cubase 9.5 I was surprised to find that the Hub was always showing Connecting… and would never show any of the content. Some googleing found a bunch of people with this issue but solutions were pretty much non-existent. I write Windows applications for a living though and working this out is (sadly) well within my skill set. It took a bit but I’ve figured out why and can recommend some solutions.

In a nutshell Cubase (via the hubsupport.dll) loads/uses DLLs from the eLicnenser tools directory (for me this was C:\Program Files\eLicenser\Tools) this includes QtNetwork4.dll. The problem is that QtNetwork4.dll imports ssleay32.dll and libeay32.dll DLLs. These DLLs provide the OpenSSL support for apps that want to us encrypted HTTP.

Since the eLicenser Tools directory isn’t in Cubase’s path, the actual DLLs loaded depends on the user’s path (and a lot of other things including some system settings/etc). In my case some application (still not sure who) had installed its versions of ssleay32.dll and libeay32.dll into my Windows\System32 folder. As a result Cubase was actually loading those versions, instead of the versions in the eLicensers Tools dir. Which might have been fine, but the DLLs in my system were/are newer than the version eLicenser installs. And they don’t have the same DLL exports. So the loading throws an ordinal not found exception. Which results in the whole QtNetwork4.dll failing. Which causes the Cubase hub to show the “Connecting…” message and never show any web content.

I think Steinberg needs to modify every single application that uses this eLicenser tools dir to first do a SetDllDirectory() call on that path, so that it will look for DLLs in that directory before using the rest of the user’s path. Or perhaps they should move the support DLLs into the Cubase exe directory and not do this “shared” support DLL directory thing. There are also a few manifest tricks they could use as well, but they need to do something so that DLLs in the system and other folders with the same names as the DLLs in the eLicneser tools dir aren’t loaded instead of the ones they want.

In order to solve this problem there are a couple of ways you can do it. The best solution for me was to copy the version of the OpenSLL DLLs that Cubase/eLicenser wants into the Cubase exe directory. That is I copied C:\Program Files\eLicenser\Tools\ssleay32.dll and C:\Program Files\eLicenser\Tools\libeay32.dll into the same directory with the Cubase9.5.exe file. If you have a version of QtNetwork4.dll or QtCore4.dll in your path (because of another application) you might need to copy more DLLs from the eLicenser Tools dir into the Cubase dir. But that might lead to problems if/when eLicneser is updated.

Once I did this, the Hub Connect would show actual web content.

(I also added firewall exception rules for Cubase but I don’t think I actually needed them, my problem was the network support DLL load issue)

Being new to Cubase I’m not sure if submitting this to Steinberg is worth my time, but I’m posting this here so that it might help someone.

Do you suspect this could be a fix also for Cubase 8 ?

And if I do as you suggest are there any risks of breaking anything making matters even worse, requiring a reinstall, etc., etc., or could I just erase the two copied files from the Cubase exe folder and be back to my original condition ?

Bob (and BTW tnx for taking the time to post this. I’ve seen several posts about this issue and Steinberg apparently does nothing about it- odd since its a real advertising opportunity for them in the Hub and I should think a relatively easy fix in the cost vs. benefit tradeoff, as opposed to some little never noticed bug fix…).

Hey Matt,

Thank you so much for the solution and the detailed description of the backgrounds. It’s so simple and it works!
I just copied ssleay32.dll and libeay32.dll into the Cubase9.exe folder (resp. accordingly folders of older Cubase versions) and everything works fine.

It’s a solution for:

  • Cubase 10
  • Cubase 9.5
  • Cubase 9
  • Cubase 8.5
  • Cubase 8
  • Cubase 7.5
  • Cubase 7

Remark: If only files are copied into another directory there is no risk. Delete them and you are as you were before.

Update: At least with eLicenser-SW V6.11.9.2259 or newer the Hub connects with Cubase 10 and Cubase 10.5 without any tweaks.

I agree.
It does work!
Thank you so much Matt.


PS: I updated the eLicenser but that didn’t fix it, your solution did.

Worked on one machine, on another didn´t… :.(

Both machines (PC?) run the same version of Cubase (which)?
Both machines run the same OS?
Internet access works on second machine and it is online when opening Cubase?
Any differences in firewall configuration?

Both machines run Win 10 pro 1809 latest version all updates done
And C10 as well
Internet acces works on both
Firewall should be the same, I added a Cubase exception as well.
Switching on or off Kaspersky does not make a difference.
Will check firewall again.

I assume you counterchecked if both files are copied into the right directory.
Do both user accounts have the same privileges?
Have you tried to start C10 as administrator?
As some users seem to have problems with the first installation, did you try to un-/install C10 again?
Did you try to start C10 in factory settings mode?

In the english manual for C10 (page 1101, Where are the Settings Stored?) you can find where the preferences and customizations can be found on your machine.
Try to rename the preferences folder to let Cubase start from a clean environment.
You may also try to disable or delete preferences as described on page 1102, Disabling the Preferences).

Click on “Help”->“Cubase Help” in C10 and you are referred to the online help resp. PDF version of the manual.

By the way - if you have earlier/other versions of Cubase installed on the machine get these user preferences directories also out of the reach of Cubase. Rename the directories or move them temporarily to another folder (e.g. a directory at the same level as the Cubase preferences folders to keep the appropriate privileges).

Yes, checked firewall. Seems ok.
Will go on with your further hints, which will last a while longer…

I have the same problem on my iMaci7
My steinberg hub not connecting
Do u have any idea how to fix problem?

Unfortunately I am not familiar with Mac-OS - I am sorry. Although it’s a really annoying issue it is fortunately not an essential function for the work with Cubase. I suggest to create a Steinberg support ticket. (

I have the same problem with Mac OS 10.13.6 (both fresh installed machines with latest software updates). I think this connection problem might be related to latest Mac Security patch since before that every thing was working just fine.

Same issue here.
Mac 10.14.3, latest OS update seems to have hindered the Hubs ability to connect, just hangs on “connecting”. Still able to open sessions and sessions function normally.
If I try to quit Cubase while Hub is trying to connect, it will not quit, hangs and I have to force quit out. If I open a session and then close Cubase, quits as expected.

Same issue as below, I updated to Mojave 10.14.3 and the Hub will not connect on all current and prior versions of Cubase Pro which sort of implies that the OS is locking out the connection. Have looked at security settings in apple and no filter is being applied.

We are currently having a look at the issue on macOS.

The issue is back on W10 again since yesterday. Outdated SSL Certificate on the link in the hub is stipulated by error message.

happens here, Mac OS Mojave, cubase 9.5

On my machine the problem solved “by itself”. Obviously the ssl certificate had been renewed

It started to connect last night, thank you.

Since today the Hub with Cubase 10 Pro connected again on macOS 10.14.3 (Mojave). Finally. A big thanks to all involved… :slight_smile: