I cannot add extra pages to a flow, as the extra pages go over the following flow

I have a simple piano score. I have say 3 flows in the project. I fill in the 3 flows with notes for say 4 pages per flow. Later on, I decide to go back to flow 1 and add 2 more pages of measures. The pages are numbered. When I add say 120 extra bars, they overflow on flow 2 instead of adding to flow 1!! Why could I not add extra bars and have them added to flow 1 and the page numbers are automatically updated and the extra bars added to flow 1 do not add to flow 2?
Such a simply thing should work easily but it does not.

Hard to tell what’s going on without seeing the project, but I suspect there are page overrides and/or custom flow assignments to music frames in the layout, that prevent automatic page insertions where you want them. Can you show us?

Again, we’ll need to see the project - or at least some screenshots - to tell what’s going on, but it sounds like you’ve “done too much” to the layout, instead of letting Dorico do it.

As long as you don’t have local page overrides, in general you don’t need to think consciously about adding pages to Dorico - at least in the early stages of writing music etc. If a flow gets longer and therefore requires more space, Dorico will add it automatically, including moving flow headings etc along with the relevant flow’s new position.

The converse is true - in layouts with no page overrides, you shouldn’t need to delete pages either if flows get shorter.

1 Like

For those who doubt what I say and who would want to see a project, it is simple to verify. Do the very simply following project. Create a project with 4 flows and add say 4 pages per flow. Make sure you add page numbers for each page on every single page and add a title for each flow. Then go say back to flow 2 and add 3 more pages and see what happens to the added pages, they simply overflow to flow 3. IT IS A BUG I BELIEVE THAT NEEDS TO BE CORRECTED! I did not do “too much” to this project, in fact I did nothing except adding notes on a simple piano score in a project with a few flows!

Here’s the error. You don’t need to add pages. New pages will be added automatically as the music grows. And you should not add page numbers and titles to the pages themselves. You need to use the Master Pages (which should provide headers and page numbers by default).

Right-click on the page icons in Engrave mode, on the right hand side panel. Select “Remove Page Override” for each page with a red triangle, or you can Remove All in one go.


If you don’t want to post your project here, send it by private mssg or e-mail to Daniel with a link to this thread. Asking folks to create 12+ pages of music and stumble on what may be a quirk in your implementation is asking too much.

(Of course you never made a mistake and everything is a bug—possible, but probably not.)

Similar to what @benwiggy said, I’d recommend an experiment for you to try as well:

  1. Start a new project.
  2. Add four flows.
  3. Put a 4/4 time signature at the start of each flow, and add say 200 bars to each flow.
  4. See how many pages there are now automatically in the layout, and on which page each flow starts.
  5. Select the bar rest in the first bar of each flow and remove c. 180 bars - repeat for all flows.
  6. See how many pages there are now automatically in the layout, and on which page each flow starts.

What you should see is Dorico adding as many pages as required for each flow when you add bars, and removing however many pages are now in excess when you delete bars. The page numbers should also automatically update, meaning you don’t need to add page number changes manually. (If you added page numbers manually because they weren’t shown either on the First page - with the title and composer - or on pages you added manually, I wouldn’t recommend that in the long run. If you want page numbers on the First page with the title/composer, add a text frame with the page number token inside to the First master page.)


What you indicate is not related to what happened. I did a piano score and I added flow after flow and each time I thought the number of pages for the flow x would be enough so I added a new flow. However, later on only, I went back to a few flow and I discovered that I need to add say 1 extra page so I added say 60 extra bars. The problem? When I added these 60 extra bars in say flow 2, instead of seeing flow 2 grow by 60 extra bars, I saw the 60 extra bars overflow on the next flow 3!! So, I did not add pages, I just added extra bars to a flow. Now, I currently test the Dorico SE version that does not have the Engrave mode so I cannot do what you suggest.

Well, for the current version that I test called Dorico SE 3.5.12, when I add say 180 bars to say flow 2 and assuming I have in all up to flow 8, the extra bars overflow on flow 2 and the page numbers do not update properly, meaning they update but on flow 3 where the 180 bars have overflowed!!

Again, we really need to see the document to help you.

Do you mean that you don’t want Dorico to allocate more pages to flows when you add more bars? As in, if Flow 1 currently takes up 4 pages, you want any extra bars you add to Flow 1 to cause Flow 1’s bars to get narrower so that it still only fits on 4 pages?

I’m struggling to picture what might be wrong otherwise in SE, unless you added titles by double-clicking “1. Flow 1” etc directly on the page? How did you add flow titles - did you rename flows in Setup mode in the Flows panel, in the Project Info dialog, or by double-clicking and editing text directly on each page? If the latter, then you’ll have ended up with page overrides that you can only remove in Dorico Pro. Please feel free to share the project here so someone can do that for you, or start a completely new project and make sure you don’t double-click any text on the page - rename flows in Setup mode or Project Info.

Another thing you could try is just to delete the Full Score Layout and create a new one. Then ONLY change things in Layout Options to get it how you want.

Try using these layout options (Layout Options ->Page Setup → Flows):

Then repeat your experiment and tell us if you get a different result…

Here is a 5 min test to see if the problem I raised in this post is a BUG or not. Also a good practice to play with copy and paste to fill in pages quickly.

  1. Start Dorico, open a new project, select keyboard then piano and then, using the Write tab, add a 4:4 time signature, then add only quarter notes (any) on the first section of bars at the top.
    —Using the Write tab, select this first section of bars at the top, then copy the same notes on this first section of bars at the top to the remaining set of bars to fill in a full page to flow 1.
    —Then select the bars on this first page with the notes, then add 120 bars and then copy the first page of bars with their quarter notes, then paste this first page on the second page of bars. Repeat until you reach 3 pages.
    —Once you reach 3 pages for flow 1, delete the extra bars that make up page 4 and then close page 3 with a double vertical bar.
    —Now flow 1 has 3 pages and ends with a double vertical bar.
    —Now select the Setup tab, add flow 2. and repeat above to fill in flow 2 with 3 pages of the same notes that are in flow 1 the same way ending the 3 pages of flow 2 with a double vertical bar.
    It ends flow 2.
    —Repeat what you did in flow 2 but with flow 3.
    So go to the Setup tab, add flow 3 and repeat as above until you get also 3 pages for flow 3 and flow 3 also ends by a double vertical bar.

  2. Now the real test can begin to see if there is A BUG OR NOT.
    —Do Ctrl+Shift (vertical arrow)+L, select at the left Page Numbers, then select for the following two options, Page number in header and Flow p[age number in header, select show above flow heading.
    —Go to say flow 2 using the Write tab.
    —Add say 120 extra bars and see how these extra bars are added? Are they added in flow 2? NO!! These extra 120 bars overflow on flow 3 and see the mess with the page numbers too.

CONCLUSION: There is a BIG BUG to correct in Dorico on this matter. Why? I should add in flow 2 120 extra bars and see these extra 120 bars fully integrated in flow 2 and NOT overflow in flow 3 and not see also the mess with the page numbers.

Total of this exercise? 5 min for someone who knows how to do a copy and paste in an application and Dorico is not exception.

Do you see the problem, THE BUG?

I’m afraid I’ve just spent the five minutes following your steps, and I don’t see the problem. I’ll upload a screencast to Youtube in a few minutes (dependent on how long it takes to render and upload).

The resulting Dorico project is attached.
threeflows.dorico (513.9 KB)

1 Like

Like Leo, I’ve tried your steps and I’m able to add as many bars as I want to flow 2 (and any of the other flows) with no problems.

@MichaelIsGreat I strongly recommend if you’re encountering this problem reliably, share the project in which you’re encountering it - it’s likely there is an override or something that you can’t see in your version (SE) that someone else with Pro might. Once the situation is fully understood by all, you and all of us can all learn something from it.

1 Like

Here’s that video. I’m not sure what I’m doing differently to the OP.
(and apologies for getting tetchy at the end, but I seem to have wasted my time!)


There’s certainly no bug here I can see if you just do the same as everyone else. If there were one in something as basic as this, I’m sure others would have spotted it. As @benwiggy said, Dorico adds pages for you and you don’t change anything in the titles, flow page settings or whatever.