I cannot read REX2 files in Cubase 12

Sorry for my bad English.
REX2 files (.rx2) cannot be loaded in Cubase 12. I get an invalid file warning, and I can no longer load or paste them from mediabay either. if I initialize the Cubase settings, I can load them again, but after a while, I get a loading error. Does anyone know how to fix this?

1 Like

Got the very same issue.
It happened suddenly, without any noticeable changes in hardware or software configuration.
At first mediabay refused to preview rx2 files - just no sound at all. After cubase restart it totally excluded them from results list and drag-n-drop from windows explorer or loopcloud app started to display “medium not supported” error.
Any fiddling with “rex shared library.dll” did not help.
Only a reinstall did the trick. Not a reinstall over a current installation - it didn’t work, but the one with the proper uninstallation first.

1 Like

This seems to be an ongoing issue, is there any other way apart from full reinstall, mine was a full clean install on a brand new pc and I still can’t use rex files??? Steinberg really need to sort this.

Same problem here… Steinberg people… any fix???

.rex files in Cubase 12 - Cubase - Steinberg Forums

.RX2 audio file import works fine for me

Cubase Pro 12.0.52 on Win10 21H2.

Sorry don’t know how to help with this. Just checked mine and the preview in MediaBay wasn’t working for me (it had the last time I tried), but dragging the file into a project worked OK and heard sound when played.

Win10 Pro 1909 Cubase Pro 12.0.52

1 Like

On windows 10 (at least) make sure REX Shared Library.dll is inside “C:\Program Files\Common Files\Steinberg\Shared Components”


Working fine here too, Win10 Pro 22H2 Cubase Pro 12.0.52

Thanks, started researching this a little after this post. I found quite a few copies, and three different versions on my system, none of which were in the Steinberg Shared Components folder. I also searched my system for REX Shared Library_x64.dll and didn’t find it. The newest version I only found in my Reason 10 folder (version I copied that to the folder you pointed out, and rebooted. Still couldn’t preview, and also could not drag files into the Project window. So I deleted that version and copied in the 1.7.0 version (there is a large file size difference: 1.7 is 311 kB and 1.8 is over 2 Mb). Still can’t preview or drag files to project window. When I searched for the files, I have copies in the system32 and WOW64 folders, and the 1.8 is just in my Reason folder. According to the KVR thread below, one of the big changes in 1.8 was that it no longer needed to be installed to the system folders, so I didn’t try copying it there. This isn’t a big deal for me, although I do have a lot of REX file content from my Sonar Platinum and Reason installs and libraries, however I don’t work that much with samples. Still I’d like to see this issue resolved by Steinberg.

Found this thread on KVR that has some additional info: