I can't reactivate my license after OS reinstal

I’ve updated my windows and I can’t activate Cubase. I’ve been using it until 2 days ago and now I can’t anymore? Do licenses have an end?? Thats unfair. I’ve paid for my product. I’ve tried registering with eLicenser, with a new redeem…nothing! All I get is this message; “Currently, there is no valid Steinberg product license found on this eLicenser.” I want a solution or I’ll make my reclamation.

Please be calm. No one has cheated you, you have not lost your license.

Steinberg has a website which includes a knowledgebase – a series of articles to help with most issues a user might come across.

Since you do not mention which level of Cubase you own, I suppoe it must be LE, AI, or Elements. If that’s the case visit the support website and do a search for Reactivation.

I would appear you are trying to activate a license, which is only possible when you first make the purchase.

Thank you for your reply, Steve

Yes, it is a Cubase Elements key. I’ve already tried a reactivation but still doesn’t work. When I hit the reactivation button I it says “There is no Soft-eLicenser to reactivate.” and when I try to add one It says “Currently, there is no valid Steinberg product license found on this eLicenser.”

Please upload a screenshot of your elicenser control window.

If there’s no SeL present, you might be able to create one by running an install from the Download Assistant, since that utility also updates other things during its process.

Of course, you can always search the knowledgebase. For example, a seach there for soft elicenser yeilds the following result:


Where the top result is actually about what you are asking.

1 Like

That’s the SeL that’s been generated after I downloaded cubase with the download assistant. It doesnt work

This function should work. Since you don’t say precisely what you did, step per step, I can’t really add anything to what I’ve said.

I just downloaded the download assistant. On “my downloads” section there was the cubase 11 elements just as it did when I first installed it. I’ve installed all the included products and then gone to eLicenser. It has appeared this SeL. I’ve registered it on My Steinberg and that’s where steinberg site says: " Your eLicenser with the number 9188368311 0FB------- was successfully registered.
Currently, there is no valid Steinberg product license found on this eLicenser."

When you do the reactivation process you should get a code which can be applied to that Soft Elicenser

I’ve already tried it, Steve, as I said. There is no response

1 Like

I’m not sure what you mean. What response did you not receive?

I hit the reactivación button and It sayas I dont have any key. Then I copy the SeL on the screenshot I shared here and It does nothing. It says the dame thing: that key has no product.

I think we have a vocabulary/language difficulty. Can you post screen shot of the website where you request the reactivation code?

Did you do this?

Yes. I posted another screenshot only a few minutes after that one. As you can see, the eLicenser is successfully registered but with no valid Steinberg product license on it, as it’s shown on the screenshot. Here I post another screenshot of the download assistant with Cubase Elements 11 on my products. I think there must be some kind of error on my Steinberg account that causes my license not to be shown or activated or reactivated. For some reason My Steinberg does not recognize me as owner

I don’t know what’s going on then, sorry.

Could you just verify that the license is in your account? Please understand, I can only go by what you show or tell me.

A screenshot of your My products page might be helpful (erase any personal info, this is a public discussion)
this page:

I’ve recently changed the e-mail associated to My Steinberg account. I think that the problem may be related to this, but in any case this shouldnt be a problem. I mean, why wouldn’t I use that avilable option? If Steinberg allows me to change the e-mail…should I lose the product I paid for?

The software tab, like in my screenshot.

there’s nothing on the software tab. I can’t understand. My cubase license just disappeared from my steinberg. I have cubase working on another pc and I’ve been using it on this one just 3 days ago

I don’t understand what you mean with that. There’s some kind of error going on here. I’ve entered my cubase 11 elements key on last september and I’ve been using it since then. I hope you’re not meaning that I’m not telling the truth or something like that.