iC Pro & iPad v1?

This is a repost from the iC Pro forum… not much traffic there :slight_smile: Thanks for the help.

I just jumped on the Cubase bandwagon from Studio One and having found that my Faderport is basically useless in 64 bit mode I decided to purchased the iC Pro version for an iPad v.1 hoping it might work since IOS 5 is supported.

App Installs, have the SKI app installed on my Mac Pro… iC Pro will open up but only to a black blank screen.

Both iPad and Computer recognize it… is this an iPad 1 limitation or a common issue with iC Pro?

I was planning on upgrading to an iPad 2 or 4 when I noticed the app was specc’d to include IOS 5, so I thought I’d give it a try on hardware I already owned… glad I didn’t get the Android Tablet I was planning on a few months ago for this app!

Thx for the help!

big~C

Hi,

What iOS version is installed on your iPad, please?

Faderport is working fine here on Mac OS X Cubase Pro 8.5 64-bit.
Make sure you are using the Faderport in native mode. Just hold down the “Stop” button and after a few seconds press the flashing “Output” button. Now you can use the Faderport with the plain “Mackie Control” remote device.

It might be a hardware limitation with V1 as I recall seeing complaints about this on the forums. I’ve used IC Pro successfully with both V2, V3 and now an Air2. Curiously, when you launch the app, do you see your Mac appear in the “select your computer” screen or does the app launch to just a black screen?

BTW - I feel your pain with the dedicated forum for this app - it’s appallingly mismanaged.

Thanks for the help!

“SuStudio” your forum name reminded me of Phil Collins’ “Susudio”… now I’ve not heard “No Jacket Required” in a looong time :slight_smile: “Take Me Home” was one of my favorites for at least 1 decade :slight_smile:

I’m using IOS 5 on a v1 iPad. Everything about the bootup appears as it should be but as soon as the splash-page for iC Pro connecting boots up it turns black (that backlit black where you know the program is engaged but nothing is happening).

The iC Pro recognizes and see’s my Mac and then just goes black. It must be a hardware limitation. Thanks for the reply on the iPad’s that worked for you, I may just pick up a used v2 64 bit just for this App, incredibly inexpensive solution.

Thanks also “tedannemann”, I’ll try your solution when I get home, I couldn’t find it in Presonus’ manual. If that works, I’m back in the game!

Anyone using Arts|Muted Lemur overlays? If so what are your thoughts of that vs iC Pro?

Thanks everyone, truly appreciate it.

big~C

Thanks for the tip, got it to work. The only curiosity is that the Master input and output don’t work… limitation within Cubase and Mackie protocol?

I have the same problem with the V-Control Pro 2 app. Is there some option you need to select to allow this parameter to sync? Otherwise it’s working great.

Thanks.

Hi,

Mackie Control doesn’t Control Input Channels. You can Control one Output Channel. On Mackie Control protocol, this is the PitchBend messages send on Channel 9.

As Martin mentioned, the Mackie Control protocol isn’t working to its full potential with the Faderport.
Some people do have better results with the “Mackie HUI” protocol - in this case without the native mode. Just plug in the Faderport and try the “Mackie HUI” protocol (delete the Mackie Control device first of course).
However it seems that different firmwares and systems bring different results with the Faderport:
https://www.steinberg.net/forums/viewtopic.php?t=72878

Thanks for the tip. I’ll give it another try. That is how I did have it set up (and how Presonus recommended) but it was as mental as a Boston Bulldog on Starbucks. :slight_smile:

For now the transport, pan, and fader functions are working for everything minus the master output. A good start.

I think this combined with the iC Pro will work for now. I’d like to use the AI knob function on the CC121 maybe I can find a solution for that without spending the $430 for the controller.

Ultimately the Raven MTi2 is the near future solution I think. But this will at least get me somewhat tactile again.

Anyone been able to get the faderport to work with the Master out?

Thanks again,

Big~C

duplicate…

I finally plugged the Faderport in… All I wanted was the basic Play/Stop/Rec…

But I noticed that the Transport Meter was showing a steady pulse every second or so.

Traced it to the Faderport… disconnected it and all is well again.

Win10-64

Hi,

Mackie HUI (based on the specification) is sending this kind of pulses to inform the DAW “I’m still alive”.

thanks for the reply… I tried to get rid of the pulses showing in the meter but with no luck… the only way was to disconnect the Faderport

As Martin mentioned this is a normal behavior with the Faderport and the Mackie HUI protocol.

My experience as well.

Got a company iPhone 6 yesterday and checked out iC Pro using it… What a great app! I love the key command buttons. Well thought out even for the smaller real estate of the iPhone.

Time to get another iPad. I had to sell most of my high end gear a few years ago and am finally back in the place to reacquire, so every purchase matters at the moment. Glad my 09 Mac Pro is still kicking along :slight_smile: Equator Audio Monitors and AKG XLSII are next. Miss my Metric Halo though! My old Focusrite still sounds good enough to do the trick at the moment.

Thanks again for the help… amazing that we can have this level of tactile control for a couple hundred dollars now. I remember when my used Mackie Universal was a steal at $800 used.

Hmm…

Well I just bought an iPad Air 2 and it won’t sync up with Cubase… iC Pro recognizes my Mac Pro but I seem to have the spinning ball of fun instead.

After about 30 seconds it stops…

Odd that my phone would work just fine this morning. (I’ve also ensured my iPhone iC Pro was not open).

Thanks!

UPDATE: Just powered the iPad off/on and it she sync’d up with Cubase 8.5. Nice!