iCON QCon Pro G2 (+Extender) MIDI Remote Script

Tx for the heads up Thomas and the related thread.

The more I read about USB connectivity issues the more I suspect this as a probable cause or, at the very least, not helping the situation. I have 4 USB devices (2 x Qcon Pro G2 [both mains powered], a Komplete Audio 6 interface and a Komplete Kontrol keyboard) all going through one USB powered hub into one USB host controller in my PC. This just seems like a bottleneck of endpoints being reached but I am only guessing.
I’ve ordered a PCI expansion card with 4 USB ports for my PC which gives each USB port its own host controller and if it all works I will return with good news. If not then the device will return … to Amazon :slight_smile:

I don’t think this is the issue. Even USB 1.0 has much higher bandwidth than what MIDI would require.

Also, on my side the very same device doesn’t suffer any disconnect when using it a s a Generic Remote or Mackie Control.

This is very true, mine doesn’t either.

There are too many times in the past for me to eliminate USBs as not being part of the cause. Bandwidth is not an issue, I agree, endpoints could be and power also but it could also be the midi-remote script. I hate USB Hubs anyway so even just eliminating that from my setup is still a plus for me.

No surprise, but my USB experiment did not cure the problem.

So back to Mackie Control and a quieter life :slight_smile:

How the heck do I install this script? Isn’t it supposed to be just a .js file I load from the MIDI Remote editor? I don’t see any .js file in GitHub. Can someone please explain how to install use this script to a non-programmer?


Go to the github page:

Then scroll down until you reach the “setup” instructions. You are allowed to read the whole text :wink:



1 Like

Thank you

Hello ! Thank you for your work bjoluc.
Is there any chance we could see auto select bank with the UF1 in one script ?



1 Like

Hi. Having been frustrated with no autobanking for years, I was really pleased to see this script being worked on. Thank you!

I have one little issue in setting up, I have one G2 main and 2 extenders and, by editing the script to read [“main”, “extender”], I can get the main and 1st extender working, with glorious autobanking, but I can’t seem to work out what to put in the script to also get the second extender to be recognised? I edited the script to read [“main”, “extender”, “extender”] but that just prevents any of the units to be recognised at all. In fact with this edit Nuendo doesn’t even see there is a script. Any ideas?

Using Nuendo 13, Windows 11



Update! Well I’ve managed to get it working for the main + 2 x extenders, although i’m not really sure how! So, I hope I don’t need to do it again anytime soon! Now just need Steinberg to sort out control surface follows track visibility issue…

1 Like

Hi @Simon_G, using more than one extender currently requires a manual setup via the “+” button in the MIDI Remote pane. I’ll fix this in the next release!

Yes, I’m really looking forward to this…


A couple of issues but firstly a really big thanks, the scroll to selected is worth it on its own!

This is setup in Windows 11, Nuendo 13 (up to date) and an Icon Pro G2 and 2 extenders.

My main issue is around plugin parameters. When I hit ‘Inserts’ the plugin’s parameters only seem to select when a second plugin is put ‘in focus’. For example I’ll open insert 2, ProQ 3, and nothing appears even though the plugin has ‘focus’. If I then open a plugin in a second slot, which takes the focus, now the parameters show up, but for the previous plugin, in this case ProQ 3. This seems to be consistent behaviour when moving through several inserts on a track. Also, even though I have moved focus to a new plugin, with the parameters now showing for the previous ‘in focus’ plugin, those parameters will happily control that previously ‘in focus’ plugin, if that makes sense. In essence the plugin parameters are exposed on my control surface for the previously ‘in focus’ plugin, and continue to control the parameters of that previous plugin.

Secondly there seems to be a reset occurring with my control surface at regular intervals when Nuendo sits ‘idle’, resulting in my faders slamming to zero and then back up to their previous position. This seems to happen after a certain amount of time, but I haven’t been able to time it - it’s minutes to an hour at a guess)

Thirdly, I find that often button presses are very very slow to engage, if they engage at all.

Fourthly (and this is I think related to the plugin parameters issue outlined above) is it possible to keep the Scub function and the Fader Flip functions working? They seem to activate only intermittently or as a delayed action, if that makes sense?

Sorry for pointing out issues, but I hope it helps.

Thanks again for all your hard work, it is really appreciated.



1 Like

I see this issue has also recently shown up on the X-Touch (+extender) thread.

I was just doing a little more poking around and it seems like pressing the flip button then stores the button press, but doesn’t act on it till there is a second input (opening a different plugin), which definitely seems tied to the plugin focus issue above. The Scrub button seems to need this to happen the first time it’s button is pressed, but then afterwards seems to work as expected, unlike the Flip button.

It all seems like the button presses are being held in a buffer of a single press or something?

Hope this helps,


Hi @Simon_G, thanks for reaching out! Can you check whether the issues persist when disabling and re-enabling the controller script?


I think I may have found part if not all of the cause. I have an X-Touch Mini set up as a channel strip controller, and open and close my plugins via that. This does open them with focus, but doesn’t register them as such, as per previous, until I open a second plugin etc. etc. But, if I just hit the ‘e’ button with my mouse, on the channel strip insert on the project page, to open the plugin, this again give the plugin focus, but now will instantly open up its parameter’s to the QCon’s ‘inserts’.

However if I hit the ‘e’ on a channel’s insert to open the plugin whilst in the mixer window, the plugin parameter’s won’t switch to that plugin (even though it now has focus) unless the channel the plugin is inserted on is actually selected first.

So, there is a work around by manually using the mouse to open the plugin, but that is less than ideal for my workflow as having the X-Touch mini set up as a channel strip controller is a real quality of life improvement for me.

Fader flip also activates on first mouse click to open/edit a plugin, rather than buffering a click when opened via an external controller.

I did notice that when clicking on the insert ‘e’ with the mouse the channel strip is first, briefly, focused and then the focus is thrown onto the now open plugin, which may be why the parameters are instantly exposed, whereas using a controller to open the plugin doesn’t first throw focus to the channel strip before it jumps onto the plugin, therefore reducing the focus pulls from 2 to 1 and maybe that’s why everything seems to lag a button press behind? Does that make any sense?

And this was after disabling and enabling the script (which I redownloaded and reinstalled yesterday)



Hi @rabaeus, I almost forgot to mention: v1.10.0 includes a dedicated UF1 script!

Hey @Simon_G,
I have have finally included port detection for setups with more than one extender in v1.10.0 so this should work out of the box now!
I’m aware of the insert effect focus issues when plugins are brought up via anything but the mouse. Sadly, this is fully up to Cubase – in the script, I just say “followPluginWindowInFocus():confused:

Hi there bjoluc,

thanks very much for doing what you can, as always it’s much appreciated. I have worked out that if I just have a single plugin opened at a time, via my controller, if I open/close/open the plugin it gains focus for your script. Now I’ll just have to see what bit of muscle memory proves quicker, the 3 click controller, or just using my mouse.



1 Like

Fantastic Bjoluc ! Very much appreciated, I tried it today and works like a charm. You’re a king.

1 Like

This is awesome, thanks bjoluc you’re a legend.
Installed G2 plus 2 extenders and followed instructions with no problems.

Only minor issue observed that holding “shift” button the “left” and “rewind” buttons also light up. Doesn’t seem to affect functionality though.

Other observation is I don’t see the “Layer 2” button being used. Maybe this is hardware specific but in Mackie protocol i have some buttons with 3 options depending on using “Shift” or “Layer 2”.

In terms of enhancements we do need Steinberg to add the channel visibility option to MR, it’s a major benefit of using a mixing controller.

I particularly love now being able to flip the Name and Pan values. Just seems so obvious with pan below.
Is there a way of setting this by default in the script?

Also the pot encoder resetting pan to 0 is another great addition.

There’s a few buttons I’d been able to change in iCon iMap - e.g. bank 1 channel buttons I dont really need so was using as Page buttons.

Ideally it would be great to move some of these buttons around or use for something new. But I note in MR it’s not possible to remove factory button assigns.
How possible is it to change some of these, or free them up, via the script?

1 Like

Further to the above, I’ve found it is possible to apply secondary mapping to the F1-F8 keys by assigning using the “Layer 2” button.

So with regards this being listed as a drawback, for the G2 this is still possible due to this extra button.